Advanced Host Controller Interface (AHCI) and Redundant Array of Independent Disks (RAID) on HP Compaq dc7800 Business PCs

Using Intel Matrix Storage Manager
RAID migrations ............................................................. 20
   Migration to RAID 1 from two non-RAID hard drives using
   Intel Matrix Storage Console ........................................... 20
Degradation ................................................................. 22
   Migration to RAID 0 from two non-RAID hard drives using
   Intel Matrix Storage Console ........................................... 23
   Migration to RAID 0 from three non-RAID hard drives using
   Intel Matrix Storage Console ........................................... 24
   Migration to RAID 5 from three non-RAID hard drives using
   Intel Matrix Storage Console ........................................... 28
   Migration to Matrix RAID 5 and RAID 0 from three non-RAID hard drives using
   Intel Matrix Storage Console ........................................... 32
   Migration to RAID Matrix Mode (0 + 1) from two non-RAID hard drives using
   Matrix Storage Console .................................................. 41
Installation ................................................................. 41
Language support table .................................................. 42
Introduction

This whitepaper covers two drive technologies that are provided on the HP Compaq dc7800 Business PC products, AHCI and RAID. This whitepaper provides a basic overview of AHCI and RAID technology, supported factory configurations of HP Compaq dc7800 Business PCs, other supported RAID configurations, and basic instructions on how to migrate non-RAID to RAID configurations in the field. HP also provides a Smart IV Hard Drive technical whitepaper for HP Compaq dc7800 Business PC products on HP.com.

Advanced Host Controller Interface (AHCI) functionality provides customer benefits such as NCQ, which is intended to increase the performance of the hard disk drive. HP Compaq dc7800 Business PC products provide support for AHCI in single and multiple drive configurations.

RAID (Redundant Array of Independent Disks) is a category of hard drives that employ two or more drives in combination for fault tolerance and performance. Initially used with servers, desktop PCs are increasingly using RAID by adding a RAID controller and extra IDE or SCSI disks. Newer system boards often have RAID controllers.

RAID technology takes advantage of Serial Advanced Technology Attachment (SATA) and the integration of RAID into the Intel Q35/ICH9-D0 chipset. This white paper provides a basic overview of RAID technology, supported factory configurations of HP Compaq dc7800 Business PCs, other supported RAID configurations, and basic instructions on how to migrate non-RAID to RAID configurations in the field.

Basics of AHCI and RAID Technology

Definitions

<table>
<thead>
<tr>
<th>Table 1 Basic AHCI and RAID Definitions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AHCI</strong></td>
</tr>
<tr>
<td><strong>ATA</strong></td>
</tr>
<tr>
<td><strong>BIOS</strong></td>
</tr>
<tr>
<td><strong>Chipset</strong></td>
</tr>
<tr>
<td><strong>HDD</strong></td>
</tr>
<tr>
<td><strong>ICH</strong></td>
</tr>
<tr>
<td><strong>IDE</strong></td>
</tr>
<tr>
<td><strong>INF</strong></td>
</tr>
</tbody>
</table>
To take advantage of single drive AHCI support, a change is required in F10 setup. To run a single drive configuration on HP Compaq dc7800 Business PCs in AHCI mode:

1. Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.
2. Press F10 as soon as the monitor light turns green.
   If you do not press F10 at the appropriate time, you must restart the computer, and then press F10 again to access the utility.
3. Select your language from the list, and then press Enter.
4. Use the arrow keys to select Storage.
5. Use the down arrow key to select Storage Options, and then press Enter.
6. Change SATA Emulation from IDE to RAID.

**NOTE:** Make sure the Intel Matrix Storage driver is loaded in the SW image prior to making the F10 setup change. The operating system will not boot without this driver. The dc7800 factory SW image already contains this driver. This driver is also provided as a softpaq at www.hp.com.

Single Drive AHCI Configurations are supported on the dc7800 SFF and dc7800 CMT products.
Basic RAID Types

This section provides a brief explanation of the supported RAID configurations for HP Compaq dc7800 Business PCs.

**RAID 0 with two hard drives (Striped)**

Even though HP supports RAID 0, it is not the recommended configuration for business PC users. Lack of redundancy causes less than half the reliability of a single hard drive system since the Mean Time Between Failure (MTBF) of RAID 0 is equal to the MTBF of an individual drive, divided by the number of drives.

**Table 2** RAID 0 with two hard drives (Striped)

<table>
<thead>
<tr>
<th>First Disk</th>
<th>Second Disk</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Segment 1</td>
<td>Data Segment 2</td>
</tr>
<tr>
<td>Data Segment 3</td>
<td>Data Segment 4</td>
</tr>
<tr>
<td>Data Segment 5</td>
<td>Data Segment 6</td>
</tr>
<tr>
<td>Data Segment 7</td>
<td>Data Segment 8</td>
</tr>
<tr>
<td>Data Segment 9</td>
<td>Data Segment 10</td>
</tr>
<tr>
<td>Data Segment 11</td>
<td>Data Segment 12</td>
</tr>
<tr>
<td>Data Segment 13</td>
<td>Data Segment 14</td>
</tr>
<tr>
<td>Data Segment 15</td>
<td>Data Segment 16</td>
</tr>
</tbody>
</table>

In the previous table, each “Data Segment n” represents a group of data, known as a strip. In this case, each row represents a stripe. RAID 0 represented in the table above shows how information is segmented, made into chunks or strips, and stored across the stripes of the hard drive members of this RAID volume.

To better illustrate the concept of RAID 0 and striping, the following graphic shows how a sequence of data “ABCD...” is stored in a RAID 0 mode. In this example, each letter represents a segment or strip. The graphic shows how the various pieces of the information go to different hard drives. If any segment of RAID 0 fails, all information from all members is lost.
At a higher reliability cost with faster performance, the HP Compaq dc7800 Business PC Convertible Minitower also allows for RAID 0 with three hard drives. RAID 0 with two or three hard drives is a supported configuration.

RAID 0 with three hard drives is shown in the following figure:

**Figure 1** Performance - RAID 0 with two hard drives

At a higher reliability cost with faster performance, the HP Compaq dc7800 Business PC Convertible Minitower also allows for RAID 0 with three hard drives. RAID 0 with two or three hard drives is a supported configuration.

RAID 0 with three hard drives is shown in the following figure:

**Figure 2** RAID 0 - Three hard drives
RAID 1 with two hard drives (Mirror)

Because it is a very cost-effective way to increase system storage reliability and a great value proposition, RAID 1 is the only RAID configuration that HP preconfigures for HP Compaq dc7800 Business PCs. RAID 1 provides high availability with minimal performance impact, as well as greater reliability compared to a single hard drive configuration.

RAID 1 has redundancy and hence is a true RAID. It more than doubles reliability because the MTBF of RAID 1 is equal to the MTBF of an individual drive multiplied by the number of drives (2). In other words, the probability of one hard drive failure on a given day is the square root of that same probability. Hypothetically, if the chances that a single hard drive fails is 1:2000, with RAID 1 the chance that both of your hard drives fail is 1:4,000,000.

Mirroring, segmentation, and striping have no real meaning in RAID 1. In the table and graphic, the data is arranged in rows for representation of different pieces of data.

Table 3 RAID 1 with two hard drives (Mirror)

<table>
<thead>
<tr>
<th>First Disk</th>
<th>Second Disk</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Segment 1</td>
<td>Data Segment 1</td>
</tr>
<tr>
<td>Data Segment 2</td>
<td>Data Segment 2</td>
</tr>
<tr>
<td>Data Segment 3</td>
<td>Data Segment 3</td>
</tr>
<tr>
<td>Data Segment 4</td>
<td>Data Segment 4</td>
</tr>
<tr>
<td>Data Segment 5</td>
<td>Data Segment 5</td>
</tr>
<tr>
<td>Data Segment 6</td>
<td>Data Segment 6</td>
</tr>
<tr>
<td>Data Segment 7</td>
<td>Data Segment 7</td>
</tr>
<tr>
<td>Data Segment 8</td>
<td>Data Segment 8</td>
</tr>
</tbody>
</table>

In the previous table, each “Data Segment n” represents a group of data, known as a strip. In this case, each rows represent a stripe. This table shows how information is duplicated in both hard drives. The size of the strips is mostly irrelevant and not a configurable option.

To better illustrate the concept of RAID 1 and mirroring, the following figure shows how a sequence of data “ABCD...” is stored in a RAID 1 volume. In this example, each letter represents a data segment. The graphic shows how the various pieces are replicated for both of the hard drives; hence, if any one member of the RAID 1 volume fails, the information is kept in the surviving members. After a hard drive failure, the user interface sends a notification so the failed hard drive can be replaced. No user information is lost in this scenario.
RAID 5 with three hard drives

RAID 5 has been used in servers for many years and is one of the most common types of RAID. RAID 5 uses striping with parity data in distributed blocks across all member disks. Therefore, the mass storage controller can simultaneously write new information to two hard drives and parity information to the third hard drive, so if one hard drive fails, the RAID controller can rebuild all the information after the volume degradation occurred. Hence, RAID 5 with three hard drives has similar performance to RAID 0 with two hard drives, and the reliability of RAID 1 with a minimum of three hard drives.
Table 4 RAID 5 with 3 hard drives (Parity)

<table>
<thead>
<tr>
<th>First Disk</th>
<th>Second Disk</th>
<th>Third Disk</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Segment 1</td>
<td>Data Segment 2</td>
<td>Parity for 1 and 2</td>
</tr>
<tr>
<td>Data Segment 3</td>
<td>Parity for 3 and 4</td>
<td>Data Segment 4</td>
</tr>
<tr>
<td>Parity for 5 and 6</td>
<td>Data Segment 5</td>
<td>Data Segment 6</td>
</tr>
<tr>
<td>Data Segment 7</td>
<td>Data Segment 8</td>
<td>Parity for 7 and 8</td>
</tr>
<tr>
<td>Data Segment 9</td>
<td>Parity for 9 and 10</td>
<td>Data Segment 10</td>
</tr>
<tr>
<td>Parity for 11 and 12</td>
<td>Data Segment 11</td>
<td>Data Segment 12</td>
</tr>
<tr>
<td>Data Segment 13</td>
<td>Data Segment 14</td>
<td>Parity for 13 and 14</td>
</tr>
<tr>
<td>Data Segment 15</td>
<td>Parity for 15 and 16</td>
<td>Data Segment 16</td>
</tr>
<tr>
<td>Parity for 17 and 18</td>
<td>Data Segment 17</td>
<td>Data Segment 18</td>
</tr>
</tbody>
</table>

In the previous table, each “Data Segment x” represents a strip. A stripe is made with strip “Data Segment x”, “Data Segment y” and strip “Parity for x and y.” Notice that the strip “Parity for x and y” is used to store the required information to recreate the data if any one of the RAID volume members is compromised.

To better illustrate the concept of RAID 5 (parity based RAID), the following figure shows how a sequence of data “ABCD...” is stored in a RAID 5. In this example, each letter represents a segment or strip. The figure shows how the various pieces of the information go to different hard drives, hence if any one member of the RAID 5 fails, the information from all members is not lost.

Figure 4 RAID 5 with three hard drives
Intel Matrix Storage Technology

This technology provides protection against data loss from a hard drive failure and faster access to digital photo, video, and music files by supporting NCQ as well as RAID 0, 1, 5, and 10. Matrix RAID enables two RAID levels to be combined for data loss protection plus performance. Intel Matrix Storage Technology was previously known as Intel Application Accelerator 4.x and Intel Application Accelerator RAID Edition 3.x.

Figure 5 Matrix RAID combining reliability and performance with the same two hard drives

Using Intel Matrix Storage technology, you can configure the HP Compaq dc7800 Business PC Convertible Minitower with two RAID volumes using three hard drives - a RAID 0 volume for ultimate performance, and a second volume as RAID 5 with reliability and performance improvements.
Configurations

Recommended configurations

HP recommends factory configurations of the preinstalled RAID offerings for HP Compaq dc7800 Business PCs.

The preinstalled RAID offering is a RAID 1 volume of two identical SATA hard drives with the following customer choices:

- Two SATA 80GB 7200RPM drives
- Two SATA 250GB 7200RPM drives
- Two SATA 500GB 7200RPM drives
- Two SATA 80GB 10000RPM drives
- Two SATA 160GB 10000RPM drives
Hardware and firmware support is present to take advantage of the future Microsoft Vista operating system. Intel Matrix Storage Technology RAID software support for Microsoft Vista will be available at a later date.

HP Compaq dc7800 Business PCs are based on the Intel Q35/ICH9-DO RAID chipset, which is a combined hardware and software RAID solution. The Intel ICH9-DO SATA mass storage controller allows all drives to operate in IDE or RAID SATA modes. Each mode of the controller means a different PCI controller, with different device ID, class code, and driver support.

**NOTE:** HP recommends and only supports Microsoft’s IDE driver stack based on the ATAPI.SYS driver for HP Compaq Business PC products including all supported RAID configurations.

**WARNING:** The PCI Device ID of the mass storage controller changes after changing IDE mode. Changing the BIOS from IDE mode to RAID mode is the equivalent of connecting the hard drives to a new add-on RAID storage controller. The installed operating system on the hard drive is unaware of this new mass storage controller. If the operating system does not have the RAID drivers enumerated and PnP for the RAID controller, the operating system will fail to boot (blue screens) when Microsoft XP or Microsoft Vista attempts to boot.

Table 5 RAID Drives

<table>
<thead>
<tr>
<th>Mode</th>
<th>Purpose</th>
<th>Minimal HDD Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAID 0</td>
<td>Striped for Performance.</td>
<td>2</td>
</tr>
<tr>
<td>RAID 1</td>
<td>Mirrored for Protection.</td>
<td>2</td>
</tr>
<tr>
<td>RAID 5</td>
<td>Parity for Accuracy.</td>
<td>3</td>
</tr>
<tr>
<td>RAID 0 + 1</td>
<td>Mirrored and Striped.</td>
<td>4*</td>
</tr>
<tr>
<td>Intel’s Matrix Technology</td>
<td>4 logical drives on 2 physical disks, to emulate RAID 0 and 1.</td>
<td>2</td>
</tr>
</tbody>
</table>

* Not supported on HP Compaq dc7800 Business PCs.
NOTES: The following notes are important for RAID configuration:

- RAID 1 is the only RAID configuration that HP Compaq dc7800 Business PC products offer as factory configurations.
- The preconfigured systems:
  - Are complete RAID systems.
  - Have both drives installed.
  - Have the necessary Option ROM configuration.
  - Are preloaded and preinstalled with all required Intel software.
  - Include a preinstalled operating system that is mirrored mode out of the box.

HP Backup and Recovery interactions
After enabling and configuring RAID, restore the system using backup CDs. After completing the restore, reinstall HP Backup and Recovery. These steps are necessary for the F11 restore to function properly.

HP also recommends keeping the default options in the RAID Option ROM and in the Windows RAID application. Options like “chunk” size for changing the size “stripe” size have more history in their defaults settings.

Additional technical information will be provided in the future for customers who want to add RAID software image deployment capabilities.

Other supported configurations
HP Compaq dc7800 Business PC products support two other RAID configurations:

- Two hard drive configuration.
  - Two equal size/type SATA hard drive RAID configurations in RAID 0 or RAID 1 or Matrix Mode of RAID 0 and RAID 1.
  - Maximum of two SATA optical drives (on HP Compaq dc7800 Business PC Convertible Mini- towers).
- Three hard drive configuration (only on HP Compaq dc7800 Business PC Convertible Minitowers).
  - Three equal size/type SATA hard drive RAID configurations in RAID 0 or RAID 5 or Matrix Mode of RAID and RAID 5.
  - Maximum of one SATA optical drives.

Unsupported configurations
HP Compaq dc7800 Business Desktop PC products only support the best user experience and highest possible reliability. As a result, HP does not support the following combinations of RAID hard drives:

- Different sizes
- Different speeds (5400 rpm, 7200 rpm, etc)
- Old and new technologies (SATA 1.5 GB and SATA 3.0 GB)
- NCQ hard drives and non-NCQ drives
• Different cache size
• RAID combinations of hard drives with any operating system other than Microsoft XP Pro (SP2) using Microsoft’s IDE driver stack based on ATAPI.SYS

Configuring RAID on non-factory preinstalled configurations

The remaining sections of this white paper describe steps to set up supported RAID configurations where customers have not purchased factory preinstalled RAID configurations.

Enabling RAID through F10 System BIOS

1. Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.
2. Press F10 as soon as the monitor light turns green.
   If you do not press F10 at the appropriate time, you must restart the computer, and then press F10 again to access the utility.
3. Select your language from the list, and then press Enter.
4. Use the arrow keys to select Storage.
5. Use the down arrow key to select Storage Options, and then press Enter.

![Hewlett-Packard Setup Utility](image)

6. On the Storage Options menu, use the down arrow key to select SATA Emulation.
7. Press the right arrow key until RAID displays, and then press Enter.
8. To apply and save changes, select File > Save Changes and Exit.
   • If you do not want to apply your changes, select Ignore Changes and Exit.
   • To reset to factory settings, select Set Defaults and Exit. This option restores the original factory defaults.
CAUTION: Do NOT turn the computer power off while the ROM is saving the F10 Computer Setup changes as the CMOS could become corrupted. Only turn the computer off after exiting the F10 Setup screen.

Configuring RAID Option ROM

You can only access Computer Setup at system startup. To access the Computer Setup Utilities menu and enable RAID:

1. Turn on or restart the computer by clicking **Start > Shut Down > Restart the Computer**.

2. Press **Ctrl + I** repeatedly as soon as the monitor light turns green to enter the RAID configuration utility. If you do not press **Ctrl + I** at the appropriate time, you must restart the computer, and then press **Ctrl + I** again to access the utility.

   The Intel Matrix Storage Manager screen (RAID Option ROM) displays briefly during boot up. The RAID configuration utility is English only. To configure RAID in other languages, use the Windows-based RAID configuration utility.
Configuring RAID Volume using the Option ROM

1. Once you are in the Option ROM, if there are no previous RAID member hard drives, press Ctrl + I to enter the RAID configuration utility.
2. With **Create RAID Volume** selected, press **Enter** to access the Create Volume screen.

3. Select or enter the desired **RAID Level**. Use the information on the bottom half of the screen if necessary.
4. Use the arrow keys to scroll to **Create Volume**, and press Enter. The following screen appears.

**CAUTION:** All data on the selected disk will be deleted.

![Intel Matrix Storage Manager](image)

**Notes for operating system installation**

- After creating a RAID disk volume in the option ROM, you can install the operating system.
- HP provides a download for the required F6 disk for Windows XP CD installation.
- Customer-created images MUST account for the RAID controller.
- Failure to install and enumerate the RAID driver after enabling the RAID controller (with or without creating a volume) will result in a Windows boot failure (blue screen) for inaccessible boot device.

**WARNING:** The PCI Device ID of the mass storage controller changes after changing IDE mode. Changing the BIOS from IDE mode to RAID mode is the equivalent of connecting the hard drives to a new add-on RAID storage controller. The installed operating system on the hard drive is unaware of this new mass storage controller. If the drivers are not available, enumerated, and PnP for this new controller, the operating system blue screens in Microsoft XP and Microsoft Vista.

Additional technical information will be provided in the future for customers who want to add RAID SW image deployment capabilities.
Intel Matrix Storage Manager software installation

This section of the paper focuses on how to configure RAID using Intel Matrix Storage Manager software. The configuration steps are for application usage and supported RAID migrations.

Console Software Installation

The Intel Matrix Storage Manager Software is preloaded in all HP Compaq dc7800 Business desktops at “C:\Intel\Intel MSM”. To execute the software, run the setup.exe file. You can also get this software from the HP and Intel Web sites.

1. Select Start > All Programs > Intel(R) Matrix Storage Console.

Welcome to the setup for the Intel(R) Matrix Storage Manager.

This setup program will install Intel(R) Matrix Storage Manager onto your computer. It is strongly recommended that you exit all Windows programs before continuing setup.

2. Click Next.
3. Read the driver agreement. If you agree, click Next.
4. Read the License Agreement. If you agree, click Yes.
5. Select or browse to a destination folder, and then click Next.
6. The Select Program Folder window suggests a program folder with Intel Matrix Storage Manager highlighted to add the program icons.
7. Click Next to finish the installation.
8. Click Finish to close the setup.
9. Restart the computer.
Using the Intel Matrix Storage Console interface

1. Click **Start > All Programs > Intel Matrix Storage Manager/Intel Matrix Storage Console** to open the Intel Matrix Storage Console application. The Intel Matrix Storage Console starts in basic mode by default and has three main menus.

   **NOTE:** The report the applications generate is very comprehensive. You can view the report at **View/System Report**. The reports contains information about the driver, operating system, language, and hard drive.

2. Select **View hard drive and volume Status.**

![Image of Intel Matrix Storage Console interface](image)

3. For a more detailed view of the RAID controller, click **View > Advanced Mode.**

   ![Advanced Mode view](image)

   In Advanced Mode, the Intel Matrix Storage Console also includes the **Actions** menu. Use this menu to access the advanced features of the RAID solution.

**RAID migrations**

**Migration to RAID 1 from two non-RAID hard drives using Intel Matrix Storage Console**

**NOTE:** HP Compaq dc7800 Business PC products only support RAID based on two identical SATA hard drives in either RAID 0 or RAID 1 or Matrix Mode of RAID 0 and RAID 1.
1. Open the Intel Matrix Storage Console and in the left pane select either **Protect data from a hard drive failure with RAID 1** or **Improve storage performance with RAID 0**.

2. In the right pane, select **Protect data from a hard drive failure with RAID 1**.

3. Click **Create a RAID 1 volume** to open a verification window.

4. Select **Yes** to begin the migration process.

5. Click **OK** after the migration completes.
Degradation

In the unlikely event that one of your hard drives malfunctions, you will be notified with the following message:

1. Run the Intel Matrix Storage Console application on the system experiencing a degradation to identify the hard drive that failed and to which port it is connected.

2. After identifying the hard drive, close all applications, shut down the operating system, power down the unit, unplug the power cord, and replace the defective hard drive.
3. After replacing the hard drive, automatic rebuild of the redundancy begins immediately after the system is powered up and operating system starts. The following message appears:

![A RAID volume is being rebuilt. Data redundancy is being restored.]

Migration to RAID 0 from two non-RAID hard drives using Intel Matrix Storage Console

**NOTE:** HP Compaq dc7800 Business PC products only support RAID based on two identical SATA hard drives in either RAID 0 or RAID 1 or Matrix Mode of RAID 0 and RAID 1.

1. Open the Intel Matrix Storage Console and select **Improve storage performance with RAID 0**.

![Intel(R) Matrix Storage Console]

2. Click **Actions > Create a RAID 0 volume** to open a verification window.

![View hard drive and RAID status]

**Detail:** System functioning normally.

- Protect data from a hard drive failure with RAID 1
- Improve storage performance with RAID 0
3. Click **Yes** to begin the migration process.

![Intel Matrix Storage Console](image)

4. Click **OK** after the migration completes.

Migration to RAID 0 from three non-RAID hard drives using Intel Matrix Storage Console

**NOTE**: Back up all data before proceeding.

**NOTE**: HP Compaq dc7800 Business PC products only support RAID based on three identical SATA hard drives RAID in either RAID 0 or RAID 5 or Matrix Mode of RAID 0 and RAID 5.

1. Open the Intel Matrix Storage Console and select **View>Advanced Mode**.

![Intel Matrix Storage Console](image)

2. Click **Actions > Create RAID Volume from Existing Hard Drive**, which opens a verification window.
3. Click **Next**.

4. Type the RAID Volume Name, select the RAID Level (for three hard drive RAID 0 or RAID 5 only), and select the Strip Size.

   **NOTE**: HP currently supports only the default Strip Size (in this case 128KB). There is a performance relation between the type of data and the strip sizes.
5. Click **Next** to display the selection of hard drives that will be part of this RAID volume.

6. Select all three hard drives (Port 0, Port 1, and Port 2), and then click the right arrow to place them in the **Selected** box.

7. Click **Next**.
8. Select all hard drive members of the RAID volume, and then click the right arrow to place all three hard drives in the **Selected** box.

9. Click **Next**.

10. Complete the volume size selection screen, and then click **Next**.

   **NOTE:** If users consume all available storage for this RAID volume, there will be no space to create another RAID volume for this hard drive, thereby not allowing for Matrix mode RAID.

   Note the size if you want to create a second RAID volume in this set of hard drives.

11. To create one RAID 0 out of the hard drive, leave the default of 100% for **Percentage of Available Space**, and then click **Next**.
12. Select **Finish** to start the migration process, which can take a few hours.
   After you click **Finish**, the migration starts and the following screen displays:

![Intel Matrix Storage Console](image)

13. Reboot the system after the migration finishes.

**Migration to RAID 5 from three non-RAID hard drives using Intel Matrix Storage Console**

**NOTE**: Back up all data before proceeding.

**NOTE**: HP Compaq dc7800 Business PC products only support RAID based on three identical SATA hard drives in either RAID 5 or RAID 0 or Matrix Mode of RAID 0 and RAID 5.

1. Open the Intel Matrix Storage Console and select **View>Advanced Mode**.
2. Click **Actions/Create RAID Volume from Existing Hard Drive** to open a verification window.

3. Click **Next**.

![Create RAID Volume from Existing Hard Drive Wizard](image)

4. Type the RAID **Volume Name**, select the **RAID Level** (for three hard drive RAID 0 or RAID 5 only), and select the **Strip Size**.
   
   **NOTE**: HP currently supports only the default Strip Size (in this case 64KB).
5. Click **Next** to see the selection of hard drives that will be part of this RAID volume.

6. Select all three hard drives (Port 0, Port 1, and Port 2), and then click on the arrow to move them to the **Selected** window.

7. Click **Next**.
8. After the selection of the all hard drive members of the RAID volume, complete the volume size selection screen, and then click **Next**.

**NOTE**: If users consume all available storage for this RAID volume, there will be no space to create another RAID volume for this hard drive, thereby not allowing for Matrix mode RAID.

![Create RAID Volume from Existing Hard Drive Wizard](image)

Note the size if you want to create a second RAID volume in this set of hard drives.

9. To create one RAID 5 out of the hard drive, leave the default of 100% for **Percentage of Available Space**, and then click **Next**.
10. Select **Finish** to start the migration process, which can take a few hours. The following screen displays.

![Migration to Matrix RAID 5 and RAID 0 from three non-RAID hard drives using Intel Matrix Storage Console](image)

11. Reboot the system after the migration finishes.

**Migration to Matrix RAID 5 and RAID 0 from three non-RAID hard drives using Intel Matrix Storage Console**

**NOTE:** Back up all data before proceeding.

**NOTE:** HP Compaq dc7800 Business PC products only support RAID based on three identical SATA hard drives in either RAID 5 or RAID 0 or Matrix Mode of RAID 0 and RAID 5.

1. Open the Intel Matrix Storage Console and select **View>Advanced Mode**.

![Intel(R) Matrix Storage Console](image)
2. Click **Actions/Create RAID Volume from Existing Hard Drive** to open a verification window.

3. Click **Next**.

![Create RAID Volume from Existing Hard Drive Wizard](image)

4. Type the RAID **Volume Name**, select the **RAID Level** (for three hard drive RAID 0 or RAID 5 only), and select the **Strip Size**.
   
   **NOTE**: HP currently supports only the default Strip Size (in this case 128KB).
5. Click **Next** to see the selection of hard drives that will be part of this RAID volume.

6. Select all three hard drives (Port 0, Port 1,1 and Port 2), and then click on the arrow to move them to the **Selected** window.

7. Click **Next**.
8. After the selection of the all hard drive members of the RAID volume, complete the volume size selection screen, and then click **Next**.

**NOTE:** If users consume all available storage for this RAID volume, there will be no space to create another RAID volume for this hard drive, thereby not allowing for Matrix mode RAID.

![Create RAID Volume from Existing Hard Drive Wizard](image)

Note the size if you want to create a second RAID volume in this set of hard drives.

9. To create two volumes based on your space, reliability and performance needs, select the size of the first RAID volume by sliding the bar or entering the desired volume size. For example, divide in half the available hard drive storage in two RAID volumes by setting the **Percentage of Available Space** to 50%, so that 50% of drive capacity is used for RAID 0.

10. Click **Next**.
11. Click **Finish** to start the migration process, which can take a few hours.

![Image of Intel Matrix Storage Console with RAID Volume creation process]

12. Reboot the system after the migration finishes.

   **NOTE:** Back up all data before proceeding.

13. After the first RAID volume has been created, create the second RAID volume by opening the Intel Matrix Storage Console, clicking **View>Advanced Mode**, and then clicking **Actions/Create RAID Volume from Existing Hard Drive**.
14. Click **Next**.

15. Use the same values you entered in the previous RAID volume confirmation and type the RAID **Volume Name**, select the **RAID Level** (for three hard drive RAID 0 or RAID 5 only), and select the **Strip Size**.

   **NOTE**: HP currently supports only the default Strip Size (in this case 64KB).

16. Click **Next** to see the selection of hard drives that will be part of this RAID volume.
17. Because this is the second volume for this set of hard drives, select the existing name in the Available box (Array 0000), and then click the right arrow to move this array into the Selected box.

18. Click Next.

![Specify Volume Size screen](image)

The Specify Volume Size screen is grayed out because the second volume of this matrix mode takes the remaining space. After the selection of all hard drive members of this RAID volume, follow the volume size selection screen.

**NOTE:** The first array volume creation is the place for adjusting the size; the second volume will take any remaining space.

19. While creating the second RAID volume, click Next to open the completion window.
20. Select **Finish** to start the migration process, which can take a few hours. The following screen appears.
21. Reboot the system after the migration finishes.

After the second reboot and both migrations are complete, you can see the state of the Matrix mode created by opening the Intel Matrix Storage Console and clicking **View>Advanced Mode**. The matrix mode of three hard drives is illustrated in the following image.
Migration to RAID Matrix Mode (0 + 1) from two non-RAID hard drives using Matrix Storage Console

The migration process for two hard drives to RAID Matrix Mode (0 + 1) is very similar to the process described in the section about migration of three hard drives to matrix mode RAID (0 + 5). The difference in the process is selecting two hard drives as part of the volume created and selecting RAID 5 instead of RAID 1.

Installation

HP desktops come with RAID software preinstalled; however, if reinstallation is necessary, use setup in combination with the following supported flags:

-? : The installer presents a dialog showing all the supported setup flags (shown here) and their usage.

-A : Extracts all files (does not install driver) to <path> if -P is also supplied. Otherwise, the files are extracted to the default location.

-B : Forces a system reboot after installation.

-O<name> : Allows for the customization of the program folder name for the Intel(R) Matrix Storage Console, which appears in Start > All Programs.

-P<path> : Supplies target path when using -A flag.

-N : Installs all components except driver.

-NoGUI : Installs only the driver. The Intel(R) Matrix Storage Console, Event Monitor, and Tray icon applet are not installed.

-NoMon : Disables the Event Monitor which consists of the Disk Monitor Service and the System Tray Icon Applet.

-S : Silent install (no user prompts).

-BUILD : Displays build information.

-G<number> : Forces a particular language install. There cannot be a space between -G and <number>.

-f2<path\name> : Creates a log file in <existing path> with <name>. Use during silent installation. There cannot be a space between -f2 and <path\name>, and the path must exist prior to installation.

Notes: Flags and their parameters are not case-sensitive. Flags may be supplied in any order, with the exception of -S and -G, which must be supplied last. When using the -A flag, a target path may be specified using the -P flag, and the -O, -G, -S, and -N flags are ignored. When using the -B, -O, -G and -f2, flags there should be no space between the flag and the argument. When using the -f2 flag, specify a log file name and path. The path must exist prior to the installation.
## Language support table

<table>
<thead>
<tr>
<th>Code</th>
<th>Language</th>
<th>Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ara</td>
<td>Arabic</td>
<td>Arabic (Saudi Arabia) 0401</td>
</tr>
<tr>
<td>chs</td>
<td>Chinese</td>
<td>Simplified 0804</td>
</tr>
<tr>
<td>cht</td>
<td>Chinese</td>
<td>Traditional 0404</td>
</tr>
<tr>
<td>csy</td>
<td>Czech</td>
<td>0005</td>
</tr>
<tr>
<td>dan</td>
<td>Danish</td>
<td>0006</td>
</tr>
<tr>
<td>nld</td>
<td>Dutch</td>
<td>0013</td>
</tr>
<tr>
<td>enu</td>
<td>English</td>
<td>United States 0009</td>
</tr>
<tr>
<td>fin</td>
<td>Finnish</td>
<td>0008</td>
</tr>
<tr>
<td>fra</td>
<td>French</td>
<td>International 040C</td>
</tr>
<tr>
<td>deu</td>
<td>German</td>
<td>0007</td>
</tr>
<tr>
<td>ell</td>
<td>Greek</td>
<td>0008</td>
</tr>
<tr>
<td>heb</td>
<td>Hebrew</td>
<td>040D</td>
</tr>
<tr>
<td>hun</td>
<td>Hungarian</td>
<td>000E</td>
</tr>
<tr>
<td>ita</td>
<td>Italian</td>
<td>0010</td>
</tr>
<tr>
<td>jpn</td>
<td>Japanese</td>
<td>0011</td>
</tr>
<tr>
<td>kor</td>
<td>Korean</td>
<td>0012</td>
</tr>
<tr>
<td>nor</td>
<td>Norwegian</td>
<td>0014</td>
</tr>
<tr>
<td>plk</td>
<td>Polish</td>
<td>0015</td>
</tr>
<tr>
<td>ptb</td>
<td>Portuguese (Brazil)</td>
<td>0416</td>
</tr>
<tr>
<td>ptg</td>
<td>Portuguese (Standard)</td>
<td>0816</td>
</tr>
<tr>
<td>rus</td>
<td>Russian</td>
<td>0019</td>
</tr>
<tr>
<td>esp</td>
<td>Spanish</td>
<td>000A</td>
</tr>
<tr>
<td>sve</td>
<td>Swedish</td>
<td>001D</td>
</tr>
<tr>
<td>tha</td>
<td>Thai</td>
<td>001E</td>
</tr>
<tr>
<td>trk</td>
<td>Turkish</td>
<td>001F</td>
</tr>
</tbody>
</table>

© 2007 Hewlett-Packard Development Company, L.P. The information in this document is subject to change without notice. The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein. Microsoft, MS-DOS, Windows, Windows NT, and Windows Vista are trademarks of Microsoft Corporation in the U.S. and other countries. 42464-001 9/2007