
Administrator's Guide
Linux-based HP Compaq t5735 Thin Client



© Copyright 2008 Hewlett-Packard
Development Company, L.P. The
information contained herein is subject to
change without notice.

Microsoft and Windows are trademarks of
Microsoft Corporation in the U.S. and other
countries.

The only warranties for HP products and
services are set forth in the express warranty
statements accompanying such products
and services. Nothing herein should be
construed as constituting an additional
warranty. HP shall not be liable for technical
or editorial errors or omissions contained
herein.

This document contains proprietary
information that is protected by copyright. No
part of this document may be photocopied,
reproduced, or translated to another
language without the prior written consent of
Hewlett-Packard Company.

Administrator's Guide

Linux-based HP Compaq t5735 Thin
Client

First Edition (January 2008)

Document Part Number: 480953–001



About This Book
WARNING! Text set off in this manner indicates that failure to follow directions could result in bodily
harm or loss of life.

CAUTION: Text set off in this manner indicates that failure to follow directions could result in damage
to equipment or loss of information.

NOTE: Text set off in this manner provides important supplemental information.
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1 Introduction

CAUTION: Thin clients are designed for remote data storage and excessive writes to flash may
damage the flash memory.

This guide provides the network administrator with instructions for configuration of the Linux-based thin
client and explains the various configuration utilities.

NOTE: Not all features described in this guide are available in all Linux-based terminal models.

Typically, to configure multiple terminals, you can configure a terminal locally and then use it as a
template for other terminals, which you can then configure using remote administration tools.

NOTE: A default administrator account is pre-installed with the following settings: User name and
Password = root. Additionally, the HP t5735 ships with a basic user account with the user name and
password = user. By default, the t5735 will autologin into the user account. HP recommends that you
change the user and root passwords as soon as possible. See Login Window on page 26 for more
information on accessing the root account.

Thin client image
The HP t5735 Linux thin client offers an extensible Linux image built upon Debian GNU/Linux. HP has
extensive Debian experience and selected Debian as the foundation for its thin client based on its
stability, security, and market acceptance. Debian includes a package management system that ties
into repositories maintained by the Debian community, HP, and others. Package is the generic term for
all software, drivers, features, etc., that are “wrapped” in code that allows the software to be easier to
automatically install into proper directories and check for any other dependences that are required to
ensure they work properly once installed. Once created, packages reside in various repositories that
are maintained by the Open Source Community for open source packages. HP hosts a unique repository
for updates and features specifically for the HP t5735. Aptitude is a command-line and/or text-based
GUI program for connecting to and managing packages locally and in a repository.

This image also comes with FTP update for installing new packages and settings files using an FTP
server and ThinState capture. For more information about ThinState, see HP ThinState utility
on page 28.

You can use the Altiris client to provide remote management of the thin client and to upgrade the Linux
image with feature enhancements, device drivers, and maintenance updates.
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Desktop options
This section describes the Linux thin client desktop.

By default, at least three objects appear on the desktop:

● Computer icon—This icon gives you access to removable media such as USB flash drives, as well
as to the entire filesystem (also known as the root filesystem). By default, you do not have the
security permissions to read other users' files or to edit system files. It allows you to see a graphical
representation of the files and folders on the system and to browse the various folders.

● User’s Home icon—Your Home Folder is labeled username's Home; it’s where all of your personal
files are kept.

● Trash icon—Trash is a special folder in which to place files and folders you no longer need.

When you insert a flash drive or other removable media, a corresponding icon appears on the desktop
and a window opens and displays any files and folders on the device.

As you work with your HP Compaq thin client, the desktop may become obscured by the windows you
are working with. To reveal the desktop quickly, you can minimize all windows by doing one of the
following:

● Click the Show Desktop button at the bottom left of the screen.

● Press Ctrl+Alt+D.

Either action will also restore your windows to their previous state. Alternatively, you can switch to
another workspace to see the desktop.

The files and folders you put on the desktop are stored in a special folder within your Home Folder called
Desktop. Like any other folder, you can put files and other folders directly into it.
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Taskbar and menus
The default taskbar contains the following menus that provide quick function access:

● Applications menu

● Places menu

● Desktop menu

Applications menu
The Applications menu contains a hierarchy of submenus, from which you can start the applications
that are installed on your thin client.

Each submenu corresponds to a category. For example, in the Internet submenu, you will find the HP
Connection Administrator used for connecting to a server.

To launch an application,

1. Click Applications.

2. Move the cursor down the menu to the category of the application you want. Each submenu opens
as your cursor passes over the category.

3. Click the menu item for the application.

When you install a new application, it is automatically added to the Applications menu in a suitable
category. For example, the Web browser can be found in the Applications > Internet submenu.

Applications submenus
Submenus contain tools to manage and use your computer:

● Root Terminal: Opens a terminal as the root user, using GKSU to ask for the administrative
password. It is useful to menu items or other graphical programs that need to ask a user's password
to run another program as another user.
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● Citrix PNA Menu Items: A file browser that allows you to view all Program Neighborhood Agent
(PNAgent) items.

● Citrix Presentation Server Client: Allows you to add, delete, configure, or connect to a Citrix ICA
server. Click View to select Connection View or PNAgent View, or click Tools to view or edit
Settings, open the Connection Center, or open Xcapture.

● HP Connection Administrator: Allows administrative users to manage various types of
connections, for example: ICA, RDP, XDM, and browser connections and allows all users to
connect or disconnect a selected connection.

● Iceweasel Web Browser: Allows you to launch an Internet Web browser. Iceweasel is an open-
source Web browser based on Mozilla Firefox that is designed for standards compliance,
performance, and portability.

● TeemTalk: Allows you to use terminal emulation to connect and communicate with applications on
mainframes and midrange systems including servers running proprietary OS’s, UNIX and Linux
systems.

● GNOME ALSA Mixer: An Advanced Linux Sound Architecture (ALSA) sound mixer for GNOME.
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● File Browser: Allows you to graphically browse through files and folders on the thin client.

● HP Date and Time Manager: Allows you to adjust the thin client date and time, and to set the
Timezone.

● HP FTP Update: Allows you to configure the thin client to check a specific ftp location for a newer
image or package upon reboot.

● HP Network Manager: Allows you to configure connectivity between the thin client and the internet,
a network, or a computer.

● HP Printer Manager: This utility allows you to add a new printer and modify printer settings.

● HP System Information: Allows you to view system information.

● HP ThinState Capture: Allows you to capture an HP thin client image that can then be deployed
to another HP thin client of identical model and hardware.

● HP VCN Shadow: Allows you to control and configure the VNC Shadowing ability of the thin client.

● New Login: Allows you to log in as another user without logging out.

Places menu
The Places menu is a quick way to go to various locations on your computer and your local network.

The Places menu allows you to open the following items:

● Home Folder, where all of your personal files are kept.

● Desktop folder, which corresponds to the items displays in the desktop.

● Computer, which shows all your drives.

● Network Servers. If your system is configured to access places on a network, you can use the
network file browser to access the network places.

The last two items on the menu perform actions rather than open locations:

● Connect to Server, lets you choose a server on your network.
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To connect to a remote server, select the service type, and then type in the Server IP address. If
required by your server, you may provide the following optional information and click Connect.

◦ Type in the Port to connect to on the server. This should only be used if it is necessary to
change the default port; you would normally leave this blank.

◦ Type the Folder to open upon connecting to server.

◦ Type a Name to use for connection. The designation of the connection as it will appear in
the file manager.

● Recent Documents, submenu lists the documents you have recently opened.

Click the last entry in the submenu, Clear Recent Documents, to clear the list.

Desktop menu
The Desktop menu allows you to set preferences for your thin client.

● Administration submenu contains tools to manage your computer. These all require your system's
password. The GNOME-system-tools package can be installed to provide additional tools for
performing advanced configuration.

● Preferences submenu contains all the preference tools. With these you can configure your
GNOME Desktop. For more on preference tools, see Chapter 8, Configuring Your Desktop, in the
GNOME Desktop User Guide at http://library.gnome.org/users/user-guide/stable/.

● About GNOME item has a brief introduction to GNOME, links to the GNOME Web site, and credits.

● Log Out user to log out user of the current session, or to log in as a different user. When you end
a session, applications with unsaved work may not warn you so please save data and exit all
programs first.

● Shut Down to end your session and turn off your thin client, or restart it.

Click to shut down your computer and switch off the power or log out for another user to log in.
When you end a session, applications with unsaved work may not warn you, so please save data
and exit all programs first.
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Desktop submenus

● Login Window: Allows you to configure the login window.

● Accessibility: Allows you to enable support for assistive technologies at login and set your
keyboard accessibility preferences. The Debian repository provides additional accessibility support
in packages like GNOME-accessibility-themes.

● About Me: Allows you to set your personal information for use with the Evolution package, if
installed.

● Desktop Background: Allows you to change the color of the desktop background or the image
displayed there. You can also open Desktop Background Preferences by right-clicking on the
desktop and choosing Change Desktop Background, as well as from the Desktop >
Preferences menu.

● File Management: Allows you to customize the file manager to suit your requirements and
preferences.

● Font: Use to select the fonts to use in your applications, windows, terminals, and desktop.

● Keyboard: Allows you to modify the autorepeat preferences for your keyboard, set your keyboard
layout, and configure your keyboard options and typing break settings. You can also click Layout
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Options > Accessibility button to set options such as filtering out accidental key presses, using
the keyboard as a substitute for the mouse, and using shortcut keys without having to hold down
several keys at once.

● Keyboard Shortcuts: Allows you to customize the default keyboard shortcuts to your
requirements. Shortcut keys are keys that provide you with a quick way to perform a task.

● Login Photo: Enables you to change the picture that is displayed in your login screen. From the
Login Photo Preferences window, select an image to display in your login screen.

● Menus & Toolbars: Allows you to customize the appearance of menus, menubars, and toolbars
for applications.

● Mouse: Allows you to set the mouse preferences; buttons, pointers, and motion.

● Network Proxy: Enables you to configure how your system connects to the Internet. You can
configure the thin client to connect to a proxy server, and specify the details of the proxy server.

NOTE: This setting is for GNOME applications only; other applications like Iceweasel and
aptitude have their own proxy settings.

● Preferred Applications: Allows you to specify the applications that you want the thin client desktop
to use when the thin client starts an application for you. For example, you can install a local mail
client and specify it as your mail reader.

● Removable Drives and Media Preferences: Enables you to manage multimedia devices. For
example, you can select settings for removable storage, blank CD and DVD disks, audio and video
disks, etc.

● Screen Resolution: Allows you to specify the resolution and refresh rate settings for your screen.

● Sessions: Enables you to manage your sessions. You can also set session options and specify
which applications to start when you start a session. This dialog can be used in conjunction with
HP Connection Administrator and other applications to configure the client as a basic kiosk.

● Sound: Allows you to enable sounds. You can also specify which sounds to play when particular
events occur if you install the GNOME-audio package or a set of sound files.

● Theme: Allows you to select from a list of available themes, install a new theme to the list, create
a custom theme or delete a theme option. Additional themes can be installed with the GNOME-
themes and GNOME-themes-extras packages, or you can install themes from sources like
http://www.gnome-themes.orgor create your own theme.

● Windows: Allows you to customize window behavior for the desktop.
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Synaptic
Thin client software is organized into packages. Synaptic provides a graphical user interface to the
package manager that allows you to easily add, upgrade, and remove packages on your thin client.

NOTE: Synaptic Package Manager is only usable from the Root desktop

Most applications reuse the functionality of other applications or libraries; therefore, most packages
depend on other packages. The Synaptic Package Manager resolves the dependencies automatically.

Synaptic provides the following features:

● Install, remove, configure, upgrade, and downgrade single and multiple packages

● Upgrade entire system (not recommended)

● Manage package repositories

● Search packages by name, description, and several other attributes

● Select packages by status, section, name, or a custom filter

● Sort packages by name, status, size, or version

● Browse all available online documentation related to a package

● Lock packages to the current version

● Force the installation of a specific package version

HP hosts a repository for t5735 options, add-on, and package updates at ftp://ftp.hp.com/pub/
tcdebian.

NOTE: To conserve flash space, Synaptic is not normally installed. The root user’s desktop has an
icon that when run will use aptitude to install Synaptic, which may be removed when no longer
necessary. To access the root user’s desktop, a user who knows the administrative password must
check the Allow local system administrator login check box on the Security tab of the Login Window
applet in the Desktop/Administration menu.

You must log in as root or a user in the Administrator group to use Synaptic. Click Desktop > Log Out
User > Log Out to open the administrator login windows.

Reload package information regularly so you do not miss important security upgrades.

Synaptic requires an active network connection to work properly.

Synaptic requires that the thin client have Internet access.

If the HP Repository appears to be down or does not connect when trying to update the package list,
wait and retry.

From time to time HP may release new or updated packages to the HP repository. HP packages
have hptc- at the beginning of their name (i.e., hptc-control-panel); however, for the benefit of our
customers, other vendors may also post packages in the HP repository (i.e., ICA updates, ThinPrint
packages, etc.) that follow the vendor's naming convention and therefore do not begin with hptc-.

The first time you launch Synaptic, it decompresses itself and loads the list of all available packages
from default ftp sites.
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To launch Synaptic for the first time:

1. Click Desktop > Administration > Login Window, and click the Security tab.

2. Check the Allow local system administrator login check box.

3. Enter proxy information, if necessary (Applications > System Tools > HP Network Manager).

4. Log out and login again as root.

5. Select the Synaptic icon on the desktop.

An xterm window opens.

6. Type Y, and then press Enter.

The install results are displayed on-screen.

7. Read the installation results to confirm the packages successfully installed, and then close the
window.

NOTE: After running Synaptic for the first time, its icon changes.

Alternatively, you can open a root terminal and enter the command aptitude update && aptitude
install synaptic after performing any necessary proxy configuration, as described above.

The Synaptic Package Manager window includes a pane (left) that allows you to list packages by
category, a pane (upper right) that lists all packages within a selected category, and a pane (lower right)
that provides information about a specific selected package.

For detailed information about a package, including size, version number, dependencies, files, and
more, right-click the package and select the Properties button.

To install packages on the thin client:

NOTE: Be sure to read the installation messages, as they can require user input. Installing or removing
packages requires administrator root permissions.

1. Open Synaptic Package Manager by double-clicking Synaptic on the desktop.

2. Click Search to open the Find dialog box.

3. Type a parameter of what you are searching for in the Search field, then select the search category
in the Look in list, and then click Search. The upper right pane displays all packages located based
on your search criteria.

4. In the upper right pane, select the specific package to install. If desired, read about the selected
package in the lower right pane.

5. In the dialog box, select the installation option based on the type of installation you are performing.

6. If necessary, repeat steps 2 - 5 to location and mark more packages for installation.

7. Click Apply.

8. Confirm the action and click Apply.

9. Click Close after all packages are successfully installed.

10 Chapter 1   Introduction ENWW



NOTE: When uninstalling packages, Mark for Removal uninstalls the package from the thin client
without removing the configuration files. Mark for Complete Removal removes all traces of the package
from the thin client.

For more information about Synaptic functions and features, go to the local Synaptic help file (launch
the Iceweasel Web browser and go to file:///usr/share/synaptic/html/index.html).

TeemTalk

TeemTalk is the essential connectivity tool for enabling non-X based applications to be run in the X
environment. TeemTalk provides precise emulation of a wide range of industry standard terminals with
impressive additional features formulated to increase productivity and reduce network loading. These
include dynamic window sizing, hotspots, soft buttons, keyboard mapping, mouse button definition and
customizing capabilities. TeemTalk integrates seamlessly into the X Window system with the same look
and feel as other applications.

NOTE: The X Window System is a network-based windowing system that provides a common
graphical interface for application programs. It defines how applications create windows and the
graphics displayed in them.

The basic function of TeemTalk is to accept command sequences from a host application (client) and
convert them into equivalent X functions, which can then be passed on to the X display server. This
means that current investment in host application software can be retained in the X Windows
environment.

Each window displayed by TeemTalk is, in effect, a separate 'terminal'. Several terminal emulation
windows may be displayed simultaneously on the same display server, all running different programs.
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For more information about TeemTalk, see the TeemTalk 5.0 for Unix User Guide at
http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00782549/c00782549.pdf.

Connection types
By default the t5735 comes ready to run use the following connection types:

● ICA

● rdesktop

● Iceweasel

Other connections may be available in the Debian repositories and in the Open Source Community and
may be configured through Connection Administrator’s Other connection type.

For more information about connections, see HP Connection Administrator on page 35.

System information
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To locate information about the system and operating system (for example, what version of the image
is currently running), click Applications > System Tools > HP System Information.

The screen displays information about the CPU, flash, memory, BIOS, and operating system.
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2 Preference Settings

This chapter provides an overview of using the preference tool to customize your desktop.

A preference tool allows you to change thin client desktop preferences. Each preference setting covers
a particular aspect of your computer. For example, with the Screen Resolution preference tool, you can
select the appropriate resolution for your monitor or change the refresh rate. With the Menu and Toolbar
Preferences tool, you can select and view the behavior and appearance Icons and toolbars.

To open a preference tool, click Desktop > Preferences, and select the appropriate submenu item.

With a few exceptions, the changes you make to settings in a preference tool take effect immediately
without needing to close the preference tool. You can keep the preference tool window open while you
try the changes and make further changes, if you wish.

NOTE:  Some applications or system components may add their own preference tools to the menu.
Some settings for your thin client require administrator access.

Date/Time

The HP Date and Time Manager utility allows you to set the date and time, select the appropriate time
zone, and enable NTP (Network Time Protocol).

Click Applications > System Tools > HP Date and Time Manager to access this utility. Use the values
in the Date, Time, and Time Zone areas to select the appropriate date and time information.
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Configuring the system hardware clock from BIOS
You can set the system hardware clock to your local date and time using the BIOS setup utility as follows:

1. Reboot the system and press F10.

2. Select Standard CMOS Features, and then press Enter.

3. Set the date and time using the Page Up and Page Down keys or type the new numbers using the
Num keys.

4. To save the changes, press F10, and then press Enter.
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Desktop background

The desktop background is the image or background color that is applied to your desktop.

To access the Desktop Background Preferences:

� Right-click on the desktop, then click Change Desktop Background.

–or–

� Click Desktop > Preferences > Desktop Background.

You can customize the desktop background in the following ways:

● Select an image for the desktop background. The desktop background color is visible if you select
a transparent image or if the image does not cover the entire desktop.

● Select a color for the desktop background. You can select a solid color or create a gradient effect
with two colors. A gradient effect is a visual effect where one color blends gradually into another
color.

Desktop Wallpaper
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You can choose an image from a list, or select Add Wallpaper to choose any image on your thin client,
including a USB drive.

To specify how the image is displayed, select one of the following options from the Style list:

● Centered: Displays the image in the middle of the desktop.

● Fill Screen: Enlarges the image to cover the desktop and maintains the relative dimensions of the
image.

● Scaled: Enlarges the image until the image meets the screen edges and maintains the relative
dimensions of the image

● Tiled: Enlarges the image until the image meets the screen edges and maintains the relative
dimensions of the image

To remove a desktop wallpaper image:

� Select the wallpaper that you want to remove, then click Remove.

This removes the image from the list of available wallpapers; however, it does not delete the image
from your thin client.

Desktop Colors

You can specify a color scheme by using the options in the Desktop Colors list, and by selecting color
(s) using the color selector buttons.

To specify a color scheme:

� Use the options in the Style list and the color selector buttons. Choose Solid Color, Horizontal
Gradient, or Vertical Gradient.
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Keyboard

Use Keyboard Preferences to set key behavior, keyboard character repeat parameters, and the
Numlock setting. To access this utility, click Desktop > Preferences > Keyboard.

NOTE: Changes to the keyboard preferences apply locally. Remote settings are determined by the
applications (rdesktop, Citrix, etc.) and server, but may be affected by local settings.

Drivers for the various languages do not transfer to the remote computer; therefore, you must also install
the drivers for the selected language on the remote computer.

If you enable the Typing Break utility and stop using the keyboard and mouse for a length of time equal
to the Break interval setting, the current work interval will be reset.

Mouse

Set Mouse Preferences to configure your mouse for right- or left-hand use, or to specify the speed and
sensitivity of mouse movement. To access this utility, click Desktop > Preferences > Mouse.

On the Buttons tab, you can specify whether the mouse buttons are configured for right- or left-hand
use. You can also specify the delay between clicks for a double-click.
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The Pointers tab allows you to set your mouse pointer preferences.

The Motion tab allows you to set your preferences for mouse movement.

Network Manager
Use the Network Manager utility to configure connectivity between the terminal and the Internet, a
network, or a computer. To access this utility, click Applications > System Tools > HP Network
Manager.

Interfaces

On the Interfaces tab, you can add, modify, or remove network interfaces in /etc/network/interfaces.
Select the interface, and then use the following buttons as necessary:

● Activate: Click to activate an inactive NIC if the unit has multiple Ethernet cards installed (for
example, the down network card and an additional PCI NIC card).

● Deactivate: Click to deactivate a specific card if the unit has multiple Ethernet cards installed.

● Add: Click to walk through the options to set up a new NIC interface.

● Modify: Click to modify an existing interface. The IP Address Configuration window is displayed.
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In this window, you can set the following options:

● Configuration: Select a configuration from the following options:

◦ Automatic address setup (via DHCP): Enables DHCP and displays settings provided by IT
or allows configuration.

◦ Static address setup: Allows you to enter a specific IP address, Subnet Mask, and Gateway.

● Link Speed: Set a specific link speed. Auto Negotiated is the default.

General
On the General tab, you can locate network identification information and current IP settings.
Additionally, you can name the interface and provide a description, as well as select between provided
DNS servers.

DNS
On the DNS tab, DNS names and domains are displayed and can be configured.

20 Chapter 2   Preference Settings ENWW



ENWW Network Manager 21



Printers

The Printer Management utility allows you to add a new printer and modify printer settings. Click
Applications > System Tools > HP Printer Manager to access this utility.

NOTE: To enable printing, you must install lprng using Synaptic.

Text and postscript print formats are currently supported locally.

Parallel printer
1. Click the Printers tab.

2. Select Load LPD Server at boot time. If this check box is not available, lprng is not installed. You
must install lprng to enable printing.

NOTE: To install lprng, use the package management system (Synaptic or aptitude) and search
for and install lprng. For more information about Synaptic, see Synaptic on page 9.

3. Click Add.

4. Select Parallel Printer.
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5. Type a Printer Name and Description (optional).

6. Use the value that defaults in the Device Port field. If the field is empty, there is no printer connected
to the client.

7. If necessary, type a driver name in the Windows driver field. Citrix ICA and RDP use this field to
set the printer driver for the session.

NOTE: You must type the Windows driver name exactly as it is on the server.

8. From the Use Filter list, select /usr/lib/lprng/filter/lpf. If NONE is displayed, lprng is not installed.

9. If you want to make this the default printer, select Make Default.

10. If desired, click Test to send a sample job to the printer.

11. Click OK to save changes.

USB printer
1. Click the Printers tab.

2. If Load LPD Server at boot time is not available, lprng is not installed. You must install lprng to
enable printing.

NOTE: To install lprng, use the package management system (Synaptic or aptitude) and search
for and install lprng. For more information about Synaptic, see Synaptic on page 9.

3. Click Add.

4. Select USB Printer.

5. Type a Printer Name and Description (optional).

6. Use the value that defaults in the Device Port field. If the field is empty, there is no printer connected
to the client.

7. If necessary, type a driver name in the Windows driver field. Citrix ICA and RDP use this field to
set the printer driver for the session.

NOTE: You must type the Windows driver name exactly as it is on the server.
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8. From the Use Filter list, select /usr/lib/lprng/filter/lpf. If NONE is displayed, lprng is not installed.

9. If you want to make this the default printer, select Make Default.

10. If desired, click Test to send a sample job to the printer.

11. Click OK to save changes.

Network printer
1. Click the Printers tab.

2. If Load LPD Server at boot time is not available, lprng is not installed. You must install lprng to
enable printing.

3. Click Add.

4. Select Network Printer.

5. Type a Printer Name and Description (optional).

6. Select the appropriate Device Port. If the list is empty, there is no printer connected to the client.

7. Fill in the LPD Server field. This value is the Printer Server IP address.

8. Fill in the Shared Printer field. This value is the shared printer name on the server.

9. If necessary, type a driver name in the Windows driver field. Citrix ICA and RDP use this field to
set the printer driver for the session.

NOTE: You must type the Windows driver name exactly as it is on the server.

10. From the Use Filter list, select /usr/lib/lprng/filter/lpf. If NONE is displayed, lprng is not installed.

11. If you want to make this the default printer, select Make Default.

12. If desired, click Test to send a sample job to the printer.

13. Click OK to save changes.
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Samba printer
1. Click the Printers tab.

2. If Load LPD Server at boot time is not available, lprng is not installed. You must install lprng to
enable printing.

3. Click Add.

4. Select Samba Printer.

5. Type a Printer Name and Description (optional).

6. Select the appropriate Device Port. If the list is empty, there is no printer connected to the client.

7. Fill in the Samba Server field.

8. Fill in the Shared Printer field.

9. Fill in the User Name, Password and Workgroup fields. These values are determined by your
Windows Server configuration.

10. If necessary, type a driver name in the Windows driver field. Citrix ICA and RDP use this field to
set the printer driver for the session.

NOTE: You must type the Windows driver name exactly as it is on the server.

11. From the Use Filter list, select /usr/lib/lprng/filter/lpf. If NONE is displayed, lprng is not installed.

12. If you want to make this the default printer, select Make Default.

13. If you want the system to automatically translate carriage returns when printing from Linux to
Windows and Windows to Linux, select Translate.

14. If desired, click Test to send a sample job to the printer.

15. Click OK to save changes.

ENWW Printers 25



Print jobs
To view print jobs:

1. Click the Jobs tab.

2. Select the printer to view from the Select Printer list.

3. Click the Delete or Delete All buttons to delete jobs from the print queue.

Sound — GNOME ALSA Mixer

The ALSA Mixer dialog box allows you to set a wide variety of sound controls for the thin client.

To open the ALSA Mixer, click Applications > Sound & Video > GNOME ALSA Mixer.

For more information on ALSA Mixer, go to the Advanced Linux Sound Architecture (ALSA) project
home page at http://www.alsa-project.org/.

Login Window
Use the Login Window Preferences utility to select the type of interface to use for the login screen for
users logging in from a local or a remote system, select Accessibility and Security preferences, and
select the user settings desired. For more information on GNOME Login Window Preferences, go to
http://www.gnome.org.

To access this utility, click Desktop > Administration > Login Window.
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Of special importance—by default the t5735 image boots to the user desktop. To enable login access
to the root desktop, click the Security tab and select the Allow local system administration login
check box. To log in to the root desktop, click Desktop > Log Out User > Log Out and log in on the
administrator login windows.
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HP ThinState utility

HP ThinState capture and deploy allows you to capture a thin client image and deploy it to other thin
clients of the same model. To access this utility, click Applications > System Tools > HP ThinState
Capture.

The HP ThinState Capture tool is a simple wizard-based tool that can be used to capture an HP thin
client image that can then be deployed to another HP thin client of identical model and hardware.

What do you need to have?

● An HP thin client Linux unit that contains the latest HP-provided image

● An HP-approved USB drive key

NOTE: The HP ThinState Capture tool is not a standalone tool and can only be accessed by the
administrator from within the thin client image.

Save all data on the USB flash drive to some other device prior to performing this procedure. The USB
flash drive will be formatted and all data will be lost.

Close all other applications and do not make any changes to the system flash during this process.

To use HP ThinState to capture thin client settings:

NOTE: It is recommended that any previously captured settings files be deleted from the USB flash
drive before performing the following steps.

1. Attach a USB flash drive to your thin client.

A File Browser window opens on the desktop.

2. Click Applications > System Tools > HP ThinState Capture.
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3. Click OK on the notification message.

The following window is displayed:

4. Click Capture Settings, and then click Next.

The following window is displayed:

By default, all settings are captured. You can select only the settings you want to capture by using
HP ThinState Advanced Settings.

To use Customized Captured Settings:
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NOTE: Files deleted from the List of files to capture are permanently removed and no longer
available for future setting captures.

a. Click Advanced.

The following window is displayed:

b. Select the feature and click Delete. This eliminates all settings of the feature from the current
and all future captured settings files.

c. Click OK on the notification. Repeat as necessary to complete the customization.

d. Click Save.

e. Click OK on the notification.

f. Close the HP ThinState Advanced Settings dialog window.

5. Select the target USB flash drive from the list.

6. Click Capture.

7. Click OK on the notification.

8. Close the window.

Use the capture settings on the USB drive to replicate (deploy) an image on different systems or
to restore the original settings to a thin client.

To Use HP ThinState to deploy captured settings:

1. Attach the USB flash drive containing the previously captured settings

2. Click Applications > System Tools > HP ThinState Capture.
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3. Click OK on the warning.

The following window is displayed:

4. Select Deploy Settings.

5. Click Next.

6. If multiple USB devices are connected, select the target USB flash drive from the list.

7. Click Deploy.

Once image settings have deployed, a notification that the settings have been deployed
successfully and it is safe to remove the USB flash drive appears.

8. Click OK on the notification. The thin client immediately reboots.

NOTE: If you do not remove the USB flash drive before reboot, you are prompted to press any
key. Simply remove the flash drive and press any key to continue rebooting.
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To use HP ThinState to capture a thin client full image:

1. Attach a USB flash drive to the thin client.

NOTE: HP ThinState, when capturing a full image, automatically formats the USB flash drive and
makes the flash drive bootable.

2. Click Applications > System Tools > HP ThinState.

3. Click on the warning. The following window is displayed.

The following window is displayed:

4. Select Capture Full Image, and then click Next.

The following window is displayed:

5. Click Capture.

6. Click OK on the warning.

NOTE: HP ThinState, when capturing a full image, automatically erases all data on the USB flash
drive.
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7. Remove the USB flash drive and click OK.

8. Close the HP ThinState window.

Use the captured full image on the USB drive to replicate the image on different systems or to
restore the original settings to a thin client.

To use HP ThinState to deploy a thin client full image:

1. Set the boot order in the F10 System BIOS to USB boot (if necessary).

2. Turn off the thin client.

3. Attach the USB flash drive to the thin client unit onto which you wish to deploy the captured image,
and then turn on the unit.

4. Follow the on-screen instructions.

After you remove the USB flash drive and cycle power to the system, the image is unbundled. Do not
interrupt or cycle power to the unit during this process.

You may use the captured image (flash.dd) found in the USB flash drive in combination with Altiris
Deployment Solution to remotely image multiple thin client units.

NOTE: You must use flash.dd in conjunction with the HP ThinState Deploy utility (e.g., ibr.exe).
Flash.dd is not compatible with the Altiris rdeploy.exe or rdeployt.exe utilities.

Please consult the HP Compaq Thin Client Imaging Tool at http://h20000.www2.hp.com/bc/docs/
support/SupportManual/c00485307/c00485307.pdf.

For more information about Altiris, see http://www.altiris.com/.

FTP Update

Use HP FTP Update utility to enable automatic FTP updates as an alternative to the Altiris Deployment
Solution. Enabling this feature allows you to configure the thin client to check a specific ftp location for
a newer thin client settings file upon reboot.

To access this utility, click Applications > System Tools > HP FTP Update.
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NOTE: FTP Update does not support full image updates on the t5725.

As the Network Administrator, you can set the DHCP Scope Options for FTP server. Find these options
at /etc/ftpclient.conf:

● 180 – force ftp imaging

● 181 – ftp server ip

● 182 – ftp server path

● 183 – user name

● 184 – password

● 190 – altiris server ip
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3 HP Connection Administrator

HP Connection Administrator allows you to manage server and application connections by setting up
Web, RDP, XDM, ICA, and other types of connections and assigning them to users.

Click Applications > Internet > HP Connection Administrator to access HP Connection
Administrator. To access all HP Connection Administrator functionality, you must log in with root
permissions as a member of the root group; however, non-root users can run and be assigned to
connections.

HP Connection Administrator window

HP Connection Administrator allows you to add, edit, and delete connections.

Click Applications > Internet > HP Connection Administrator to access HP Connection
Administrator.

NOTE: You must log in with root permissions to access all components of the HP Connection
Administrator window.

The HP Connection Administrator features the following:

● Connections Display: Lists all server and/or application connections assigned to the user
currently logged on to the terminal. For each connection, the display shows the name, type, and
status of the connection.

NOTE: Double-click any displayed connection to activate that connection.

● Connect: Click to activate a selected connection.
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● Disconnect: Click to disconnect a selected connection.

● Exit: Click to exit HP Connection Administrator if the terminal is not in Kiosk mode. If the terminal
is in Kiosk mode, click this button to end the session. If you are a member of the administrator or
shutdown groups, the thin client displays options to turn off or reboot the terminal.

● Delete: Click to delete a selected connection.

NOTE: The connection is deleted from the list of connections available to all users, not just the
user currently logged on to the terminal.

● Add: Click to create a new connection and add it to the list of connections assigned to the user
currently logged on to the terminal.

NOTE: You can assign a new connection to other users using the Advanced Configuration utility.
Click Advanced to access this utility.

● Edit: Click to edit the selected connection.

● Advanced: Click to access the Advanced Configuration utility, where you can configure and assign
connections and configure the terminal user interface.

Connection types
You can use the HP Connection Administrator to create the following types of connections:

● Citrix ICA

● Iceweasel

● rdesktop

● XDM

● Other

Adding, editing, and deleting connections
You can add, edit, or delete connections in the HP Connection Administrator or in the Advanced
Configuration utility. However, you need to note the following important difference based on where you
add connections:

● Adding a connection in the HP Connection Administrator adds it only to the list of connections
assigned to the user currently logged on to the terminal.

● Adding a connection in the Advanced Configuration utility automatically adds the connection to the
currently selected user. The new connection is also available in the Advanced Configuration utility
for assignment to other users.

For more information about the different types of connections, see the related sections later in this
chapter.
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To add a connection:

1. Click Add.

The system displays the Add Connection dialog box, which lists the connection types registered
with the system.

2. Select the type of connection you want to create and click OK.

3. Follow the on-screen instructions specific to your selection to add the connection to the user's
connections list and to the list of available connections that you can assign to other users in the
Advanced Configuration utility.

To edit a connection:

� Select the connection and click Edit.

To delete a connection:

� Select the connection and click Delete. The connection is deleted from all user connection lists.

Citrix ICA
The ICA Connection window allows you to configure Citrix settings.

To configure Citrix ICA settings:

1. Click Applications > Internet > HP Connection Administrator.

The HP Connection Administrator window opens.

2. Click Add.

The Add Connection window opens.

3. Select Citrix ICA and click OK.

The ICA connection window opens.

4. Use the following to configure a Citrix ICA connection:
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● Server tab: Allows you to choose published applications or add a server and to configure
server location settings

◦ Select the appropriate radio button depending on whether the connection being created
is to a Server or to a Published Application. Click the Refresh button to update the list
of available connections of that type or a specific server name you can type.

◦ Server Location button: Click to launch the Server Location screen where you can add
or delete specific server connections, for all connections or for this specific connection.

◦ To add or delete connections for all ICA server connections, select Default from the
Server Group list.

◦ To add or delete ICA server connections for this specific connection, select Custom from
the Server Group list.

◦ Modify settings for a newly added ICA server connection using the Global ICA Setting
button on the HP Connection Administrator window. For more information about
Connection Administrator, see HP Connection Administrator on page 35.

NOTE: Adding or deleting ICA servers from the Default group on this screen adds or
removes them for all ICA connections.

● Applications: Allows you to select applications by entering a command line.

◦ Command line: If required, type the specific command line to launch an application. The
user's Citrix environment determines whether the command line is required.

◦ Working directory: If required, type the working directory information for the user's
specific environment.

● Logon: Allows you to specify logon information for connecting to a remote application. If
desired, you can specify logon information to be used when connecting the remote application.

Select Allow smartcard logon to enable smart card authentication with ICA connections.

● Window: Allows you to specify how the application window size and color. Select Seamless
Window to enable the connection to start in seamless windows mode.
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● Options: Allows you to configure Sound quality, Microphone input, SpeedScreen, Mouse
Click Feedback, Local Text Echo, Encryption level, and to Name the connection. You can also
enable Compress data stream, Enable sound, and Use disk cache for bitmaps.

Refer to Citrix documentation for a description of settings at http://support.citrix.com/servlet/
KbServlet/download/180-102-12980/Unix_Client_Admin_Guide.pdf.

NOTE: There is no one best configuration for these options. Each option may or may not
be beneficial to the connection, depending on the installed Citrix ICA environment.

The Use disk cache for bitmaps option may be slower and cause excessive wearing of the
flash drive.

● Firewall Settings: Allows you to configure the proxy address and port.

Iceweasel connection
The Iceweasel connection allows you to create a browser connection.

To configure Iceweasel:

1. Click Applications > Internet > HP Connection Administrator.

The HP Connection Administrator window opens.

2. Click Add.

The Add Connection window opens.

3. Select Iceweasel.

4. Click OK.

The Web connection window opens.

5. Complete the following settings to configure this connection:

● Start Page: Enter the Web address to launch with this connection.

● Name this connection: Type a name to associate with this connection.
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rdesktop connection
The rdesktop connection allows you to set up a remote desktop connection. rdesktop is an open source
client capable of speaking Remote Desktop Protocol (RDP). Unlike Citrix ICA, rdesktop requires no
server extensions.

To configure rdesktop:

1. Click Applications > Internet > HP Connection Administrator

2. Click Add.

The Add Connection window opens.

3. Select rdesktop.

4. Click OK.

The rdesktop connection window opens.

5. Use the following tabs to configure a rdesktop connection:

● General.

Allows you to select a remote computer and provide the logon credentials for accessing this
computer.

To select a computer:

1. Type the computer name or select a computer from the drop-down list.

2. Type the user name and password.

3. (Optional) Type the domain.

4. (Optional) In the Client Hostname field, type the host name for the terminal services
session. This entry allows you to dictate what is displayed when viewing shared
resources.

5. In Connection Settings section, type a name for the connection.
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● Display.

Allows you to configure the size and color of the remote desktop.

NOTE: Settings on the remote computer might override this setting. The remote computer
may be unable to pass to the thin client the requested settings.

● Local Resources.

Allows you to configure local devices.

This window allows you to configure the following:

◦ Remote computer sound, which allows you to play the remote computer’s sound on your
thin client, play no sound at all, or leave the sound at the remote computer.

◦ The desired keyboard language.

◦ Connection to the following local devices:

disk drives—Type the path. Using a symbolic link may result in undesirable behavior.

printers—Type the path to the printer.
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parallel ports—Type the location of the physical device. The default is /dev/lp0.

serial ports—Type the location of the physical device. The default is /dev/ttyS0.

For more information, type the rdesktop command in the console.

NOTE: To forward rdesktop connections, HP recommends redirecting from /media/usb0
(where 0 = 1st device, 1 = 2nd device, 2 = 3rd device, 3 = 4th device) for hard drive and USB
drive key. As devices are added and removed, links are automatically created in this location.
For USB CD-ROM drives, redirect from /media/cd.

You can change device ownership and attributes by editing /etc/fstab. Type man fstab or
man mount at a xterm session command line to display the options and settings available
for editing and configuring “fstab”.

If you select the Printers check box, the following window is displayed.

This window displays installed printers for you to select.

� Simply select the printer to redirect.

NOTE: When creating an rdesktop connection, if you receive a printer error (for example,
“Couldn’t open printcaps”), make sure you properly installed the printer using the printing
applet in the system setting control panel.

● Programs.

Allows you to launch programs through the remote desktop connection.
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To launch a program:

1. Select Start the following program on connection.

2. Type the program path and file name.

3. Type the folder from which you want the program to launch.

4. Click Save.

● Experience.

Allows you to configure the thin client desktop and performance factors.

You can configure the following:

◦ Connection speed: Select the speed at which the thin client connects.

◦ Desktop background: Select to allow a desktop background to display.

◦ Show contents of window while dragging: Select to allow the contents of windows to
display when you drag the window.

◦ Menu and window animation: Select to allow menu and window animation.
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◦ Themes: Select to allow themes.

◦ Bitmap caching: Select to allow bitmap caching, which places commonly used bitmaps
in a file on the thin client. This process improves performance by minimizing the amount
of display information that must be passed over a connection.

NOTE: Depending upon connection configuration, selecting Bitmap caching may or
may not improve performance.

◦ Use persistent bitmap caching: Select to allow persistent bitmap caching, which stores
bitmaps that are sent from the server on permanent media, such as a hard disk. Upon
connection, the thin client informs the server of the bitmaps it has so that the server does
not have to resend them.

NOTE: Depending upon connection configuration, selecting Use persistent bitmap
caching may or may not improve performance.

◦ Use protocol compression: Select to enable protocol compression, which makes
communication between computers faster.

◦ Use BackingStore of X server if available: Select to enable BackingStore. A
BackingStore contains the set of operations that can be performed on a JNDI Attributes.
Java Naming and Directory Interface (JDNI) is a programming interface (API) that allows
you to connect Java programs to naming and directory services such as DNS, LDAP,
and NDS.

◦ Use these additional options: Select and populate to use additional rdesktop options.

For additional information, please visit the rdesktop Web site at http://www.rdesktop.org.

XDM connection
The X Display Manager (XDM) connection window allows you to create and configure an XDM
connection.

To configure XDM settings:

1. Click Applications > Internet > HP Connection Administrator.

2. Click Add.

The Add Connection window opens.

3. Select XDM.
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4. Click OK.

The XDM connection window opens.

5. Use the following options to configure an XDM connection:

● Hostname: Type the XDM server name or server IP address.

● Display: Select the Linux display setting for this XDM connection to utilize. The display
number determines which display to use.

● VT (Virtual Terminal): Select Automatic. Consoles 9 thru 12 are available, and you can enable
other consoles by editing /etc/inittab. For example, to select Automatic, press Ctrl+Alt+F9 to
access the first XDM display. To select VT 12, press Ctrl+Alt+F12 to access the fourth XDM
display.

● Keymap: Select whether to use the language based on the local thin client settings, the server
settings, or select a specific language.

● Query Mode: Select the type of XDM connection:

◦ Broadcast: Uses the first host that replies.

◦ Indirect: Provides a list of available hosts.

◦ Direct: Uses a single host.

● Name this connection: Type a name to associate with this XDM connection.

Other
To create an Other connection:

1. Click Applications > Internet > HP Connection Administrator.

2. Click Add.

The Add Connection window opens.

3. Select Other.

ENWW HP Connection Administrator window 45



4. Click OK.

The Other connection window opens.

5. Type the full path and any necessary quoting, e.g., /urs/bin/program_name in the Command
to create process field.

For example, to launch an Xterm and then execute the command ls, type xterm –hold –e
ls in the Command to create process field.

NOTE: If a command is not properly interpreted by the shell, place commands in a script and run the
script as an Other connection.

The Other connection dialog box allows The HP Connection Administrator to launch any other
applications or command lines that are available on the system. For example, to launch an Xterm and
then execute the command ls, enter xterm –hold –e ls in the Command to create process field.

NOTE: If you are using HP Connection Administrator, you need to use a command such as xterm -
hold -e ls, so the commands output is available in the Xterm.

Advanced Configuration utility
You can configure and assign connections and configure the user interface for the terminal in the
Advanced Configuration utility. To access the utility, click the Advanced button in the HP Connection
Administrator window.

NOTE: You must log in with root permissions to access the Advanced Configuration utility.

To access the Advanced Configuration utility:

1. Click Applications > Internet > HP Connection Administrator
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2. Click Advanced.

The Advanced Configuration window opens.

Configuring available connections
The Available Connections area on the left side of the screen lists all connections that you can assign
to users. Use the following features to modify, add, or delete connections:

● Ping First column allows you to enable the Connection Administrator to ping the server before
attempting a connection. If the server name fails to resolve or the server fails to respond to the
ping, the thin client aborts the connection attempt. If you are having trouble establishing a
connection, disable Ping First.

● Click Add to create a new connection and add it to the list of available connections in the current
user's connection list.

● Select a connection and click Edit to edit the selected connection.

● Click Delete to delete a selected connection. The connection is deleted from the lists of connections
assigned to all users.

NOTE: For more information, see Adding, editing, and deleting connections on page 36.

Configuring user connections
The User Connections area on the right side of the screen displays all connections currently assigned
to the user selected from the drop-down list at the top of the window. Select a user from the list and use
the following features to configure connections for the user:
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● Name: Displays the name of the connection. You cannot change the connection name.

● Type: Displays the type of connection (Web, RDP, XDM, ICA, or other). You cannot change the
connection type from this column.

● Primary: Select the check box to designate a connection as primary. The thin client attempts
secondary connections if the primary connection fails. If more than one secondary connection is
associated with a primary connection, the thin client prioritizes the secondary connections starting
with the first connection in the group.

● Auto: Select the check box to designate whether a user is automatically logged on when HP
Connection Administrator starts up. You must log in using the root account to enable or disable
automatic connections.

● Persistent: Select the check box to designate whether the system will attempt to reconnect when
a connection fails. You can only make primary connections persistent.

● Prompt: Select the check box to configure the system to determine whether a user is still using
the thin client after a group of connections fails. Clear this check box to allow the system to continue
to cycle through the connections in the group.

NOTE: The user must quit the current session to disable automatic connection.

● Right arrow: Click to add a selected Available Connection (left list box) to the selected user’s
connection list (right list box).

● Left arrow: Click to add a selected Available Connection (left list box) to the selected user’s
connection list (right list box).

● Up arrow: Click to move a selected user connection up in the list.

● Down arrow: Click to move a selected user connection down in the list.

● Save: Click to save changes made to user connections and user interface settings.

● Cancel: Click to cancel unsaved changes made to user connections and user interface settings
and exit the Advanced Configuration utility.

● OK: Click to save changes made to user connections and user interface settings and exit the
Advanced Configuration utility.

48 Chapter 3   HP Connection Administrator ENWW



Assigning connections to users

After creating a connection using the root account, you can assign it to users.

To assign a connection to users:

1. In the HP Connection Administrator, click the Advanced button to access the Advanced
Configuration utility.

2. Under User Connections, select the appropriate user.

3. Under Available Connections, select the connection in the list of available connections, and then
click the Right arrow button to copy the connection to the list of connections for the user.

4. Click Save to save the updated list of connections for the user.

Configuring connections as primary, secondary, or to auto connect

Use the following procedure to configure connections in the Advanced Configuration utility.

● You can designate connections as primary or secondary. A primary connection is the first attempted
in a group of connections. Secondary connections are attempted if the primary connection fails,
and attempt to connect in their listed order. You can assign several primary connections, each with
several associated secondary connections.

● You can set primary connections to automatically connect when HP Connection Administrator
starts up.

● You can set primary connections to automatically reconnect if the connection is lost.
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To configure connections:

1. In the HP Connection Administrator, click the Advanced button to access the Advanced
Configuration utility.

2. Under User Connections, select the appropriate user.

3. Select the connection in the user's connection list that you want to modify.

4. If you want to make a connection a primary connection:

a. In the Primary column, select the check box.

b. To assign a secondary connection to the primary connection, clear the check box in the
Primary column that you want to be the secondary connection. The connection becomes a
secondary connection to the first primary connection directly above the secondary connection
in the list.

c. To arrange the connections in the order that you want them to connect, select a connection
and click the Up arrow and Down arrow to move the connection. Secondary connections are
always associated with the first primary connection above them in the list.

d. Click Save to save your changes.
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NOTE: Since each secondary connection must have an associated primary connection
listed above it, the connection at the top of the list must be a primary connection.

5. If you want to set automatic connections:

a. In the Auto column, select the check box.

b. Click Save to save your changes.

NOTE: You can set only primary connections to automatically connect when HP Connection
Administrator is launched.

6. If you want to set automatic reconnections:

a. In the Persistent column, select the check box.

NOTE: You cannot disable automatic connection unless the user quits the current session.

b. Click Save to save your changes.

NOTE: You can set only primary connections to automatically reconnect.

GLOBAL UI (User Interface) in KIOSK Mode
Global UI Kiosk Settings allows you to change the way the user interface is displayed.

The preview pane to the right of the check box indicates how the user interface is displayed.

● Show user interface: Select the check box to display the HP Connection Administrator. Clear the
check box to hide the HP Connection Administrator window from users who are not in the root
group. This further locks down the terminal. You can use this feature for connections set to
automatically start at boot up where the HP Connection Administrator window is not needed.

NOTE: The user interface is always shown for users in the root group.

You must reboot the terminal for changes to take effect.

● Disconnect action: Select the action taken when the user ends a session. You can force the thin
client to Continue, Shut down, or Reboot.
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Setting Citrix global settings
Click the Citrix Global Settings button to configure global Citrix settings.

Server Location

Use this tab to add or modify Citrix servers.

To add a server:

1. Select the browser type from the list in the box at the bottom of the dialog box.

2. Click Add.

3. Type the server address and port number.

4. Click OK.

5. Select the appropriate browser from the pull-down list at the bottom of the window.

6. Click Save.

Preferences

Use this tab to select the keyboard language.
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Hotkeys

Use this tab to configure thin client hot keys.

Drive Mapping

Use this tab to assign drive numbers to drives and configure whether the drive is enabled, readable,
and can be written to.
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To configure a drive:

1. Click the drive letter to configure.

2. Select the Enable, Read, or Write check boxes to assign those characteristics to the drive.

3. With the drive letter selected, click in the Path column.

4. Type the drive path.

NOTE: The preferred method of forwarding in Citrix connections with the HP Linux image is to redirect
from /media/usb0 (where 0 = 1st device, 1 = 2nd device, 2 = 3rd device, 3 = 4th device) for hard drive
and USB drive key. As devices are added and removed, links are automatically created in this location.
For USB CD-ROM drives, redirect from /media/cd. This setting will be in place for all Citrix connections
from this unit.

You can change device ownership and attributes by editing /etc/fstab. Type man fstab or man
mount at a Xterm session command line to display the options and settings available for editing and
configuring “fstab”.

COM ports

Use this tab to map devices to communication ports.
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To map devices:

1. Click Add.

2. Under Folders, select the location of the device.

3. Under Files, select the device.

4. Fill in the Selection: /dev field.

5. Click OK.

ENWW HP Connection Administrator window 55



4 Citrix

This chapter provides an overview of the Citrix (ICA) program. For more detailed help in configuring the
Citrix client, see the Clients for UNIX Administrator’s Guide at http://support.citrix.com/docs/.

Introduction
The Linux thin client offers two different options you can use to establish an ICA connection:

● Citrix ICA Connection Manager—software application developed by Citrix Corporation.

● HP Connection Administrator—user interface developed by HP.

NOTE: Certain Citrix functions, such as Citrix ICA PNAgent capability, are not accessible under
HP Connection Administrator.

You can access Citrix ICA by clicking Start > Programs > Apps > Net > Citrix ICA Connection
Manager.

Citrix (ICA)
The Citrix (ICA) Connection Manager allows you to set up and configure Citrix ICA client connections.

To access the Citrix ICA Connection Manager, click Applications > Internet > Citrix Presentation
Server Client.
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ICA Client Settings
To view or set the preferences for ICA, select Tools > Settings. From the Settings window, you can
select keyboard layouts and types, enable or disable sounds, configure audio input, and allow automatic
client updates.

Preferences
From the Settings window, you can configure Window color and size, determine server location,
configure hot keys, configure or clear disk cache, map drives, add COM ports, configure firewall, enable
auto reconnect, and configure PNA.

Connection View
In Connection View, you can create, modify, or launch connections, and begin a session on a Citrix
server. To access Connection View, click View > Connection View.

Program Neighborhood Agent (PNAgent)
In PNAgent View, you can view and activate the applications that have been published in the
Neighborhood on a Citrix server or server farm. To access PNAgent View, click View > PNAgent
View.
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5 Support

If you require support for your Linux-based thin client, contact your region’s HP Technical Support
Center. While HP provides support for Linux-based thin clients, HP does not provide technical support
for the Linux operating system or application components that are obtained from the open source
community.

Support contact information is available at the Contact HP link on the HP home page or at
http://welcome.hp.com/country/us/en/contact_us.html.

Hardware warranty
The hardware warranty is three years limited coverage and can be upgraded by purchasing an optional
HP Care Pack.

Software warranty
The software warranty covers several features, including:

● Altiris Remote Management Client

● Citrix Client

● Network Management Applet

NOTE: Altiris is supported directly by Altiris, Inc. All other services and features are from open source
community packages and are not supported by HP.

Image updates and add-ons
HP provides periodic updates to the image, as well as add-ons. Check the HP support site for important
documentation that provides specific information for your image version and for installing add-ons. You
can find support documentation at http://www.hp.com/support/.

To search for support documentation, enter your country and product name, and then click Manuals.

Custom image requests
To obtain a custom image from HP, contact your HP Account Team, which will work through the HP
Specials Process to understand the opportunity, image requirements, schedule, and costs involved.
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Availability of Linux Open Source code
You can get the source code for Open Source components contained in the HP t5735 in three ways:

● Go to http://www.debian.org or the Debian stable repositories, locate the specific file you are
interested in, and then download the source files.

● Download the source file package from the HP Debian repository located at ftp://ftp.hp.com/pub/
tcdebian.

● On media by mail: Source code is available only on recordable media. To obtain the media, contact
your local HP Customer Support Center. HP may charge a nominal fee for the media.
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6 Frequently Asked Questions

.

Linux operating system
Question Answer

How do I tell what the image version/build number is? To obtain the image version, from the desktop click
Applications > System Tools > HP System Information.
The dialog box provides system information, including the
image version. The image version number is obtained from the
file /etc/imageid.

How and where is the Linux image stored in flash memory? The image is stored in various formats. The boot up process
decompresses and loads certain portions of the image in RAM.
Some features and aspects of the image are not loaded until
they are needed. The image is stored in the following partitions
(both are formatted as ext2):

/dev/hda1 - /

/dev/hda2 - /mnt, /root, /home, /media

System Administration
Question Answer

How are users managed? A system administrator creates new user accounts and
assigns users to groups. The two recommended methods to
manage users are:

● You can install the GNOME-system-tools package and
use the Users and Groups application in the Desktop >
Administration menu.

● Standard command-line tools to manage users. Letter
case matters when using command line names and
option switches.

System Management
Question Answer

How do you configure the system hardware clock? Set the system hardware clock using the BIOS setup utility:
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Question Answer

1. Reboot the system and press F10.

2. After the Setup utility displays, press Esc.

3. Select the standard CMOS features option and press
Enter.

4. Set the date and time using Page Up and Page Down.

5. To save the changes, press F10 and Enter.

How do you configure the date and time? The date and time can be configured either from the command
line or from Applications > System Tools > HP Date and
Time Manager.

How do you change the boot order? Run the BootOrder utility to alter the order of the boot up
device. The utility is installed with the standard image.

To run the BootOrder utility, perform the following steps:

1. 1. Click Applications > Accessories > Root Terminal.

2. To use the BootOrder utility, execute cd /usr/share/
hp, then type ./hpbootorder and follow the listed
options.

To use the RepSet utility, execute ./ hprepset (without
parameters) and follow the listed options.

How do you synchronize the BIOS and system time? To synchronize the BIOS and system time, use the hwclock
command. This command allows you to either synchronize the
BIOS time to the system time, or synchronize from system time
to BIOS time. This command without any parameters displays
the current date and time.

hwclock [-r|--show] [-s|--hctosys] [-w|--
systohc] [-l|--localtime] [-u|--utc]

Query and set the hardware clock (RTC).

Options

● -r: Read hardware clock and print result

● -s: Set the system time from the hardware clock

● -w: Set the hardware clock to the current system time

● -u: The hardware clock is kept in coordinated universal
time

● -l: The hardware clock is kept in local time

● –directisa: to the hwclock command or it will not work

How do you set up a kiosk? Login as user. Use Desktop > Preferences > Session to
choose which applications to start. You may remove nautilus
and gnome-panel and add /usr/bin/cman to use HP
Connection Administrator instead. Install Pessulus or gconf-
editor and configure it, if further lockdown is desired.
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Question Answer

NOTE: Default key bindings allow Alt+F2 to run an
application unless disable command line is configured in the
Pessulus Lockdown Editor or in the desktop/gnome/lockdown
tree of the gconf Configuration Editor.

Why can I not select certain resolution that I believe my monitor
supports?

The graphics controller, driver and monitor must all support the
desired resolution with appropriate timing parameters,
furthermore some utilities do not allow resolutions above the
current resolution to be selected. HP recommends using the
HP Display applet for changing screen resolutions. Please
see /var/log/Xorg.0.log for more details. Possible workarounds
include disabling the xrandr extension and editing /etc/X11/
xorg.conf.

Why can I not to see widescreen resolutions modes on my
t5725 after I load the t5735 image onto my t5725?

The t5735 has a different chipset and video driver. The t5725
does not support all of the video or widescreen resolutions
modes that are supported on the t5735.

When I have two monitors connected, why does one screen
move around with the mouse?

This occurs on one of the monitors when a high resolution is
selected that the smaller monitor can not handle. The smaller
monitor has the same desktop size but does not display the
whole screen, as such the screen pans with the movement of
the mouse to allow viewing of all parts of the desktop.

Why do I get an error message when I press F1 or click on help
in a window?

The GNOME-user-guide was not installed by default to save
space. The administrator can install this package, if it is a
requirement, from the Debian repositories.

Why don’t my internal speakers turn off when I insert a jack
into the front audio plug?

This behavior is by design to allow simultaneous audio output
from both devices, which may be playing different content. To
disable the internal speakers, open the GNOME ALSA Mixer
(click Application > Sound & Video > Gnome ALSA Mixer),
check Mute under Front to disable the internal speaker, and
check Headphone to enable the front jack.

Why does my image get corrupted after FTP update is
complete?

The t5735 does not support FTP image updates.

General
Question Answer

Are there any hot keys? Yes, see the following:

● Ctrl+Alt+F1 to Ctrl+Alt+F6: Starts the different gettys,
which can be disabled if unused by editing /etc/inittab.

● Ctrl+Alt+F7: Default X server.

● Ctrl+Alt+F8: Syslog (configure with /etc/syslog.conf).

● Ctrl+Alt+F9: Default first XDM session.

● Ctrl+Alt+Backspace: Logs off the current session and
displays the login dialog. If the client is set to auto logon,
the auto logon completes.

● Ctrl+Alt+Left/Right: Switch to left/right workspace.

● Alt+Tab: Switches the active application focus.
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Question Answer

● Alt+F2: Show the run application dialog.

● Alt+F4: Close a window.

● Alt+F9: Minimize a window.

● Alt+F10: Maximize a window.

For more information about hot keys, click Desktop >
Preferences > Keyboard Shortcuts.

The wrong characters display when I use the keyboard? Click Desktop > Preferences > Keyboard. Click the
Layouts tab and make sure the correct keyboard is selected.

How do I launch Connection Administrator? 1. Click Desktop > Preferences > Sessions.

2. Add a command to run /usr/bin/cman on the
Startup Programs tab.

How do I lock the desktop for users to resemble Kiosk mode? To configure the user's desktop settings:

1. Log on as the user and delete any unwanted icons.

NOTE: If you do not want desktop icons and wallpaper,
comment out or remove the line that starts nautilus on
the Current Session tab of the Desktop >
Preferences > Sessions tab.

How can I install a flash player onto the t5735? One possible way to install a flash player would be to append
non-free to the end of the Debian repository entry in /etc/apt/
sources.list and install the flashplugin-nonfree package, if you
agree with the license terms.

How can I install Sun Java onto the t5735? One possible way to install Sun Java would be to install the
sun-java5-jre package or the latest package from
http://www.backports.org.

How do I disable the disconnect button in HP Connection
Administrator?

Set ALLOW_DISCONNECT=FALSE in /etc/hpoptions.

Manageability
Question Answer

Are there any updates necessary for Altiris Deployment Server
to work on an HP Compaq Linux thin client?

Yes. There is a hot fix available from Altiris which includes
updates to the imaging process and the DOS agent
Bootwork.exe. This hot fix includes a sample script that allows
capture and deployment of images using Rdeployt.exe, as well
as a new Bootwork.exe file that recognizes the bootloader in
the image. This hot fix is available from the Altiris Web site
support page.

What are the steps to capture and deploy an image on an HP
Compaq Linux thin client?

The thin client supports the Linux version of the Altiris Remote
Management Client. Altiris management software allows you
to remotely capture and deploy Linux images. You can use the
Altiris Rdeployt tool, a text-base utility, to perform this function.

Capturing an Image:
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Question Answer

HP Compaq Thin Client Actions (Required)

1. Create an Altiris script to run usr/share/hp/
hpbootorder nuh.

or

1. Reboot the client and launch the F10 System
Configuration Setup Screen.

2. Select the Advanced BIOS Features option and press
Enter.

3. Select the First Boot Device option and press Enter.

4. Select the Network option and press Enter.

5. Press F10 to save the configuration.

6. Press Enter to save and exit.

Altiris Deployment Server Console Actions

1. Double-click the Deployment Server Console icon from
the desktop to open the Deployment Server Console.

2. Right-click on the lower left window and select New
Job.

3. In the empty field, type Image Capture and press
Enter.

4. From the upper right window, click Add.

5. From the drop-down menu, select Run Script.

6. In the Run this Script window, type the following
command: rdeployt -mu -raw -f.\images
\test.img

NOTE: test.img is used for this example. You may
select any name for the.img file.

7. Select the DOS radio button from In which OS would
you like to run this script?

8. Click Finish.

You can drag and drop this job to any Linux unit to capture its
image.

How is an image deployed using Altiris? An image can be deployed by performing the following steps:

HP Compaq Thin Client Actions (Required)

1. Create an Altiris script to run /usr/share/hp/hpbootorder
nuh.

or

1. Reboot the client and launch the F10 System
Configuration Setup Screen.

2. Select the Advanced BIOS Features option and press
Enter.
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Question Answer

3. Select the First Boot Device option and press Enter.

4. Press F10 to save your configuration.

5. Press Enter to save and exit.

Altiris Deployment Server Console Actions

1. Double-click the Deployment Server Console icon from
the desktop to open the Deployment Server Console.

2. Right-click the lower left window and select New Job.

3. In the empty field, type Image Deployment and
press Enter.

4. From the upper right window, click Add.

5. From the drop-down menu, select Run Script.

6. From the Run this Script window, type the following
command: rdeployt -md -raw -f.\images
\test.img

NOTE: test.img is used for this example. You may
select any name for the .img file.

7. Select the DOS radio button from In which OS would
you like to run this script?

8. Click Finish.

9. To deploy an image, you can drag and drop this job to any
HP Compaq Linux thin client.

How can a factory image be restored locally? A factory image can be restored locally using USB drive key or
USB CD-ROM. Instructions for this procedure are available on
the HP Compaq Thin Client Linux Image SoftPaq.

Can you capture and deploy settings separately from an
image?

Yes. HP has developed custom scripts for Altiris that capture
system settings and defined HP Connection Administrator
connections from a source HP Compaq Linux thin client
system through the Altiris deployment console. You can then
deploy these captured system settings and connections out to
a target HP Compaq Linux thin client system through the Altiris
deployment console. For more information, see the white
paper entitled Altiris Manageability Scripts for HP Compaq
Linux Thin Clients at http://h20000.www2.hp.com/bc/docs/
support/SupportManual/c00448511/c00448511.pdf.

Are there other management methods available from HP to
manage HP Linux thin clients?

Yes, you may update images using new HP FTP image update
and DHCP image update for HP Linux thin clients. For more
information, see the white paper entitled, FTP/DHCP Image
Update for HP Linux Thin Clients available on the
http://www.hp.com product support site.
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7 Troubleshooting

Altiris
ISSUE

Altiris fails to restore my Debian image from a USB storage device.

SOLUTION

This issue occurs with Altiris versions prior to 6.8.177. The issue does not occur with Altiris 6.8.177 or
higher. Update to a more recent version of Altiris.

HP Connection Administrator
ISSUE

Launching a connection changes the connection state to active then immediately back to not
connected without establishing a connection.

SOLUTION

There can be a variety of reasons for this behavior. If the connection is set to ping first and the host
name cannot be resolved, the target is behind a firewall or unable to successfully ping the target. As a
workaround, disable Ping first under Advanced settings for the connection. As a diagnostic step, try
pinging the host from a console.

Citrix ICA
ISSUE

After connecting to Adobe Acrobat as a Published Application and then shutting down the connection,
the Adobe process does not properly terminate and will not allow you to relaunch an Adobe session.

SOLUTION

HP Connection Administrator is designed to prevent multiple instances of the same connection to run.
To resolve this issue, update to a newer version of Adobe or contact Citrix for an alternative solution.

ISSUE

The Audio input feature is grayed out in Citrix ICA client and the microphone input does not work even
with this feature enabled in HP Connection Administrator.
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SOLUTION

When there is no existing /etc/.hpconman/wfclient.ini, cman uses the one created by wfcmgr, but there
is an entry missing from the default wfclient.ini that is only created after you enable it through wfcmgr.
If you have already run cman, you need to remove the version without AllowAudioInput=True and enable
audio in wfcmgr so that cman will create a new version with the correct value.

ISSUE

USB storage devices that are automatically mounted and then mapped through an ICA connection with
enabled read and write options fail to save, edit or delete files on the USB device.

SOLUTION

One workaround for this Citrix ICA issue is to change /etc/fstab and /etc/hal/devices.d/50-
pmount.hal to umask-000. However, you should evaluate the security implications of this workaround
in your specific environment.

rdesktop
ISSUE

You add a rdesktop connection with the default settings, and then change the video size to 200 percent
or to full screen on Media Player, and no video displays.

SOLUTION

1. In HP Connection Administrator, select the connection, and then click Edit.

2. Click the Experience tab.

3. Clear Bitmap caching and Use persistent bitmap caching.

Iceweasel
ISSUE

Iceweasel inside HP Connection Administrator is not recognizing the proxy settings from the desktop
version of Iceweasel.

SOLUTION

If behind a firewall, disable ping first, because most firewalls block ping.

ISSUE

When Auto is enabled in HP Connection Administrator for an Iceweasel connection with two Iceweasel
secondary connections, the error Iceweasel is already running , but it is not responding message
is displayed.

SOLUTION

To open new Iceweasel windows, you must first close the existing Iceweasel process or restart the
system. This is a known Iceweasel issue for the shipping version. Please see http://kb.mozillazine.org/
Profile_in_use for more information.

ISSUE
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System intermittently hangs while running Iceweasel 2.x.

SOLUTION

This occurs because the flash file system has no available space, which may be caused by the Iceweasel
2.x list of suspected forgery sites that are downloaded to the client by default. Try disabling this feature
by clearing the Tell me if the site I’m visiting is a suspected forgery check box under Iceweasel
2.x > Tools > Security. If you install a version of Iceweasel that you did not obtain from HP, you may
also want to run the /usr/share/hp/Iceweaseltweaks script as root from an Xterm or console to
reduce unnecessary writes to the flash disk.

XDM
ISSUE

You cannot run an X application to a local machine when you Telnet to a remote XDM.

SOLUTION

The default configuration disables this functionality because of security concerns. You can enable by
removing –nolisten TCP from /etc/X11/wdm/Xservers and restarting the X server.

ISSUE

Keyboard is dead/locks up when VT is set between 1 and 6 in an XDM connection.

SOLUTION

VTs 1 through 6 are reserved as additional gettys by default. Press the power button to shutdown, then
either select a different VT or modify /etc/inittab and comment out the line that creates the getty
you would like to use. Reboot for the changes to take effect.

Kiosk
ISSUE

When you shut down or reboot while in Kiosk mode, you get a blank, blue screen and no connection.

SOLUTION

This occurs at logout when a non-root user is in Kiosk mode with no auto-connection and the user was
not granted rights from the administrator to reboot or shut down the system.

Printing
ISSUE

You cannot print a large job to local printers in rdesktop sessions.

SOLUTION

This issue may occur if a large volume of documents or an individually large document is sent to the
local printer. Try to send large documents to a printer that is not connected locally to the thin client. If
you want to print multiple documents, allow the print queue to clear before submitting the documents.
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ISSUE

You cannot print large jobs to local printers from an ICA session.

SOLUTION

The thin client has limited space available for the print spooler. This issue may occur if a large volume
of documents or an individually large document is sent to the local printer. Try to send large documents
to a printer that is not connected locally to the thin client. If you want to print multiple documents, allow
the print queue to clear before submitting the documents.

ISSUE

You set up a new printer using Printer Manager. When you test the printer, you receive an error message
“Printer Test Failed!!!”

SOLUTION

The entry in the Printer Name field cannot contain spaces. Remove any spaces from the entry in this
field. You can use spaces for the description.

ELO Touch Monitor
ISSUE

While using an ELO Touch screen monitor, you log out by clicking Start > Window Manager > Log
Out, and the ELO Touch monitor stops accepting touch commands. After a power cycle the monitor
functions correctly.

SOLUTION

Log out by pressing the Ctrl+Alt+Backspace keys.

USB
ISSUE

Automount only supports the first partition of an external drive.

SOLUTION

Mount the other partitions manually or add entries for them to /etc/fstab.

Network
ISSUE

Attempts to ping a host result in message “unknown host” error in a mixed Windows and Linux
environment.

SOLUTION

One possible solution is to install the winbind package from the Debian repositories using Synaptic or
Aptitude and configure for the specific environment. After installing it, edit from a command line /etc/
nsswitch.conf and add the word wins to the end of the hosts: line.
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ISSUE

Attempts to ping the client result in message “unknown host” error.

SOLUTION

Ensure the host name is correct and includes a fully qualified domain name (FQDN) for the applicable
domain where the thin client is located. You may also need to add the FQDN in /etc/hosts.
Modify /etc/dhcp3/dhclient.conf and enter the option send host-name [FQDN].

Keyboard
ISSUE

The local keyboard settings do not match the actual characters on my keyboard.

SOLUTION

The characters used in the keyboard mappings are defined by the xserver provided by the Debian
repository and can be modified either by changing the source files in /etc/X11/xkb or by running the
xmodmap command from the users ~/.xsession script. This latter method is used by the hptc-
keyboards package available in the HP repository to customize the international keyboard provided by
HP.

Multimedia
ISSUE

Attempting to play video with the default install of the mplayer package from
http://www.debian-multimedia.org causes this message to appear: Error opening/initializing the
selected video_out (-vo) device.

SOLUTION

Open the Preferences dialog, select the Video tab, and select a different driver. The xv or x11 drivers
seem to provide the best performance.

Miscellaneous
ISSUE

The system intermittently hangs.

SOLUTION

Check available flash space with the command df –h from an xterm or console. You may need to
delete unnecessary files. One possible alternative is to install localepurge from the Debian repository
or delete documentation files by running the /usr/share/hp/cleandocs script from an xterm
console.
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8 Useful information

See the following Web sites for information relevant to the Linux thin client.

Site URL

Linux Online http://www.linux.org

Linux.com http://www.linux.com

Linux on Laptops http://www.linux-laptop.net

Linux Security http://www.linuxsecurity.com

Linux Journal http://www.linuxjournal.com

Linux Gazette http://www.linuxgazette.com

HP white papers. To search for white papers, type your
country, product name, and then click Manuals.

http://www.hp.com/support/

Debian http://debian.org

Debian — Wikipedia definition http://en.wikipedia.org/wiki/Debian

Debian backports http://backports.org

Debian GNU/Linux System Administration Resources http://debian-administration.org

Debian Linux Kernel Handbook http://kernel-handbook.alioth.debian.org

Debian Security Information http://www.us.debian.org/security

Debian Help http://www.debianhelp.co.uk

Getting Help with XFree86 http://www.xfree86.org/sos

Synaptic Package Manager — Wikipedia definition http://en.wikipedia.org/wiki/Synaptic_Package_Manager

The Linux Documentation Project http://tldp.org

Debian Multimedia http://www.debian-multimedia.org

GNOME http://www.gnome.org/

GNOME Desktop User Guide http://library.gnome.org/users/user-guide/stable/
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