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Introduction 
This white paper covers the Advanced Host Controller Interface (AHCI) and 
Redundant Array of Independent Disks (RAID) drive technologies that are provided 
on the HP Compaq Elite 8000, 8100, and 8200 (hereafter referred to as the 8000-
series) Business PC products. This white paper provides a basic overview of AHCI 
and RAID technology, supported factory configurations of HP Elite 8000-series 
Business PCs, other supported RAID configurations, and basic instructions on how 
to migrate non-RAID to RAID configurations in the field. HP also provides a Smart 
IV Hard Drive technical white paper for Smart IV Technology on HP Business 
Desktop Hard Drives on www.hp.com.  
AHCI is a hardware mechanism that allows software to communicate with Serial 
ATA (SATA) devices. It is enumerated as a PCI device and it transfers data between 
system memory and SATA devices.  
The HP Elite dc7900 Business PC was the first HP business PC to have AHCI as the 
default SATA emulation mode in BIOS. All previous HP business PCs that supported 
SATA were in IDE (legacy) SATA emulation mode by default.  
HP Elite 8000-series Business PC products provide support for AHCI in single and 
multiple drive configurations.  
RAID (Redundant Array of Independent Disks) is a category of hard drives that 
employs two or more drives in combination for fault tolerance and performance. 
Initially used with servers, desktop PCs are increasingly using RAID by adding a 
RAID controller and extra IDE or SCSI disks.  

http://www.hp.com/�
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HP Elite 8000-series Business PCs take advantage of Serial Advanced Technology 
Attachment (SATA) technology and the integration of RAID support into select Intel 
chipsets. Table 1 lists the HP business PC platforms and associated Intel chipsets 
that provide native RAID support. 

Table 1. HP Elite 8000-series Business PCs and Intel chipsets with RAID support 
HP business PC Intel chipset Chipset components (#; type) 

Elite 8000 Q45 Express 2; Q45 GMCH & 82801 ICH10 

Elite 8100 Q57 Express/5 Series 1; Q57 PCH-DO 

Elite 8200 Q67 Express/6 series 1; Q67 PCH-D0 

 
This white paper provides a basic overview of RAID technology, supported factory 
configurations of HP Elite 8000-series Business PCs, other supported RAID 
configurations, and basic instructions on how to migrate non-RAID to RAID 
configurations in the field.  
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Basics of AHCI and RAID Technology 

Definitions 
Table 2. Basic AHCI and RAID Definitions 

 
Acronym or term Description 

AHCI  Advanced Host Controller Interface, a specification for hardware 
and software, is a registered interface for SATA, intended to add 
higher speed, NCQ and other features. 

ATA  Advanced Technology Attachment.  

BIOS  Basic Input/Output System, also known as system ROM.  

Chipset  Term used to define a collection of integrated components required 
to make a PC function.  

HDD  Hard disk drive  

ICH The Input/Output Controller Hub. This component includes the 
mass storage controller. ICH is part of the Intel Q45 Chipset 

IDE  Integrated Drive Electronics  

INF  

Information file (.inf) used by Microsoft® operating systems that 
support the Plug & Play feature. When installing a driver, this file 
provides the operating system needed information about driver 
filenames, driver components, and supported hardware. 

Migration  Term used to describe the movement of data from one 
configuration or usage model to another.  

NCQ  Native Command Queuing.  

Option ROM  

Piece or software module inside the System BIOS which provides 
extended support for a particular piece of hardware. The RAID 
Option ROM provides boot support for RAID volumes as well as a 
user interface for managing and configuring the system's RAID 
volumes. 

PCH  Platform Controller Hub. This component includes the mass storage 
controller. PCH is part of the Intel Q57/Q67 chipset 

PCI  Peripheral Components Interface.  

PCIe  PCI express. A serial version of PCI.  

PnP  Plug and Play  

RAID  Redundant Array of Independent Disks.  

ROM  Read Only Memory.  

SATA  Serial ATA  

Strip  Set of data on a single hard drive in a RAID 0 volume.  

Stripe  Group of all strips going horizontally across all the hard drive 
members of a RAID volume.  
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Benefits of AHCI 
AHCI provides several benefits: 
• Elimination of master/slave handling  
• Native Command Queuing (NCQ)  
• Hot-plugging  
AHCI mode eliminates the master/slave topology for cabling SATA hard drives. 
Hardware and software that emulate IDE still have some limitations with the 
master/slave topology that came from the Parallel ATA (PATA) mass storage 
implementation. With AHCI mode, there is no need to worry about cabling 
considerations, other than the boot drive should be on the lowest numbered SATA 
port (dark blue connector). SATA ports are independent of each other and are not 
tied together by master/slave relationship.  
Native Command Queuing (NCQ) is technology that allows a SATA device to 
internally optimize the order of command execution for increased performance. 
Commands sent to a NCQ-capable SATA device are placed in an internal queue 
where they can be dynamically and intelligently re-ordered and tracked.  
Hot-plugging is the ability to insert a SATA device into a running system and have 
the operating system recognize the device. AHCI is required for eSATA hot-plug 
functionality. Refer to the “Using eSATA on HP Compaq Business PCs” white paper 
for more information about eSATA hot-plugging. 

BIOS / Software / Hardware Considerations 

BIOS Interface 

SATA Emulation Mode 
SATA emulation mode can be set in F10 Setup by selecting Storage > Storage 
Options > SATA Emulation > Default - AHCI.  
SATA emulation mode is set to AHCI by default. This is a change from previous HP 
Compaq dc7xxx Business PCs, which had a default SATA emulation mode of IDE 
(legacy).  
RAID SATA emulation mode includes AHCI functionality. Customers purchasing a 
RAID system do not need to make any changes in F10 Setup.  

BIOS Support for _GTF in ACPI Mode  
The system BIOS supports the Get Task File (_GTF) ACPI control method while in 
AHCI mode. However, a Registry key is required to enable the port(s). See the 
_GTF Support section for more information.  
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Software Drivers 

AHCI Driver 
In addition to setting the SATA emulation mode of AHCI or RAID in F10 Setup 
(See BIOS Interface section for more information), an AHCI driver is required 
for AHCI support.  

The Windows Vista™ or Windows 7 image that ships with the HP Elite 8000-
series Business PC has the Intel AHCI driver (iastor.sys) pre-loaded. The system can 
be freely switched between IDE to AHCI.  

Note 
In order to reuse a hard drive from a RAID configuration in 
AHCI mode, it is necessary to remove RAID metadata 
from the drive. This can be accomplished using low level 
system format or Option ROM interface. 

For customers who do not use the pre-installed HP image, there are several 
scenarios for using AHCI:  

New operating system installation  
A fresh installation of Windows XP, Vista or Windows 7, while in AHCI mode, is 
the most straightforward way of installing the AHCI driver.  
Windows XP requires adding the Intel AHCI driver with the F6 option during 
installation. Windows Vista and Windows 7 has native AHCI support, so either the 
native AHCI driver will be used or the Intel AHCI driver can be added.  
An existing Windows XP, Vista or Windows 7 image using the native AHCI driver 
can be updated to use the Intel AHCI driver (iastor.sys). The driver can be 
downloaded from www.hp.com.  

Enhancing existing Vista or Windows 7 images from IDE mode or 
native AHCI mode  
Vista and Windows 7 have a native AHCI driver. If Vista or Windows 7 was 
installed while in IDE mode, a registry change will allow users to gracefully switch 
to AHCI mode using the Microsoft driver. See the Microsoft Knowledge Base Article 
at http://support.micorsoft.com/kb/922976/en-us  
Corporate IT may be able to update an existing Vista or Windows 7 image that 
was created in IDE mode to use the Intel AHCI driver. The process requires inserting 
the Intel AHCI drivers into the image in a pre-installation environment using the 
appropriate OS Tools.  
Required software to insert the Intel AHCI driver:  
• Windows Preinstallation Environment (WinPE) CD  
• Windows OPK (OEM Preinstallation Kit) CD  
• PKGMGR.EXE (Package Manager)  

http://www.hp.com/�
http://support.micorsoft.com/kb/922976/en-us�
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The OPK CD is not available for general download. It must be obtained through a 
Microsoft authorized distributor. PKGMGR.EXE is a tool that installs, uninstalls, 
configures, and updates features and packages for Vista and Windows 7.  
For more information and instructions on OPK or PKGMGR.EXE, go to 
http://www.hp.com.  
The process is as follows:  
1. Boot into WinPE. 
2. Run PKGMGR.EXE from OPK. 
A sample command line is:  
pkgmgr.exe /o:"C:\;C:\Windows" /n:"C:\AddAHCI\HP-AHCI.xml" 
Where C:\AddAHCI\HP-AHCI.xml contains: 

<?xml version="1.0" ?>  

<unattend xmlns="urn:schemas-microsoft-com:asm.v3" 
xmlns:wcm="http://  

schemas.microsoft.com/WMIConfig/2002/State"> 

  <settings pass="offlineServicing"> 
   <component name="Microsoft-Windows-
PnpCustomizationsNonWinPE"  
processorArchitecture="x86" 
    publicKeyToken="31bf3856ad364e35" language="neutral"  
versionScope="nonSxS"> 
     <DriverPaths> 
      <PathAndCredentials wcm:keyValue="1"> 
 <Path>C:\AddAHCI</Path> 
      </PathAndCredentials> 
     </DriverPaths> 
   </component> 
  </settings> 
</unattend> 
3. Reboot the computer. 
4. Enter F10 Setup and change SATA Emulation mode to AHCI. 
5. Reboot the computer into the OS. 
An existing Vista or Windows 7 image using the native AHCI driver can be 
updated to use the Intel AHCI driver (iastor.sys). The driver can be downloaded 
from www.hp.com.  

Note 
Be careful when moving an image to computer with a 
different chipset. The Device ID of the AHCI controller must 
match what is in the INF or the AHCI driver will fail and 
the computer will not boot. 

http://www.hp.com/�
http://www.hp.com/�
http://www.hp.com/�
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Enhancing existing Windows XP images from IDE Mode  
Corporate IT may be able to update an existing Windows XP image to be AHCI-
compatible that was created in IDE mode. The process requires inserting the AHCI 
drivers into the image in a pre-installation environment. Once that is done, the 
system can be switched to AHCI mode safely.  
Required software to insert the AHCI driver:  
• Windows Preinstallation Environment (WinPE) CD  
• Windows OPK (OEM Preinstallation Kit) CD  
• MSDINST.EXE (Mass Storage Device Installer)  
The OPK CD is not available for general download. It must be obtained through a 
Microsoft authorized distributor. MSDINST.EXE is a tool designed to insert mass 
storage drivers into an offline Microsoft Windows XP image.  
For more information and instructions about OPK or MSDINST.EXE go to 
http://www.microsoft.com. 
The process for updating an existing Windows XP image to be AHCI compatible is 
as follows:  
1. Boot into WinPE.  
2. Run MSDINST.EXE from OPK.  

MSDINST.EXE is executed from a command line where the location for the .inf 
file containing the PnP ID of the RAID/AHCI SATA controller of the target 
system and location of the Windows directory are specified.  
For example: Newmsd.inf has the PnP IDs and it is in the C:\AddAHCI 
directory. C:\Windows is the location of the Windows directory. The command 
line is: 
 
msdinst.exe c:\AddAHCI\newmsd.inf c:\windows /force  
 
Newmsd.inf contents: 
[SysprepMassStorage] 
PCI\VEN_8086&DEV_2822&CC_0104 = 
C:\Compaq\MSD\Intel\iaStor.inf 
PCI\VEN_8086&DEV_3A02&CC_0106 = 
c:\Compaq\MSD\Intel\iaahci.inf 
PCI\VEN_8086&DEV_3A22&CC_0106 = 
c:\Compaq\MSD\Intel\iaahci.inf 
PCI\VEN_8086&DEV_3B22&CC_0106 = 
c:\Compaq\MSD\Intel\iaahci.inf 
PCI\VEN_8086&DEV_1C02&CC_0106 = 
c:\Compaq\MSD\Intel\iaahci.inf 
…where: 
Dev 2822 is the device ID for Intel(R) ICH8R/ICH9R/ICH10R/DO/PCH SATA 
RAID Controller  
Dev 3A02 is the device ID for Intel(R)  ICH10D/DO SATA AHCI Controller  
Dev 3A22 is the device ID for Intel(R)  ICH10R SATA AHCI Controller  
Dev 2B22 is the device ID for Intel(R)  PCH SATA AHCI Controller. 
Dev 1C02 is the device ID for Intel(R)  Desktop/Workstation/Server Express 
Chipset SATA AHCI Controller. 

http://www.microsoft.com/�
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3. Reboot the computer.  
4. Enter F10 Setup and change SATA Emulation mode to AHCI. 
5. Reboot the computer into Windows XP.  

_GTF Support (HP 8000 and 8100 Business PCs only) 
HP Elite 8000 and 8100 Business PCs support _GTF (Get Task File) AHCI control 
method when in AHCI mode. The Intel AHCI driver needs a registry key to enable 
_GTF for each port. This registry key has been added with the Windows XP, Vista 
or Windows 7 image that ships with HP Elite 8000 and 8100 Business PCs.  
For customers using their own image, the following key is required:  
 
HKLM\System\CCS\Services\iaStor\Parameters\Port[X] 
name:GTF 
value: 0=disabled 1=enabled 
 

…where [X] represents the physical AHCI port of the connected drive to be _GTF 
enabled. To enable _GTF support for all ports, set this value under each port (Port0, 
Port1...PortN). 

Hardware 
The HP Elite 8000-series Business PCs uses Intel chipsets that support an AHCI 
capable Host Bus Adapter (HBA). This HBA supports ATA and ATAPI devices in 
both PIO and DMA modes with NCQ as long as the device supports NCQ.  
All hard drives shipped with the HP Elite 8000-series Business PCs are NCQ 
capable.  

Limitations 
NCQ functionality requires both HBA and hard drive to support it. Non-NCQ 
capable hard drives will not see any performance benefits even though the HBA is 
NCQ capable.  
Hot-plugging is not possible in an operating system without an AHCI driver that 
supports hot-plugging, such as DOS, Windows 9x, Windows NT4.0, and older 
versions of Linux.  

Changing AHCI to IDE Mode through the HP Replicated 
Setup Utility 
Multiple AHCI systems can be reverted back to IDE mode using the HP Replicated 
Setup Utility. This utility allows for system BIOS settings to be replicated and 
distributed throughout an enterprise. The procedures and information about how to 
obtain the Replicated Setup Utility are described in the HP white paper “Business 
Desktop UEFI BIOS Tools” available at www.hp.com. 
 

http://www.hp.com/�
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Basic RAID Types 
This section provides a brief explanation of the supported RAID configurations for 
HP Elite 8000-series Business PCs.  

RAID 0 with two hard drives (Striped)  
Even though HP supports RAID 0, it is not the recommended configuration for 
business PC users. Lack of redundancy causes less than half the reliability of a 
single hard drive system since the Mean Time Between Failure (MTBF) of RAID 0 is 
equal to the MTBF of an individual drive, divided by the number of drives.  

Table 3. RAID 0 with two hard drives (Striped) 
First Disk Second Disk 

Data Segment 1  Data Segment 2  

Data Segment 3  Data Segment 4  

Data Segment 5  Data Segment 6  

Data Segment 7  Data Segment 8  

Data Segment 9  Data Segment 10  

Data Segment 11  Data Segment 12  

Data Segment 13  Data Segment 14  

Data Segment 15  Data Segment 16  

In the previous table, each “Data Segment n” represents a group of data, known as 
a strip. In this case, each row represents a stripe. RAID 0 represented in the table 
above shows how information is segmented, made into chunks or strips, and stored 
across the stripes of the hard drive members of this RAID volume.  
To better illustrate the concept of RAID 0 and striping, Figure 1 shows how a 
sequence of data “ABCD...” is stored in a RAID 0 mode. In this example, each 
letter represents a segment or strip. The graphic shows how the various pieces of 
the information go to different hard drives. If any segment of RAID 0 fails, all 
information from all members is lost.  
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Figure 1. Performance - RAID 0 with two hard drives 

At a higher reliability cost with faster performance, the HP Compaq Elite 8000-
series Business PC Convertible Minitower also allows for RAID 0 with three hard 
drives. RAID 0 with two or three hard drives is a supported configuration.  
RAID 0 with three hard drives is shown in Figure 2. 
 

 

Figure 2. Performance - RAID 0 with three hard drives 
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RAID 1 with two hard drives (Mirror))  
Because it is a very cost-effective way to increase system storage reliability and a 
great value proposition, RAID 1 is the only RAID configuration that HP pre-
configures for HP Elite 8000-series Business PCs. RAID 1 provides high availability 
with minimal performance impact, as well as greater reliability compared to a sin-
gle hard drive configuration. 
RAID 1 has redundancy and hence is a true RAID. It more than doubles reliability 
because the MTBF of RAID 1 is equal to the MTBF of an individual drive multiplied 
by the number of drives (2). In other words, the probability of one hard drive failure 
on a given day is the square root of that same probability. Hypothetically, if the 
chance for a single hard drive failure is 1:2000, then the chance that both hard 
drives failing in RAID 1is 1:4,000,000.  
Mirroring, segmentation, and striping have no real meaning in RAID 1. In the table 
and graphic, the data is arranged in rows for representation of different pieces of 
data.  

Table 4. RAID 0 with two hard drives (Mirror) 
First Disk Second Disk 

Data Segment 1  Data Segment 1 

Data Segment 2  Data Segment 2  

Data Segment 3  Data Segment 3  

Data Segment 4  Data Segment 4  

Data Segment 5  Data Segment 5  

Data Segment 6  Data Segment 6  

Data Segment 7  Data Segment 7  

Data Segment 8  Data Segment 8  

In the previous table, each “Data Segment n” represents a group of data, known as 
a strip. In this case, each rows represent a stripe. This table shows how information 
is duplicated in both hard drives. The size of the strips is mostly irrelevant and not a 
configurable option.  
To better illustrate the concept of RAID 1 and mirroring, Figure 3 shows how a 
sequence of data “ABCD...” is stored in a RAID 1 volume. In this example, each 
letter represents a data segment. The graphic shows how the various pieces are 
replicated for both of the hard drives; hence, if any one member of the RAID 1 
volume fails, the information is kept in the surviving members. After a hard drive 
failure, the user interface sends a notification so the failed hard drive can be 
replaced. No user information is lost in this scenario. 
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Figure 3. Reliability: RAID 1 - Mirroring 

 

RAID 5 with three hard drives  
RAID 5 has been used in servers for many years and is one of the most common 
types of RAID. RAID 5 uses striping with parity data in distributed blocks across all 
member disks. Therefore, the mass storage controller can simultaneously write new 
information to two hard drives and parity information to the third hard drive, so if 
one hard drive fails, the RAID controller can rebuild all the information after the 
volume degradation occurred. Hence, RAID 5 with three hard drives has similar 
performance to RAID 0 with two hard drives, and the reliability of RAID 1 with a 
minimum of three hard drives.  

Table 5. RAID 5 with three hard drives (Parity) 
First Disk Second Disk Third Drisk 

Data Segment 1  Data Segment 2  Parity for 1 and 2  

Data Segment 3  Parity for 3 and 4  Data Segment 4  

Parity for 5 and 6  Data Segment 5  Data Segment 6  

Data Segment 7  Data Segment 8  Parity for 7 and 8  

Data Segment 9  Parity for 9 and 10  Data Segment 10  

Parity for 11 and 12  Data Segment 11  Data Segment 12  

Data Segment 13  Data Segment 14  Parity for 13 and 14  

Data Segment 15  Parity for 15 and 16  Data Segment 16  

Parity for 17 and 18  Data Segment 17  Data Segment 18  
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In the previous table, each “Data Segment x” represents a strip. A stripe is made 
with strip “Data Segment x”, “Data Segment y” and strip “Parity for x and y.”  
Notice that the strip “Parity for x and y” is used to store the required information to 
recreate the data if any one of the RAID volume members is compromised.  
To better illustrate the concept of RAID 5 (parity-based RAID), Figure 4 shows how 
a sequence of data “ABCD...” is stored in a RAID 5. In this example, each letter 
represents a segment or strip. The various pieces of the information go to different 
hard drives, hence if any one member of the RAID 5 fails, the information from all 
members is not lost. 
 

 

Figure 4. RAID 5 with three hard drives 
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Intel Matrix RAID Technology 
This technology provides protection against data loss from a hard drive failure and 
faster access to digital photo, video, and music files by supporting NCQ as well as 
RAID 0, 1, 5, and 10. As shown in Figure 5, Matrix RAID enables two RAID levels 
to be combined for data loss protection plus performance. 
 

 

Figure 5. Matrix RAID combining reliability and performance with the same two hard 
drives 
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Using Intel Matrix RAID Technology, you can configure an HP Elite 8000-series 
Business PC Convertible Mini-tower with two RAID volumes using three hard drives 
(Figure 6) - a RAID 0 volume for ultimate performance, and a second volume as 
RAID 5 with reliability and performance improvements.  
 

 

Figure 6. Matrix RAID combining reliability and performance with same three hard 
drives 
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Configurations 

Recommended configurations  
HP recommends factory configurations of the preinstalled RAID offerings for HP 
Elite 8000-series Business PCs. The preinstalled RAID offering is a RAID 1 volume 
of two identical SATA hard drives.  
HP Elite 8000-series Business PCs are based on Intel chipsets that provide a 
combined hardware and software RAID solution. The Intel mass storage controller 
allows all drives to operate in IDE or RAID SATA modes. Each mode of the 
controller means a different PCI controller, with different device ID, class code, and 
driver support.  

Note 
HP recommends and only supports Microsoft’s IDE driver 
stack based on the ATAPI.SYS driver for HP Compaq 
Business PC products including all supported RAID 
configurations. 

Warning 
The PCI Device ID of the mass storage controller changes 
after changing IDE mode. Changing the BIOS from IDE 
mode to RAID mode is the equivalent of connecting the 
hard drives to a new add-on RAID storage controller. The 
installed operating system on the hard drive is unaware of 
this new mass storage controller. If the operating system 
does not have the RAID drivers enumerated and PnP for 
the RAID controller, the operating system will fail to boot 
(blue screens) when Microsoft XP, Vista or Windows 7 
attempts to boot. 

 

Table 6. RAID Drives 
Mode Purpose Minimum drives required 

RAID 0  Striped for Performance.  2  

RAID 1  Mirrored for Protection.  2  

RAID 5  Parity for Accuracy.  3  

RAID 0 + 1  Mirrored and Striped.  4*  

Intel’s Rapid Technology  
4 logical drives on 2 
physical disks, to emulate  
RAID 0 and 1 

2  

* Not supported on HP Elite 8000-series Business PCs 
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Important RAID configuration 
The following notes are important for RAID configuration: 
• RAID 1 is the only RAID configuration that HP Elite 8000-series Business PC 

products offer as a factory configuration option. 
• All pre-configured systems: 

 Are complete RAID systems 
 Have both drives installed 
 Have the necessary Option ROM configuration 
 Are pre-loaded and pre-installed with all required Intel software 
 Include a preinstalled operating system that is mirrored mode out of the 

box 
• HP also recommends keeping the default options in the RAID Option ROM and 

in the Windows RAID application. Options like “chunk” size for changing the 
“stripe” size have more history in their defaults settings 

Other supported configurations  
HP Elite 8000-series Business PC products support two other RAID configurations:  
• Two-drive configuration:  

 Two equal size/type SATA hard drive RAID configurations in RAID 0 or 
RAID 1 or Matrix Mode of RAID 0 and RAID 1.  

 Maximum of two SATA optical drives (on HP Elite 8000-series Business PC 
Convertible Minitowers).  

• Three-drive configuration (only on HP Elite 8000-series Business PC Convertible 
Minitowers): 
 Three equal size/type SATA hard drive RAID configurations in RAID 0 or 

RAID 5 or Matrix Mode of RAID and RAID 5.  
 Maximum of one SATA optical drives.  

Unsupported configurations  
HP Elite 8000-series Business Desktop PC products only support configurations 
offering the best user experience and highest possible reliability. As a result, HP 
does not support the following combinations of RAID hard drives:  
• Different sizes  
• Different speeds (5400 rpm, 7200 rpm, etc)  
• Old and new technologies (SATA 1.5 GB and SATA 3.0 GB)  
• NCQ hard drives and non-NCQ drives  
• Different cache size  
• RAID combinations of hard drives with any operating system other than 

Windows XP Pro (SP2/SP3), Windows Vista SP1/SP2, and Windows 7 using 
Microsoft’s IDE driver stack based on ATAPI.SYS  
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Configuring RAID on non-factory preinstalled 
configurations  
The remaining sections of this white paper describe steps to set up supported RAID 
configurations where customers have not purchased factory preinstalled RAID 
configurations.  

Enabling RAID through F10 System BIOS 
1. Turn on or restart the computer by clicking Start > Shut Down > Restart the 

Computer.  
2. Press F10 as soon as the monitor light turns green.  

If you do not press F10 at the appropriate time, you must restart the computer, 
and then press F10 again to access the utility.  

3. Select your language from the list, and then press Enter.  
4. Use the arrow keys to select Storage.  
5. Use the down arrow key to select Storage Options, and then press Enter.  
6. On the Storage Options menu, use the down arrow key to select SATA 

Emulation.  
7. Press the right arrow key until RAID displays, and then press Enter.  

 
8. To apply and save changes, select File > Save Changes and Exit.  

 If you do not want to apply your changes, select Ignore Changes and Exit.  
 To reset to factory settings, select Set Defaults and Exit. This option restores 

the original factory defaults.  

CAUTION 
Do NOT turn the computer power off while the ROM is 
saving the F10 Computer Setup changes as the CMOS 
could become corrupted. Only turn the computer off after 
exiting the F10 Setup screen. 
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Accessing RAID Option ROM 
You can only access Computer Setup at system startup. To access the Computer 
Setup Utilities menu and enable RAID: 
1. Turn on or restart the computer by clicking Start > Shut Down > Restart the 

Computer. 
The following screen (RAID Option ROM) displays briefly during boot up. The 
RAID configuration utility is English only. To configure RAID in other languages, 
use the Windows-based RAID configuration utility. 

 
 

2. Press Ctrl + I repeatedly as soon as the monitor light turns green to enter the 
RAID configuration utility. If you do not press Ctrl + I at the appropriate time, 
you must restart the computer, and then press Ctrl + I again to access the utility. 

Configuring RAID Volume using the Option ROM 

 
1. Use the up or down arrow key to select Create RAID Volume, and then press 

Enter to access the Create Volume screen. 
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2. Select or enter the desired RAID Level. Use the information on the bottom half 
of the screen if necessary. 

 
3. Use the arrow keys to scroll to Create Volume, and press Enter. The following 

screen appears. WARNING: All data on the selected disk will be deleted. 

 
 

4. Type Y to continue. 
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Notes for operating system installation  
• After creating a RAID disk volume in the option ROM, you can install the 

operating system.  
• HP provides a driver download for Windows XP, Vista and Windows 7 at 

www.hp.com.  
• Customer-created images MUST account for the RAID controller.  
• Failure to install and enumerate the RAID driver after enabling the RAID 

controller (with or without creating a volume) will result in a Windows boot 
failure (blue screen) for inaccessible boot device.  

WARNING:  
The PCI Device ID of the mass storage controller changes 
after changing IDE mode. Changing the BIOS from IDE 
mode to RAID mode is the equivalent of connecting the 
hard drives to a new add-on RAID storage controller. The 
installed operating system on the hard drive is unaware of 
this new mass storage controller. If the drivers are not 
available, enumerated, and PnP for this new controller, the 
operating system blue screens in Microsoft XP and 
Microsoft Vista/Windows 7.  

http://www.hp.com/�
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Intel Rapid Storage Manager software installation 
This section of the paper focuses on how to configure RAID using Intel Rapid 
Storage Manager software. The configuration steps are for application usage and 
supported RAID migrations. 
1. Select Start > All Programs > Intel > Intel(R) Rapid Storage Console.  

 
2. Click Next.  
3. Read the driver agreement. If you agree, click Next.  
4. Read the License Agreement. If you agree, click Yes.  
5. Review the Readme for Intel Rapid Storage Technology, and then click Next.  
6. Click Next, after the setup operations complete.  
7. Click Next to finish the installation.  
8. Select Restart Now or Restart Later, and then click Finish to close the setup.  
9. Restart the computer.  
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Using the Intel Rapid Storage Console interface 
1. Click Start > All Programs > Intel > Intel Rapid Storage Console to open the 

Intel Rapid Storage Console application. The Intel Rapid Storage Console starts 
in Status mode by default and has three main menus. 

Note 
The report the applications generate is very 
comprehensive. You can view the report at View/System 
Report. The report contains information about the driver, 
operating system, language, and hard drive. 

2. Select Status to view the current status of the storage system. 

 
 

3. For a more detailed view of the RAID controller, click Manage. 

 
 

In Manage, the Intel Rapid Storage Console also includes the Advanced menu. Use 
this menu to access the advanced features of the RAID solution. 
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RAID migrations using Intel Rapid Storage Console 

Migration to RAID 1 from two non-RAID hard drives  

NOTE 
HP Elite 8000-series Business PC products only support 
RAID based on two identical SATA hard drives in either 
RAID 0 or RAID 1 or Matrix RAID Mode of RAID 0 and 
RAID 1. 

NOTE 
At least 6 MB of free space at the end of the drive is 
required to migrate from a non-RAID to RAID configuration 
or an error will occur. 

1. Open the Intel Rapid Storage Console and select Create in the top pane and 
select the Volume Type in the right pane. Select Real-time data 
protection (RAID 1).  
 

 
 

2. Click Next to configure the volume.  
3. In the Configure window, name the volume, select the two disks, and specify if 

you want to keep data from one of the selected disks.  
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4. Click Next to begin the confirmation process and start the Create Volume 
action.  
 

 
 

5. Click Create Volume to confirm you understand the Volume Creation warning 
and you want to continue the action. 

6. Click OK after the action completes.  
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Migration to RAID 0 from two non-RAID hard drives  

NOTE 
HP Elite 8000-series Business PC products only support 
RAID based on two identical SATA hard drives in either 
RAID 0 or RAID 1 or Matrix RAID Mode of RAID 0 and 
RAID 1. 

To migrate two non-RAID hard drives  to a RAID 0 configuration using Intel Rapid 
Storage Console perform the following steps: 
1. Open the Intel Rapid Storage Console and select Create and select the volume 

type Optimized disk performance (RAID 0).  
 

 
 

2. Click Next to configure the volume.  
3. In the Configure window, name the volume, select the two disks and specify if 

you want to keep data from one of the selected disks.  
4. Click Next to begin the confirmation process and start the Create Volume 

action.  

5. Click Create Volume to confirm you understand the Volume Creation 
warning and you want to continue the action.  

6. Click OK after the action completes.  
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Migration to RAID 0 from three non-RAID hard drives  

NOTE 
Back up all data before proceeding. 

NOTE 
HP Elite 8000-series Business PC products only support 
RAID based on three identical SATA hard drives in either 
RAID 0 or RAID 5 or Matrix RAID Mode of RAID 0 and 
RAID 5. 

1. Open the Intel Rapid Storage Console and select Create in the top pane and 
select the Volume Type in the right pane. Select Optimized disk performance 
(RAID 0).  

2. Click Next to configure the volume.  
3. In the Configure window, name the volume, select the three disks and specify if 

you want to keep data from one of the selected disks.  
4. Click Next to begin the confirmation process and start the Create Volume 

action.  

NOTE:  
HP currently supports only the default Strip Size (in this 
case 128KB). There is a performance relation between the 
type of data and the strip sizes.  

5. Click Create Volume to confirm you understand the Volume Creation warning 
and you want to continue the action.  

6. Click OK after the action completes.  

Migration to RAID 5 from three non-RAID hard drives 

NOTE 
Back up all data before proceeding. 

NOTE 
HP Elite 8000-series Business PC products only support 
RAID based on three identical SATA hard drives in either 
RAID 0 or RAID 5 or Matrix RAID Mode of RAID 0 and 
RAID 5. 

1. Open the Intel Rapid Storage Console and select Create in the top pane and 
select the Volume Type in the right pane. Select Efficient data hosting and 
protection (RAID 5).  

2. Click Next to configure the volume.  
3. In the Configure window, name the volume, select the three disks and specify if 

you want to keep data from one of the selected disks.  
4. Specify if you want to keep data from one of the selected disks?  



29 

5. Click Next to begin the confirmation process, review the selected configuration 
and click Create Volume to start the Create Volume action.  

NOTE 
HP currently supports only the default Strip Size (in this 
case 128KB). There is a performance relation between the 
type of data and the strip sizes.  

6. Click Create Volume to confirm you understand the Volume Creation warning 
and you want to continue the action.  

7. Click OK after the action completes.  

NOTE:  
If users consume all available storage for this RAID 
volume, there will be no space to create another RAID 
volume for this hard drive, thereby not allowing for Matrix 
RAID Mode. Note the size if you want to create a second 
RAID volume in this set of hard drives. 

8. . Reboot the system after the migration finishes.  

Migration to Matrix RAID 5 and RAID 0 from three non-RAID hard 
drives 

NOTE 
Back up all data before proceeding. 

NOTE 
HP Elite 8000-series Business PC products only support 
RAID based on three identical SATA hard drives in either 
RAID 0 or RAID 5 or Matrix RAID Mode of RAID 0 and 
RAID 5. 

1. Open the Intel Rapid Storage Console and select View > Advanced Mode.  
2. Click Actions/Create RAID Volume from Existing Hard Drive to open a 

verification window.  
3. Click Next.  
4. Type the RAID Volume Name, select the RAID Level (for three hard drive RAID 

0 or RAID 5 only), and select the Strip Size.  

NOTE 
HP currently supports only the default Strip Size (in this 
case 128KB).  

5. Click Next to see the selection of hard drives that will be part of this RAID 
volume.  

6. Select the source hard drive (Port 0), and then click on the arrow to move them 
to the Selected box.  



30 

7. Click Next.  
8. Select all hard drive members of the RAID volume, and then click the right 

arrow to place the (port 2 and port 3) hard drives in the selected box.  

NOTE 
If users consume all available storage for this RAID 
volume, there will be no space to create another RAID 
volume for this hard drive, thereby not allowing for Matrix 
RAID Mode. Note the size if you want to create a second 
RAID volume in this set of hard drives.  

9. To create two volumes based on your space, reliability and performance 
needs, select the size of the first RAID volume by sliding the bar or entering the 
desired volume size. For example, divide in half the available hard drive 
storage in two RAID volumes by setting the Percentage of Available Space to 
50%, so that 50% of drive capacity is used for RAID 0.  

10. Click Next.  
11. Click Finish to start the migration process, which can take a few hours.  
12. Reboot the system after the migration finishes.  

NOTE 
Back up all data before proceeding.  

13. After the first RAID volume has been created, create the second RAID volume 
by opening the Intel Rapid Storage Console, clicking View > Advanced Mode, 
and then clicking Actions/Create RAID Volume from Existing Hard Drive.  

14. Click Next.  
15. Use the same values you entered in the previous RAID volume confirmation and 

type the RAID Volume Name, select the RAID Level (for three hard drive RAID 0 
or RAID 5 only), and select the Strip Size.  

NOTE 
HP currently supports only the default Strip Size (in this 
case 64KB).  

16. Click Next to see the selection of hard drives that will be part of this RAID 
volume.  

17. Because this is the second volume for this set of hard drives, select the existing 
name in the Available box (Array 0000), and then click the right arrow to 
move this array into the Selected box.  

18. Click Next.  
The Specify Volume Size screen is grayed out because the second volume of this 
Matrix RAID Mode takes the remaining space. After the selection of the all hard 
drive members of this RAID volume, follow the volume size selection screen.  
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NOTE 
The first array volume creation is the place for adjusting 
the size; the second volume will take any remaining 
space.  

19. While creating the second RAID volume, click Next to open the completion 
window.  

20. Select Finish to start the migration process, which can take a few hours. The 
following screen appears.  

You can see the state of the Matrix RAID Mode created by opening the Intel Rapid 
Storage Console and clicking View > Advanced Mode. The Matrix RAID Mode of 
three hard drives is illustrated in the following image.  

Migration to Matrix RAID 1 and RAID 0 from two non-RAID hard 
drives 
The migration process for two hard drives to RAID Matrix Mode (0 + 1) is very 
similar to the process described in the section about migration of three hard drives 
to matrix mode RAID (0 + 5). The difference in the process is selecting two hard 
drives as part of the volume created and selecting RAID 5 instead of RAID 1. 
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Configuring Intel Rapid Storage Console for 
Email notifications (HP Elite 8200 Business PCs only) 
To configure Intel Rapid Storage Console to send notifications of specified events to 
a designated email address, use the following steps: 
1. Open the Intel Rapid Storage Console and select Preferences.  

 
2. Select the type of event to initiate a notification (all three may be selected). 
3. Enter the email information. 

a. SMTP Host (required) 
b. Port 
c. Sender email address (required) 
d. Recipient email address (at least one required) 

4. When done click Apply Changes. 
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Installation 
HP desktops come with RAID software preinstalled. However, if reinstallation is 
necessary, use setup in combination with the supported flags (Version 
9.5/9.6/10.1) as listed and described in the sample screen shot (version 10.1) 
below 
 

 
 

Note:   
Flags and their parameters are not case-sensitive. Flags 
may be supplied in any order, with the exception of -S 
and -G, which must be supplied last. When using the -A 
flag, a target path may be specified using the -P flag, and 
the -G and -S flags are ignored. When using the -O and -
G, flags there should be no space between the flag and 
the argument. 
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Table 8. Language support 
Abbreviation Language  

ara  Arabic (Saudi Arabia)  (0401)  

chs  Chinese (Simplified)  (0804)  

cht  Chinese (Traditional)  (0404)  

csy  Czech  (0405)  

dan  Danish  (0406)  

nld  Dutch  (0413)  

enu  English (United States)  (0409)  

fin  Finnish  (040B)  

fra  French (International)  (040C)  

deu  German  (0407)  

ell  Greek  (0408)  

heb  Hebrew  (040D)  

hun  Hungarian  (040E)  

ita  Italian  (0410)  

jpn  Japanese  (0411)  

kor  Korean  (0412)  

nor  Norwegian  (0414)  

plk  Polish  (0415)  

ptb  Portuguese (Brazil)  (0416)  

ptg  Portuguese (Standard)  (0816)  

rus  Russian  (0419)  

esp  Spanish  (0C0A)  

sve  Swedish  (041D)  

tha  Thai  (041E)  

trk  Turkish  (041F)  

 

Degradation 
In the unlikely event that one of your hard drives malfunctions, you will be notified 
with the following message:  

 

If this occurs, perform the following steps: 
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1. Run the Intel Rapid Storage Console application on the system experiencing a 
degradation to identify the hard drive that failed and to which port it is 
connected.  
 

 
 

2. After identifying the hard drive, close all applications, shut down the operating 
system, power down the unit, unplug the power cord, and replace the defective 
hard drive.  

3. After replacing the hard drive, automatic rebuild of the redundancy begins 
immediately after the system is powered up and operating system starts. The 
following message appears:  
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is subject to change without notice. The only warranties for HP products and services 
are set forth in the express warranty statements accompanying such products and 
services. Nothing herein should be construed as constituting an additional warranty. HP 
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