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Executive summary
Keeping PCs in a business up to date with the latest software and hardware updates presents a number of problems, including time, bandwidth, and logistical issues. HP offers two tools, HP SoftPaq Download Manager (SDM) and HP System Software Manager (SSM) that can be used in conjunction to help streamline the update process, reducing IT costs and improving the TCO for your HP PCs. 
By using these tools, companies will be able to keep all of their HP PCs up to date with the latest SoftPaqs (software packages for updates to drivers/BIOSes and certain software for HP computers) automatically, instead of having to run each SoftPaq individually on each machine, not knowing if the SoftPaq actually needs to be installed or not.

The following topics in this document are covered:

· Overview of HP SDM and HP SSM

· Setting up and using HP SDM and SSM

· Customizing usage of HP SDM and SSM
Overview of HP SDM and HP SSM
HP SoftPaq Download Manager (SDM) is a software tool designed to streamline the download and extraction process of SoftPaqs. Instead of manually searching for and downloading each SoftPaq, IT personnel can find and grab all the appropriate SoftPaqs for each of their machines all in one sitting.

HP System Software Manager (SSM) is a free software tool designed to simplify deployment of SoftPaqs to HP PCs. The SSM tool detects which updates apply to the system from the available SoftPaqs and installs them onto the system, so you do not have to worry about accidentally installing an older version. SSM accesses the SoftPaqs from the local network or local folder instead of downloading them from the internet, cutting down on update time and saving network bandwidth.

For more details on either of these tools visit the following webpages:

SDM: http://www.hp.com/go/SDM
SSM: http://www.hp.com/go/SSM 

Use Case for SDM/SSM

Using HP SDM and SSM to manage software updates is ideal for:

· Small to medium business sizes (1-100)

· Updating a group of PCs outside normal IT maintenance

· Recommended for Enterprise Customers for faster download of SoftPaqs

· Using HP Business Notebooks Common Products Catalog

Note that SSM will only update PCs with SoftPaqs that are marked as SSM compliant.

How SDM and SSM work together
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Setup and Usage Process Overview  

1. Download and install HP SDM.
2. Setup SDM configuration for the models of machines you want to update.

3. Download desired SoftPaqs.

4. Run SSM in admin mode to prepare the download directory for SSM usage. 

5. Repeat 2 and 3 for any additional file shares that you may want to create and use.

6. Manually share the file share, if necessary.

7. Setup SSM on the client machines to run at predetermined times or run SSM manually.

General Requirements and Setup

HP SoftPaq Download Manager

.Net Framework 3.5 or later

Broadband Internet Connection (Authenticated proxies supported: Basic, Digest, KLM and Kerberos) 
512MB RAM minimum, 1GB recommended

Windows XP, Vista or Windows 7
HP System Software Manager

Computer to host a Windows-compatible file share

Supported HP / HP Compaq computers attached to a network, running Windows XP, Vista or Windows 7
Supported Client PCs and SoftPaqs

HP SDM and SSM are only supported for certain HP business products (desktops, notebooks, tablets, workstations, and blades). Servers and consumer-level products are not supported with SDM and SSM. SDM will also indicate whether a SoftPaq is SSM compliant or not. If the SoftPaq is not marked as SSM compliant, SSM cannot be used to deploy that SoftPaq.

In addition, certain platforms and operating systems may not be supported under SDM and/or SSM. Consult the documentation that comes with SDM and SSM for details.

Downloading and Installing HP SDM and SSM
The latest versions of HP SoftPaq Download Manager and System Software Manager are available from HP at http://www.hp.com/go/sdm and http://www.hp.com/go/ssm respectively.

HP SDM will appear in the Start Menu, under All Programs -> HP -> HP SoftPaq Download Manager. 
When you install SSM, no icon will be placed in the Start Menu for SSM; however, the program will be available in Hewlett-Packard\SSM under the Program Files directory for 32-bit Windows systems and Program Files (x86) directory for 64-bit Windows systems.

Setting up and using HP SoftPaq Download Manager
Option 1:  Using HP SoftPaq Download Manager to find updates for current model
1. Launch SoftPaq Download Manager

2. When prompted, select Show software for this model only.  (NOTE: If wanting to automatically install the updates on the current system, you can use the Check software updates for this model option.  If the goal is to download SoftPaqs to install on similar systems as the current platform than use the Show software for this model only option.)
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3. The current platform will automatically be displayed and selected in the Product Catalog window.

[image: image3.jpg]HP SoftPs

File Tools Help

| ] Check For Updates [[E] Show This Computer | ] Show All Products
P P
This Computer

Microscft Windows 7 Professional 32 Edion
Engish - Intemational





4. Select the desired SoftPaqs from the Available SoftPaqs window.

a. NOTE: Only SoftPaqs which are marked as SSM-compliant will be added to the SSM database. To help with the selection process you can have SDM select all SSM-compliant SoftPaqs by clicking on Select SoftPaqs -> Auto-Installable (SSM-Compliant).
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5. After selecting the desired SoftPaqs, the following options are available in the Downloaded SoftPaqs window: Download Only, Download and Unpack or Download and Install.
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a. Download Only – This option will download all selected SoftPaqs to the Download Folder (SSM Filestore) location found on the “Download” tab under Configuration Options.
b. Download and Unpack – This option will download all selected SoftPaqs to the Download Folder (SSM Filestore) location found on the “Download” tab under Configuration Options and will unpack each individual SoftPaq to the Unpack Directory location found on the “Unpack” tab under Configuration Options.  
c. Download and Install – This option will download all selected SoftPaqs to the Download Folder (SSM Filestore) location found on the “Download” tab under Configuration Options and then install each individual SoftPaq on the current system via SSM.  
Option 2:  Using HP SoftPaq Download Manager to download SoftPaqs for multiple platforms.

6. Launch HP SoftPack Download Manager

7. When prompted, select Show software for all supported models.  If already in SDM, select “Show All Products”.
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8. Prior to downloading any SoftPaqs, set your preferences in the Configuration Options window accessed from the Tools menu (Tools -> Configuration Options).

Tip:

Once all of the selections have been made, you can save the configuration file for future usage and backup purposes. This will preserve the download directory, download structure, OS and language settings, and the products you selected. To save it, go to File -> Save Product Configuration.  
For each respective tab, select from the following options:

· Download

· Download Directory – Set it to a folder that you can share. This can be either a local folder or a mapped network drive/folder. This will be the location of your SSM File Store.

· Download Folder Options – Select either Single Folder to put all SoftPaqs in a single location or Separate Folders by SoftPaq Names to separate them according to name.
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· Unpack 

· Unpack Directory – this field allows the user to change the location of where they want the SoftPaqs unpacked to once they are downloaded.

· Unpack Folder Options
· Legacy Behavior – This option will unpack all selected SoftPaqs in the Download Directory established on the Download tab (above).  Unpack directory field will be locked.  
· Separate by SoftPaq IDs – This option will unpack all selected SoftPaqs in the folder designated in the Unpack Directory.  Individual SoftPaqs will be unpacked in a unique folder based on SP#: (i.e. \SPxxxxx) according to SoftPaq category (Driver – Video, Driver – Audio, etc.). 

· Separate by SoftPaq Names – This option will unpack all selected SoftPaqs in the folder designated in the Unpack Directory.  Individual SoftPaqs will be unpacked in a unique folder based on SP Name: (i.e. HP Universal Camera Driver) according to SoftPaq category (Driver – Video, Driver – Audio, etc.). 
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Example of Separate by SoftPaq IDs option:  
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Example of Separate by SoftPaq Names option:  
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· OS Filter

· Select from the list the operating systems that are running on the network. Note that not all OSes listed are supported by SSM. The list of OSes supported by SSM is included in the SSM User’s Guide, which is included in the SSM SoftPaq.  
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· Language Filter

· Select the desired languages of the operating systems on your network. 
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· Columns

· Controls which fields are displayed in the “Available SoftPaqs” window.
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9. Once all of the Configuration Options have been set, select the respective platforms in the Product Catalog window and click “Find Available SoftPaqs” to display a list of available SoftPaqs for your selected systems.
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a. NOTE: For common driver support across multiple notebook platforms, select the HP Business Notebooks Common Products catalog.

10. Select the desired SoftPaqs from the Available SoftPaqs window.
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11. After selecting the desired SoftPaqs, the following options are available in the Downloaded SoftPaqs window: Download Only or Download and Unpack.
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a. Download Only – This option will download all selected SoftPaqs according to the settings established in the Download tab in the Configuration Options dialog.  Default is Single Folder set to “C:\SoftPaqDownloadDirectory”.

b. Download and Unpack – This option will download all selected SoftPaqs according to the settings established in the Unpack tab in the Configuration Options dialog.  Default is Legacy Behavior (unpack in Download directory) “C:\SoftPaqDownloadDirectory”.  
After download is complete, the SoftPaqs can either be installed directly via SSM or imported into your respective management solution.

c. NOTE: To quickly view the contents of either the Download or the Unpack folders, use the Explore drop down in the Downloaded Softpaqs window.
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Once the SoftPaqs have been downloaded/unpacked/installed, they will be displayed in the Downloaded SoftPaqs window.  Right-clicking on any SoftPaq in this window will present the user with the following options:
d. View SoftPaq Release Notes:  Provides detailed information about the SoftPaq contents – title, version, description, OS support, hardware support, fixes, etc. 
e. View SoftPaq CVA:  Provides detailed installation instructions (including silent install instructions) as well as any dependencies. 

f. Install SoftPaq:  Provides capability to install (silently) the SoftPaq directly from within SDM. 

g. Copy SoftPaq to Directory:  Provides capability to copy the SoftPaq (EXE), CVA and HTML files to a designated folder other than Download folder. 
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Setting up HP SSM (Admin)
SSM admin mode setup is run in order to accept the license agreement, configure user options and to build a database (called Update Information Database or UID) of SoftPaq information from the CVAs.  This information is used by clients when SSM is run in client mode.

Note:

The SSM Admin setup process should be run after the SoftPaqs have been downloaded.  
To run and setup SSM in admin mode, perform the following:

1. Navigate to Hewlett-Packard\SSM in the Program Files directory (or Program Files (x86) if you’re running 64-bit Windows) to run SSM.exe

2. When prompted for the location of the file store, navigate to the SDM download directory. Type in the name you wish to use for the file store. Click next.

3. If you are presented with a message about SSM.CAB being missing, double click on the specified text to copy the file to the file store, then click next until you reach client options.

4. Check the box “Reboot client upon completion of upgrades”. Click next.

5. Click next until you reach the Build Database window.

6. Check the “Check ftp.hp.com for CVA file updates” box first. This will cause SSM to update the specification file for each SoftPaq, which may include bug fixes and expanded coverage. 

7. Click on Build Database. Wait for the build process to finish. 

8. Click Finish to complete the process.

9. Copy SSM.EXE to the root of the SDM download directory. This will allow easier execution of SSM from the network.

The client PCs will need access to the file store containing the SoftPaqs in order for SSM to run properly on those machines. SSM will try to create the share automatically; however, this may not work in certain cases (domain settings, share is located on another computer, etc.), so you may need to share and/or change the settings of the target folder manually.

Setting up HP SSM (Clients)

In client mode, SSM uses the information in the UID database to query for applicable SoftPaqs.  If no database is present, SSM will dynamically create a temporary database on the client by reading each CVA in the file store over the network. Hence, for optimal performance make sure the SSM database is present in the file store and is up-to-date.
To run SSM in client mode, you only need to specify the location of the file store and any other desired command line switches as parameters. SSM.exe should be run from the root of the file store. The recommended command used to run SSM is:

<file store path>\SSM.EXE . /INSTALL 
To prevent network authentication issues it is recommended to map the network share to a drive letter, and then use that mapped network drive as the file store path.

There are multiple options in getting SSM to run:

· Manual Execution

· Scheduled Tasks

· 3rd party management tool

You can use the Scheduled Tasks feature in Windows to have SSM run automatically on a regular basis. Depending on which OS the computers have the setup, the process will vary.

If you use the Schedule Tasks feature, HP recommends the following options be set when setting up the task:

· In Vista and Windows 7, SSM needs to be run with the highest privileges, so the “Run with highest privileges” option needs to be checked. No UAC prompt will appear when this option is set.

· To ensure updates are applied, allow SSM to run even when the user is logged off, and add the reboot command line option as a parameter.
Maintenance Process

Adding and Removing SoftPaqs

The SDM catalog is updated on a weekly basis on Monday nights (US CST), so you can check back then if you’re looking for the latest updates for your machines.

As SoftPaqs are added, you may want to remove older or unneeded updates from the share to reduce size. This can be done manually by clicking on the Explore button in SDM. Be sure to remove the .exe and the corresponding .cva when removing a deliverable. After adding and removing SoftPaqs, reload the configuration file in SDM to get an updated list of downloaded SoftPaqs. Note that deleted SPs from the Download Directory will show up again in the “Available SPs” list.

The SSM database will also need to be rebuilt to reflect the updated SSM file share. Either run through the SSM setup process again or use the command line option. For details, look in the Advanced usage of HP SDM and SSM section.

Advanced usage of HP SSM
Running SSM from Removable Media

SSM can be run directly from removable media, such as a USB memory stick or portable hard drive. The setup process is similar to setting up SSM for use across the network, except that the SSM file store is copied to a USB drive instead of being shared across the network. SSM is then run directly from the USB drive. This can be useful for updating machines not attached to a network or for machines with special considerations.

It is recommended to create a .bat located in the root of the SSM folder with a command that would execute SSM with the desired parameters. This would allow for easy double-click execution when moving from machine to machine. 

Note:

Certain SoftPaqs that deal with USB devices (such as Bluetooth drivers) may interfere with the operation of the update process in SSM if run from a removable drive. To work around this, copy the SSM directory to the local hard drive and run SSM from there.

Updating the SSM DB and CVAs via command line

Instead of running through the SSM wizard to rebuild and update the DB, you can perform the process via a command line. The command is:

SSM /AM_BLD_DB

SSM.exe must be run and located in the root of the file store for this command to work.

This command will also update the CVA files by downloading updated ones from HP’s server. Each SoftPaq comes with a CVA file that determines which SoftPaq applies to what machines. Sometimes these CVA files are updated to add supported machines/OSes or to fix errors. If you do not wish to update the CVAs use the /NOCVAUPDATE switch.

Other SSM Configuration Options

SSM has a number of command-line switches and options that can be used during the setup and execution process. For more details on the options, please refer to the SSM User’s Guide included with SSM.

Multiple File Stores

You can share copies of the SSM file share on more than one computer or use multiple SDM configurations and download directories to create different SSM file shares. By spreading the load you may be able to alleviate network performance issues you may run into and help simplify the update process when trying to update a large number of PCs via SSM. 

Other HP Solutions

For needs that outgrow SDM and SSM, HP offers a variety of solutions. Visit http://www.hp.com/go/clientmanagement for more details.[image: image22.jpg]
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For more information 

To learn more about HP business notebooks and desktops, contact your local HP sales representative or visit www.hp.com/go/notebooks and www.hp.com/go/businesspc. 
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