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OVERVIEW 
This white paper describes the advantages of Microsoft® driver isolation mode, how it works, which 
systems it supports, and how to use it with the HP Universal Print Driver (UPD). 

Background  
Microsoft® Windows Server versions 2000, 2003, and 2008, along with client versions Windows 
XP® and Windows Vista®, utilized user-mode version 3 print drivers that operate in the print spooler 
process spoolsv.exe. If any driver utilizing spoolsv.exe fails, all print operations dependent on the 
print spool service fail.  

To solve this problem, Windows 7 and Windows Server 2008 R2 introduced isolation of print 
drivers. Drivers configured in isolation mode run in an independent PrintIsolationHost.exe process 
which proxies print services to spoolsv.exe. In the event of driver instability or failure, the 
PrintIsolationHost.exe fails independent of the Spoolsv.exe. 

Driver isolation applies to usage of the print driver in the spooler context, not use of the print system 
(for example, opening the user interface). Two or more drivers can be defined to share a 
PrintIsolationHost.exe process, or a single driver can be defined to a dedicated PrintIsolationHost.exe 
process. A driver can only be defined for one mode, while the server supports all three modes in 
combination.  

What are the driver isolation mode settings for Windows 7 and 
Windows Server 2008 R2?  
• No Isolation—The driver runs in Spoolsv.exe (the same as for Server 2003, Windows Vista, 

Windows XP, and Server 2008 SP2). All drivers set to no isolation share Spoolsv.exe. The failure 
of one driver could cause the failure of the entire print system.  

• Shared—Drivers share the same PrintIsolationHost.exe, separate from Spoolsv.exe, but not 
separate from other drivers within the shared PrintIsolationHost.exe process. The failure of one 
driver could cause the failure of all drivers sharing the isolated process, but would not cause 
failure to Spoolsv.exe.  

• Isolation—Each driver runs in its own PrintIsolationHost.exe process, separate from Spoolsv.exe, 
and separate from other drivers in isolation. Failure of one driver would not impact other drivers. 
Each print queue does not operate in its own instance of the PrintIsolationHost.exe. Instead, 
multiple queues using a single driver utilize the same instance of isolationhost.exe.  

Would a failure in the Spoolsv.exe cause dependent 
PrintIsolationHost.exe processes to fail?  
For installed print drivers defined to run in Shared or Isolation mode, PrintIsolationHost.exe is 
dependent on the underlying Spoolsv.exe. The PrintIsolationHost.exe process will become operational 
again when Spoolsv.exe recovers, but print job context might be lost during the spooler’s stop and 
restart process. 

What is the default isolation mode for HP drivers shipped with the 
Microsoft operating system?  
Shared isolation mode is the installed default for HP drivers shipped inbox with Microsoft Windows 7 
and Server 2008 R2 operating system installation media. 



 3

USING THE HP UPD IN DRIVER ISOLATION MODE 

Does the HP UPD support driver isolation mode?  
The driver in isolation mode is supported for the HP Universal Print Driver 5.0 and higher on 
Windows 7 and Server 2008 R2. This is true for all HP UPD PDLs (PS/PCL5/PCL6), for x32 and x64 
bit, and regardless of supported install method. This support includes:  

• HP UPD Dynamic Mode installations 
• HP UPD Traditional Mode, both version-specific and standard install  
• Two or more instances of the HP UPD in shared isolation  
• Combinations of HP UPD instances defined for isolated, shared, or none  
• All HP UPD supported installation methods (such as Add Printer Wizard, UPD’s Install.exe, 

printUI, and others)  
• Jobs spooled utilizing Enhanced MetaFile (EMF) (RAW spooling is handled by the Application 

process, not Spoolsv.exe, so isolation mode is not appropriate for RAW)  
• The ability to define the HP UPD to run in isolation mode via the Print Management Console 

(PMC), by Microsoft group policy, and via modification to the driver *.inf files  

What is the HP UPD install default for driver isolation mode?  
For both traditional and dynamic mode, the installation default for HP UPD prior to 5.1.1 was 
isolation mode set to “None”. For 5.1.1 and later, the installation default is “Shared isolation” (this 
change was announced in the 5.2 release notes). 

What isolation mode will subsequent installed instances of the HP UPD 
have?  
Assuming the absence of Microsoft policies for isolation mode, any subsequent install of the same 
HP UPD version will have the same isolation mode. This assumes that during installation the user 
selects, “Use the driver that is currently installed”. This step utilizes the *.inf stored on the local system.  

If the user selects “replace the current driver”, the install will use the *.inf where INSTALL.EXE was 
launched. If the selected driver is the same version, all installed instances of that driver version will 
inherit the defined settings of the *.inf from the installation directory.  

Will HP UPD Point and Print clients inherit the same isolation mode 
defined on the print server?  
Regardless of how isolation mode was defined for the HP UPD on the print server (via the PMC or 
using the *.inf prior to server installation), the server that vends the HP UPD to clients will not inherit 
isolation mode settings defined for the server. The vended driver will default to the no isolation mode.  

Isolation mode is not supported for Point and Print clients running Windows Vista, Windows XP, or 
Server 2003.  

Do HP UPD tools have settings specific to isolation mode?  
HP UPD tools such as Managed Print Administration (MPA), Driver Configuration Utility (DCU), Driver 
Deployment Utility (DDU), Active Directory Templates, and UPD’s install.exe do not have driver 
isolation settings. Driver isolation mode definition can be managed through the PMC, Printbrm, or 
Microsoft group policy, or defined in the driver *.inf prior to installation.  
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Is HP UPD performance impacted in driver isolation mode?  
Like other drivers on the system, the HP UPD competes for shared resources on the server. System 
resources are required for each driver(s) placed in isolation mode and the Windows system manages 
the resource. For each driver defined to run in full isolation mode, a unique instance of 
PrintIsolationHost.exe must launch, or drivers in shared isolation can share an instance of 
PrintIsolationHost.exe. Trade-offs exist between the stability achieved with driver isolation and 
demands on the print server or client. To optimize performance of the system, the Microsoft operating 
system opens and closes PrintIsolationHost.exe as required during print service operations.  

Does HP recommend driver isolation mode for the HP UPD?  
The HP UPD has identical functionality in both isolation and no isolation modes. Beginning with 
HP UPD 5.1.1, the driver installs by default to shared isolation mode. The decision to run the HP UPD, 
or any other HP driver, in isolation mode should be based upon the resources of the machine and the 
stability of all drivers sharing either spoolsv.exe or PrintIsolationHost.exe. A reasonable approach is 
to test new or suspect drivers in full isolation, monitor your resources, and assess driver stability before 
including the driver in shared isolation or in no isolation from spoolsv.exe. A second reasonable 
approach is to place drivers in isolation for the protection of the core printing subsystem.  

IMPLEMENTING ISOLATION MODE FOR THE HP UPD 

How can I use the PMC to define isolation mode for the HP UPD?  
HP recommends managing driver isolation settings for an installed instance of the HP UPD through the 
Microsoft Management Console (MMC) using the Print Management Console (PMC) snap-in. 

Windows Server 2008 R2 

The Print Management Console is automatically installed when you install a Print and Document 
Services role. (To confirm roles, select Start > Run, then type ‘Server Manager’.) The PMC supports 
remote management; installation of the PMC does not have to occur on the actual print server. Install 
the Print and Document Services Tools using the Add Features wizard. After the print services role is 
enabled on the server, the PMC management interface can be accessed by selecting Start > Run > 
MMC, then selecting File > Add/Remove Snap-in. Locate Print Management and select Add, then click 
OK.  

You can also access the PMC management interface by going to Start > All Programs > 
Administrative Tools > Print Management.  

Windows 7 

The Print Management snap-in is automatically installed and available through the Microsoft 
Management Console. To launch the MMC, go to Start and type “MMC” in the Search Programs and 
files box. Within the MMC, go to File > Add/Remove Snap-in, select Print Management > Add the 
Local Server, select Finish, and click OK. You can also set the HP UPD to isolation mode by going to 
Print Management > Printer Servers > [machine_name] > Drivers, select the HP UPD, and right-click 
on Set Driver Isolation.  

Can the HP UPD driver isolation mode be changed after installation?  
Utilizing Microsoft’s Print Management Console, options available for the installed HP UPD driver are 
None, Shared, Isolation, and System Default (the setting defined in the *.inf at time of the driver 
installation).  
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How can I use an HP UPD *.inf file to define isolation mode as the 
HP UPD installation default (for HP UPD 5x versions prior to 5.1.1)?  
Before proceeding with the HP UPD installation, add “DriverIsolation=2” string to a UPD *.inf file (see 
the sample section of an UPD *.inf file below). This change can be made to any of the available *.inf 
files in the driver package, and changing only one *.inf file is required. The change tells the installer 
that isolation mode is supported by the driver and defines the installation default.  

[Version]  

Signature="$Windows NT$"  

Provider=%HP%  

ClassGUID={4D36E979-E325-11CE-BFC1-08002BE10318}  

Class=Printer  

CatalogFile=hpcu091b.cat  

DriverVer=09/01/2009,61.091.13.01  

DriverIsolation=2  

NOTE Any change to the driver *.inf file breaks the WHQL signature, which results in a warning 
during HP UPD installation. For this reason, HP recommends choosing HP UPD v5.1.1 or 
higher for customers requiring isolation mode as the installation default.  

Following installation, the PMC user interface will display “Shared” in the Driver Isolation column. In 
addition, right-clicking on the UPD and selecting Set Driver Isolation will display “System Default 
(Shared)” since the setting came from the *.inf at the time of installation.  

What “DriverIsolation” settings are supported in the UPD *.inf file?  
The HP UPD supports all settings of driver isolation defined by Microsoft.  

DriverIsolation=0  

A setting of 0 (disabled) means the DriverIsolation setting is missing from the *.inf (such as with a 
legacy driver). The driver being installed will not operate in isolation mode. However, even if 0 is set, 
or no entry is made, the driver can subsequently be put into isolation mode based on Microsoft group 
policy settings.  

DriverIsolation=2  

When this setting is added to the HP UPD 5.0x driver, you will receive a WHQL error message at 
installation: “Windows can’t verify publisher of this driver software”. Select Install... and the HP UPD 
will be installed in shared isolation mode. 

Can Printbrm manage driver isolation mode?  
The Printbrm tool allows you to export and migrate driver isolation settings. Printbrm was introduced 
in Windows Vista and Windows Server 2008 as the replacement for the PrintMig utility.  

How can I use Microsoft group policy to manage driver isolation mode?  
Driver isolation mode can be managed by Microsoft group policy using one of two methods:  

1. Navigate to Computer Configuration > Administrative Templates > Printers > Execute print drivers 
in isolated processes. According to the operating system’s online help, “If you enable or do not 
configure this policy setting, the print spooler will execute print drivers in an isolated process by 
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default. If you disable this policy setting, the print spooler will execute print drivers in the print 
spooler process.” 

2. Navigate to Computer Configuration > Administrative Templates > Printers > Override print
driver execution compatibility setting reported by print driver. According to the operating system’s
online help, “This policy setting determines whether the print spooler will override the Driver
Isolation compatibility reported by the print driver. This enables executing print drivers in an
isolated process, even if the driver does not report compatibility. If you enable this policy setting,
the print spooler will ignore the Driver Isolation compatibility flag value reported by the print
driver. If you disable or do not configure this policy setting, the print spooler will use the Driver
Isolation compatibility flag value reported by the print driver.”

© 2016 Copyright HP Development Company, L.P. The information contained herein is subject to change without 
notice. The only warranties for HP products and services are set forth in the express warranty statements accompanying 
such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be 
liable for technical or editorial errors or omissions contained herein. 
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