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Introduction 
A Redundant Array of Independent Disks (RAID) is a data storage scheme that uses two or more drives accessed in 
combination to improve fault tolerance. Initially used with servers, desktop PCs are increasingly using RAID controllers 
and extra ATA or SCSI disks. Newer system boards often have RAID controllers.   

The HP EliteDesk and EliteOne 705 Business PCs take advantage of Serial Advanced Technology Attachment (SATA) and 
the integration of RAID into AMD D4 chipsets. The HP EliteDesk and EliteOne 705 Business PC products incorporate RAID 
drive support through factory configurations. This white paper provides a basic overview of RAID technology, supported 
factory configurations of HP EliteDesk and EliteOne 705 Business PCs, and other supported RAID configurations.  

Basics of AHCI and RAID Technology 

Definitions 
Table 1: Basic AHCI and RAID Definitions 

Acronym or term Description 

AHCI  Advanced Host Controller Interface, a specification for hardware and software, is a register interface for 
SATA intended to add higher speed, NCQ and other features. 

ATA  Advanced Technology Attachment, an interface standard to connect mass storage devices to the 
system. 

BIOS  Basic Input/Output System, also known as system ROM.  

Chipset  Collection of integrated circuits that controls the functionality of the system.  Chipsets are designed to 
work with specific processors. 

HDD Hard disk drive 

GPT GUID Partition Table is a standard for the layout of the partition table on a physical hard disk, using 
globally unique identifiers (GUID). 

IDE An interface for mass storage devices in which the controller is integrated into the drive. 

INF  
Information file (.inf) used by Microsoft® operating systems that support the Plug & Play feature. When 
installing a driver, this file provides the operating system needed, information about driver filenames, 
driver components, and supported hardware. 

Migration  Term used to describe the movement of data from one configuration or usage model to another.  

JBOD Just a Bunch of Disks. Logical drives concatenation (not tested or supported) 

LD Logical Drive, a grouping of physical drives presented as a single drive. 

MBR Master Boot Record, the boot sector that holds the hard drive configuration information such as the 
boot code and logical partitions. 

MDD Meta Data, i.e. previous RAID configuration information 

Mirroring Fault tolerance method using 100% duplication of data on two drives (RAID 1). After a failed drive is 
replaced, the RAID controller automatically rebuilds the lost data from the other two drives. RAID 
systems may have a spare drive (hot spare) ready and waiting to be the replacement for a drive that 
fails 

NCQ  Native Command Queuing, an extension of the SATA protocol that allows hard drives to reorder read and 
write operations for optimal performance. 

OS Operating System, software that controls the functions of the system hardware and applications. 

Option ROM  
Third party module that is loaded by the System BIOS which provides extended support for a particular 
piece of hardware. The RAID Option ROM provides boot support for RAID volumes as well as a user 
interface for managing and configuring the system's RAID volumes. 

Parity 
Mechanism for data integrity used for data recovery. Distributed parity is used in RAID 5 (requires 3 or 
more drives) to spread parity information so if any one drive fails, the other drives can rebuild the data. 

PCIe  PCI Express, a bi-directional serial version of PCI. 
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PnP  Plug and Play, automated hardware discovery and configuration. 

POST Power-On Self Test, a BIOS-initiated routine that executes when a system is powered on. System 
hardware is configured, component integrity is checked, and the system is booted. 

RAID  Redundant Array of Independent Disks, storage technology that combines multiple hard drives into a 
single logical unit. Described in more detail in this document. 

ROM  Read Only Memory, non-volatile memory that is resistant to modification. 

SATA  Serial ATA, a serialized interface (replacing ATA) to connect storage devices to the system. 

Stripe  Set of data on a single hard drive in a RAID 0 volume.  

Striping 
Group of all stripes going horizontally across all the hard drive members of a RAID 0 volume. Striping 
improves performance by interleaving bytes or groups of bytes across multiple drives so more than one 
disk is reading and writing simultaneously. 

UEFI 
Unified Extensible Firmware Interface is a specification that defines a software interface between an 
operating system and platform firmware. UEFI is meant to replace the Basic Input/Output System (BIOS) 
firmware interface. 

UFD 
USB Flash Drive, a storage device using flash memory and USB interface. It is used to install storage 
drivers during OS installation. 

 

Table 2:  RAID Modes 

Mode Purpose Minimal HDD Required 

RAID 0  Striped for Performance 2 

RAID 1  Mirrored for Protection 2 

RAID 0 + 1  Mirrored and Striped 4 (see note) 

RAID 5 Striped with parity 3 (see note) 

NOTE:  Not supported on HP EliteDesk and EliteOne Business PCs 

Important RAID Configuration information 
• RAID 1 is the only RAID configuration that HP EliteDesk and EliteOne 705 Business PC products offer as factory 

configuration. 

• The preconfigured systems:   

– Are complete RAID systems 

– Have both drives installed 

– Have the necessary Option ROM configuration 

– Are preloaded and preinstalled with all required software 

– Include a preinstalled operating system that is in mirrored mode out of the box 

Basic RAID Types  
This section provides a brief explanation of the supported RAID configurations for HP EliteDesk and EliteOne 705 
Business PCs.   

RAID 0 with two hard drives (Striped)  
Even though HP supports RAID 0, it is not the recommended configuration for business PC users. Lack of redundancy 
causes less than half the reliability of a single hard drive system since the Mean Time Between Failure (MTBF) of RAID 0 
is equal to the MTBF of an individual drive, divided by the number of drives.  
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Table 3:  RAID 0 with two hard drives (Striped) 

First disk Second disk 

Data Segment 1  Data Segment 2  

Data Segment 3  Data Segment 4  

Data Segment 5  Data Segment 6  

Data Segment 7  Data Segment 8  

Data Segment 9  Data Segment 10  

Data Segment 11  Data Segment 12  

Data Segment 13  Data Segment 14  

Data Segment 15  Data Segment 16  

 

In the previous table, each “Data Segment n” represents a group of data, known as a stripe. In this case, each row 
represents a stripe. RAID 0 represented in the table above shows how information is segmented, made into chunks or 
stripes, and stored across the stripes of the hard drive members of this RAID volume.   

To better illustrate the concept of RAID 0 and striping, the following graphic shows how a sequence of data “ABCD...” is 
stored in a RAID 0 mode. In this example, each letter represents a segment or stripe. The graphic shows how the various 
pieces of the information go to different hard drives. If any segment of RAID 0 fails, all information from all members is 
lost.  

Figure 1: Performance - RAID 0 with two hard drives 
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RAID 1 with two hard drives (Mirror) 
RAID 1 has redundancy and hence is a true RAID, which greatly increases reliability. The probability of one hard drive 
failure on a given day is the square root of the probability of both physical hard drives in the RAID 1 volume failing on a 
given day. Hypothetically, if the chance for a single hard drive failure is 1:2000, then the chance that both hard drives 
failing in RAID 1 is 1:4,000,000.  

Mirroring, segmentation, and striping have no real meaning in RAID 1. In the table and graphic, the data is arranged in 
rows for representation of different pieces of data.  

Table 4:  RAID 1 with two hard drives (Mirror) 

First disk Second disk 

Data Segment 5 Data Segment 5 

Data Segment 6 Data Segment 6 

Data Segment 7 Data Segment 7 

Data Segment 8 Data Segment 8 

 

In the previous table, each “Data Segment n” represents a group of data, known as a stripe. In this case, each row 
represents a stripe. This table shows how information is duplicated in both hard drives. The size of the stripes is mostly 
irrelevant and not a configurable option.  

Because it is a very cost-effective way to increase system storage reliability and a great value proposition, RAID 1 is the 
only RAID configuration that HP preconfigures for HP EliteDesk and EliteOne 705 Business PCs. RAID 1 provides high 
availability with minimal performance impact, as well as greater reliability compared to a single hard drive 
configuration. 

To better illustrate the concept of RAID 1 and mirroring, Figure 3 shows how a sequence of data “ABCD...” is stored in a 
RAID 1 volume. In this example, each letter represents a data segment. The graphic shows how the various pieces are 
replicated for both of the hard drives; hence, if any one member of the RAID 1 volume fails, the information is kept in the 
surviving members. After a hard drive failure, the user interface sends a notification so the failed hard drive can be 
replaced. No user information is lost in this scenario. 

Figure 2: RAID 1 with two hard drives 
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Recommended configurations for HP EliteDesk and EliteOne 705 Business PCs 
For best reliability, HP recommends factory configurations of the preinstalled RAID1. 

• The preinstalled RAID1 offering is a RAID 1 volume of two identical SATA hard drives or solid-state drives. You can 
select from a number of different SATA drive sizes. 

NOTE:  HP EliteDesk and EliteOne 705 Business PCs support Microsoft Windows operating systems.  

HP EliteDesk and EliteOne 705 Business PCs are based on the AMD D4 chipset, which is a combined hardware and 
software RAID solution. The mass storage controller operates in either AHCI or RAID mode. Changing the mode of the 
controller changes the PCI device ID and class code, requiring different device drivers in most operating systems.   

HP recommends AMD drivers for HP Business PC products, including all supported RAID configurations.   

WARNING: The PCI Device ID of the mass storage controller changes after changing the BIOS “SATA Emulation” 
Computer Setup option. Changing SATA Emulation from AHCI mode to RAID mode is the equivalent of connecting the 
hard drives to a new add-on RAID storage controller. The installed operating system on the hard drive is unaware of this 
new mass storage controller. If the operating system does not have the RAID drivers installed, the operating system will 
fail to boot. For example, All Microsoft OSs will cause a blue screen and/or reboot when attempting to boot in RAID mode 
without the RAID drivers installed.  

Other supported configurations  
HP EliteDesk and EliteOne 705 Business PC products support two other RAID configurations:   

• Two drive configuration.   

– Two equal size/type SATA drive RAID configurations in RAID 0 or RAID 1.   

– Maximum of two SATA optical drives.   

• Three drive configuration (only on HP EliteDesk 705 Microtower).   

– Three equal size/type SATA drive RAID configurations in RAID 0.   

– Maximum of one SATA optical drive.  

– NOTE: RAID 5 is not supported. 

 
Unsupported configurations  
HP EliteDesk and EliteOne 705 Business Desktop PC products only support the best user experience and highest 
possible reliability. As a result, HP does not support the following combinations of RAID hard drives:   

• Different sizes.   

• Different speeds (5400 rpm, 7200 rpm, etc.).   

• Old and new technologies (SATA 1.5 GB and SATA 3.0 GB).   

• NCQ hard drives and non-NCQ drives.   

• RAID combinations of hard drives with any operating system other than Microsoft Windows. 

• RAID configurations of two or more 10,000 RPM hard drives.  

• Any other RAID modes besides RAID 0 and RAID 1. 
 

Configuring RAID on non-factory preinstalled configurations  
The remaining sections of this white paper describe steps to set up supported RAID configurations where customers 
have not purchased factory preinstalled RAID configurations.  

WARNING:  Before configuring RAID in the Option ROM interface, be sure to back up all data. Once a RAID configuration is 
saved, all data will be erased and the drives will no longer be bootable until an operating system is re-installed.   
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Enabling RAID through F10 System BIOS  
1. Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.  

2. Press F10 as soon as the monitor light turns green.   

Note: If you do not press F10 at the appropriate time, you must restart the computer, and then press F10 again to 
access the utility.   

3. Use the arrow keys to select the Storage menu.   

4. Use the down arrow key to select Storage Options, and then press Enter.   

5. On the Storage Options menu, use the down arrow key to select SATA Emulation.   

6.  Press the right arrow key until RAID displays, and then press F10 to accept.   

 

          
 

7. To apply and save changes, select File > Save Changes and Exit 

– If you do not want to apply your changes, select Ignore Changes and Exit. 

– To reset to factory settings, select Apply Defaults and Exit. 

NOTE: Applying default settings never changes or resets the SATA Emulation mode. This setting must always be 
changed by selecting the appropriate mode from the F10 Setup Utility under Storage Options.  

CAUTION: Do NOT turn the computer power off while the ROM is saving the F10 Computer Setup changes as the CMOS 
could become corrupted. Only turn the computer off after exiting the F10 Setup screen.  

Configuring RAID Option ROM  
You can only access RAID configuration at system startup. To access the configuration screen and enable RAID:   

1. Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.   

Press Ctrl + R as soon as the monitor light turns green to enter the RAID configuration utility. If you do not press 
Ctrl +R at the appropriate time, you must restart the computer, and then press Ctrl + R again to access the utility.  

 
The RAID configuration utility is English only. To configure RAID in other languages, use the Web-based RAID 
configuration utility.  

Configuring RAID Volume using the Option ROM  
Once you are in the Option ROM you can access the Utility Main Menu by pressing Ctrl + R.   

From the Main Menu, use the arrow keys to go to different options. Press Enter to select. Press Esc to return to the main 
menu. 
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WARNING: Before configuring RAID, be sure to back up all data. Once a RAID configuration is executed and saved, data on 
the selected disks will no longer be retrievable.  

1. From the Main Menu, select Initialize Disks, and then press Enter to access the list of disks to configure. The Drives 
section of the screen displays a detailed description of available physical drives, including channel, size, and status.  
 

 
 

2. Use the A key or Ins key to select the disks to include in the RAID configuration. The text of selected disks turns 
green. Press Enter when you have selected all disks you want to configure. 
 

 
 

3. Press C to continue with the RAID configuration. Note that the selected disks will be initialized and all information 
will be deleted. 
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4. Select Create Array, and then press Enter. 

 
 

5. Use the A key or Ins key to select the disks to include in the RAID configuration. Press Enter when you have selected 
all disks you want to configure. 

6. Several options will display successively under User Input. Make the following selections, and then press Enter: 

- The type of RAID array to create. 
NOTE: RAID 5 is not supported. 
 

 
 

- The size to use to create the array 

 
 

- The caching mode to use for the array 
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7. Press C to create the array. 

 

 
 

8. Press Esc to exit. At system prompt, press Y to reboot or any other key to go back.   

Select boot order  
To set up your system to boot from the OS media, you may need to change the boot order in the F10 setup menu.   

1. Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.  

2. Press F10 as soon as the monitor light turns green.   

If you do not press F10 at the appropriate time, you must restart the computer, and then press F10 again to access 
the utility.  

3. Use the arrow keys to select Storage.   

4. Use the down arrow key to select Boot Order, and then press Enter.   

5. Use the down arrow key to select ATAPI CD-ROM Drive, and then press Enter. Press the arrow key up to the desired 
position in the boot order. Press Enter again and F10 to accept the change.   

6. To apply and save changes, select File > Save Changes and Exit.   

–  If you do not want to apply your changes, select Ignore Changes and Exit.   

–  To reset to factory settings, select Apply Defaults and Exit. This option restores the original factory defaults.   

 

Notes for operating system installation  
After creating a RAID disk volume in the option ROM and selecting the boot order, the operating system can be installed.   

Before proceeding, you will need the following:   

• Microsoft Windows OS media and Product Key.   

• RAID driver flash drive. To create, go to www.hp.com/support. Select your country and language, select Support and 
Drivers, click on Drivers and Software, enter the model number of the computer, and press Enter.   

The following steps apply to Microsoft Windows OS installations.   

1. Insert the Windows OS media and press any key to reboot the computer.   

2.  Press F9 at the prompt to begin installation.   
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3. When the load driver error window appears (below), insert the RAID driver flash drive and click Browse. 
 

 
 

4. Navigate to the directory where the .inf file is located, select it, and click Next.  
 

 
 

5. At the license screen check the “I accept…” box and click Next. 
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6. Select the partition for the OS to be installed and click Next. 
 

 
 
The OS will install. 

Failure to install and enumerate the RAID driver after enabling the RAID controller (with or without creating a volume) 
will result in a Windows boot failure (blue screen) for inaccessible boot device.   

WARNING: The PCI Device ID of the mass storage controller changes after changing the BIOS “SATA Emulation” Computer 
Setup option. Changing SATA Emulation from AHCI mode to RAID mode is the equivalent of connecting the hard drives to 
a new add-on RAID storage controller. The installed operating system on the hard drive is unaware of this new mass 
storage controller. If the operating system does not have the RAID drivers installed, the operating system will fail to 
boot.   

Additional technical information will be provided in the future for customers who want to add RAID SW image 
deployment capabilities.  

AMD Array Management Software (RAIDXpert2)  
This section of the paper focuses on how to configure RAID using AMD Array Management Software (RAIDXpert2).  

Java Runtime Environment  
RAIDXpert2 will install JRE 1.4 on your system unless you already have JRE versions 1.3.0 or 1.4.  

Console Software Installation  
The RAIDdriver softpaq also provides the AMD RAIDXpert2 utility, which you can install by running the setup.exe 
program provided. 

Log-in to RAIDXpert2  

1. Double-click on the RAIDXpert2 icon on your desktop.   

2. When the opening screen appears, type admin in the Username field. Type admin in the Password field. Note: 
The RAIDXpert2 login and password are case sensitive.   

3. Select the preferred language. 
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4. Click Submit. 

 
 
Recommended Initial Settings  
These recommended settings are most effective if you accept the initial recommended settings now. You can change 
them later as necessary.  

Administrator’s Settings  

To change the default password:  

NOTE: Usernames and passwords are case sensitive. 

1. From the Options menu, select Password. 

2. Type the user name in the Username box. 

3. Type the new password into the Password box. Use between 4 and 20 letters and numbers but no spaces or other 
characters.  
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4. Type the same password into the Confirm New Password box.  
 

 
 

With the Notification option, you can manage event log and email notifications of events. 

To set up Event Notification:  

1. From the Options menu, select Notification.  
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2. Specify the Outgoing Mail Server (SMTP) and To Email Address, to which email messages are sent when an event 
occurs. 

3. If the SMTP server requires a login, check the Server Required Login box and enter a valid Username and Password 
for the server. 

4. Specify a user address as the sender of the email notifications in From Email Address. 
NOTE: By default, the system on which RAIDXpert2 is installed is used. 

 
 

Degradation 
In the unlikely event that one of your hard drives malfunctions, RAIDXpert2 reports the condition with popup messages. 
If Event Notification is set up, RAIDXpert2 also reports the conditions with email messages. 

For More Information  
An HP online support document further describing setting up RAID using AMD RAIDXpert2 is available at the following 
web page:  

 

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01827420 
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