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Overview 

FTPS is an extension to the commonly used File Transfer Protocol (FTP) that adds support for the Transport Layer Security 
(TLS) and the Secure Sockets Layer (SSL) cryptograhics protocols. Certificates are an important factor of FTPS, and they are 
essential to creating a TLS/SSL connection. For FTPS, there are two types of certificates: server certificates and client 
certificates. A server certificate is necessary when setting up an FTPS server. This document introduces how to configure 
certificates on an IIS FTPS server and deploy those certificates to HPDM components. 

Note 
For instructions on setting up an FTPS site on an IIS server, see the HP Device Manager 4.7 FTP Configuration white paper. 

Server certificate 

A server certificate is used to prove that the FTPS Server is a legitimate server. Most FTPS servers support for server 
certificate authentication. When you set up an FTPS Server, you must provide a certificate for it. When these certificates are 
signed by a trusted certificate authority (CA), you can be assured that your device is connected to the requested server, 
avoiding man-in-the-middle attacks. If the certificate is not signed by a trusted CA (that is, it is a self-signed certificate), the 
FTPS client might generate a warning stating that the certificate is not valid. You can choose to accept the certificate or 
reject the connection. 

Configuring a server certificate on an IIS FTPS server 
1. On Windows Server 2008 R2, open IIS Manager (IIS 7.5). 

2. In the Server Manager, select your server, and then double-click Server Certificates. 

 
3. If necessary, create a certificate. See Creating a certificate signed by a CA or Creating a self-signed certificate. 

  

https://en.wikipedia.org/wiki/Certificate_authority
https://en.wikipedia.org/wiki/Man-in-the-middle_attack
https://en.wikipedia.org/wiki/Self-signed_certificate
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4. In the Server Certificates window, select Import. 

 
5. Browse to a certificate file (.pfx) that you requested from a trusted CA or created using tools such as OpenSSL and 

select it. Enter the password for this certificate, and then click OK. 

 
6. In the Server Manager, select <your server> > Sites > <your FTPS site>, and then double-click FTP SSL Settings. 
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7. Select the certificate you imported in step 5, and then click Apply. 

 

Creating a certificate signed by a CA 
1. In the Server Certificates window, select Create Certificate Request. 

 
2. Enter the Distinguished Name Properties information, and then click Next. 
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3. Select a Cryptographic service provider and Bit length, and then click Next. 

 
4. To save the certificate request, select a location for the file, and then enter a file name. Click Finish. 

 
5. In your browser, go to http://<CA-address>/certsrv. 

6. Select Request a certificate. 

7. Select advance certificate request. 

8. Select Submit a certificate request by using a base-64-encoded CMC or PKCS #10 file, or submit a renewal 
request by using a base-64-encoded PKCS #7 file. 

9. Open the certificate request you saved in step 4. 
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10. Select the text betweent the lines ---BEGIN NEW CERTIFICATE REQUEST---- and ----END NEW 
CERTIFICATE REQUEST----, and then copy it. 

 
11. Paste the text in Saved Request, and then click Submit. 

12. In the Web Access Confirmation Prompt, click Yes. 

 
13. Select Base 64 encoded, click Download certificate, and then save it. 

14. In IIS Manager, select Server Certificates. 

15. Select Complete Certificate Request. 
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16. Select the file you saved in step 13. This file contains the CA response. Enter a name for this certificate, and then click 
OK. 

 

Creating a self-signed certificate 
1. In the Server Certificates window, select Create Self-Signed Certificate. 

 
2. Enter a Friendly Name for this certificate, and then click OK. 
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Configuring a trusted-certificate list in HPDM 
By default, when connecting to an FTPS server, HPDM accepts the connection automatically and does not verify the server 
certificate. If you want to verify the server certificate when connecting to an FTPS server, create a certificate trust list (CTL) 
and deploy it to your HPDM components. 

Exporting a PEM-format certificate from a certificate 
1. In the Details tab of the Certificate dialog, select Copy to File. 
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2. In the dialog that appears, click Next. 

 
3. Select No, do not export the private key, and then click Next. 

 
4. Select Base-64 encoded X.509 (.CER), and then click Next. 
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5. Click Browse, select the file you want to export, and then click Next. 

 
6. Click Finish. You can open the exported PEM certificate in Notepad. 

 

Creating the CTL 
In HPDM, the CTL is a file containing trusted Privacy Enhanced Mail (PEM) format certificates. This file is used to verify server 
certificates. If you want your HPDM components to verify server certificates, you must create this file. 

The name of this file is ctl.pem and cannot be changed. If the server certificate is a self-signed certificate, copy its PEM-
format certificate content to ctl.pem. If the server certificate is available in a CA chain, copy all CA certificates on this CA 
chain to ctl.pem. 

To create ctl.pem: 

1. On Windows Server 2008 R2, open IIS Manager (IIS 7.5). 

2. In the Server Manager, select your server -> Sites -> your FTPS site, and then double-click FTP SSL Settings. 
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3. Click View. 

 
4. In the dialog that appears, select the Certification Path tab and then export the certificate. 

If there is only one root node, it means that this is a self-signed certificate. Export it using the procedure in Exporting a 
PEM-format certificate from a certificate. 
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If there is more than one node, it means that this is a certificate from CA chain. See the following figure. 

 
In this example, the name of the certificate is HPDMEndClient. HPDMClientCA is the root CA of HPDMEndClient and 
HPDM is the root CA of HPDMClientCA. In this scenario, you need to export both the HPDMClientCA and HPDM 
certificates; however, you do not need to export HPDMEndClient itself. Double-click the node HPDMClientCA, and then 
export it using the procedure in Exporting a PEM-format certificate from a certificate. Export the HPDM certificate using 
the same procedure. 

5. In Notepad, open the certificate files you exported in step 4. Select all content and copy it to the file named ctl.pem. If 
the file ctl.pem does not exist, create it first. 
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Deploying the trusted-certificate list to HPDM 
To verify the server certificate when HPDM components connect to the FTPS server, deploy the ctl.pem file created in 
Creating the CTL to HPDM components. Otherwise, HPDM does not authenticate the server certificate and accepts the 
connection automatically.  

• On the HPDM Console, HPDM Server, HPDM Gateway, and Master Repository Controller, copy the ctl.pem file to the 
folder %HPDMInstallPath%\Certificates\repos_certs\. 

• On HPDM Agents running a Windows Embedded operating system, copy the ctl.pem file to the folder 
c:\windows\xpeagent\repos_certs\.  

• For HPDM Agents running HP ThinPro, copy the ctl.pem file to the folder /etc/hpdmagent/repos_certs/. 

Note: 
If you want the HPDM to skip server-certificate authentication and accept the connection automatically, remove the 
ctl.pem from all HPDM components. 

Client certificate 

A client certificate is used to prove that the FTP client is a legitimate client device when it connects to an FTPS server. Only a 
few FTPS servers support client-certificate authentication, and only IIS FTPS servers can support client-certificate 
authentication. If the FTPS server has enabled the client-certificate-authentication option, the client device needs to provide 
a legitimate certificate when connecting to this FTPS server. The FTPS server refuses the connection if the client certificate 
fails to pass the client-certificate authentication. This section introduces how to configure client-certificate authication on an 
IIS FTPS server. 
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Configuring client-certificate authentication on an IIS FTPS server 
If you want the IIS FTPS server to authenticate the client certificate, you need to enable client-certificate authentication on 
the IIS FTPS server side first. There is no user interface for this option; however, you can configure it by modifying an IIS 
configuration file. 

1. In Notepad, open the configuration file ApplicationHost.config. This is typically located in 
your %WinDir%\System32\Inetsrv\Config folder. 

In the file, search for your FTPS site name. In the following example, the FTPS site name is FTPSTest.

 
2. Under the element <authentication>, clear the current content and enter the following. 

<authentication> 

 <anonymousAuthentication enabled="false" /> 

 <basicAuthentication enabled="false" /> 

  <clientCertAuthentication enabled="true" /> 

</authentication> 

3. Under the element <security>, enter the following subelement <sslClientCertificates>. 
 <sslClientCertificates clientCertificatePolicy="CertRequire" 
useActiveDirectoryMapping="true" /> 

4. Save your updated ApplicationHost.config file. 

 
For more details about client-certificate authentication, go to 
http://www.iis.net/configreference/system.applicationhost/sites/site/ftpserver/security/authentication/clientcertauthentica
tion. 

Configuring Active Directory mapping 
In an IIS server, client-certificate authentication uses Active Directory to map client certificates against a user account in a 
domain. There must be a Domain Controller (DC) and a CA in your environment, and they must be installed on the same 
device. For instructions on setting up a CA, see the HP Device Manager 4.7 SCEP Tutorial white paper. 

http://www.iis.net/configreference/system.applicationhost/sites/site/ftpserver/security/authentication/clientcertauthentication
http://www.iis.net/configreference/system.applicationhost/sites/site/ftpserver/security/authentication/clientcertauthentication
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Verifying the DC and CA configuration 
After setting up the DC and CA on a single device, verify that the components are configured correctly. 

1. Verify that the following roles are enabled: 

– Active Directory Certificate Services 

– Active Directory Domain Services 

– Web Server (IIS) 

2. Verify that the Active Directory Certificate Services has the following Role Services installed: 

 
3. Verify that the Active Directory Domain Services has the following Role Services installed: 
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4. In the DC, verify that the following IIS Role Services are installed: 
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Verify the IIS Server configuration 
1. Verify that the IIS Server is located on the same domain as the DC and CA.  

If the IIS Server is not installed on the same device as the DC and CA, you must ensure that the device it is installed on 
joins the same domain as the DC and CA device. 

2. Verify that the Web Server (IIS) role is enabled 

3. Verify that the following IIS Role Services are installed: 
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Requesting a client certificate from your CA 
1. To request a client certificate, go to http://<CA-address>/certsrv. The CA address is the address of the device where the 

DC and CA installed. 

2. Click Request a Certificate. 

3. Click advance certificate request. 

4. Click Create and submit a request to this CA. 

5. If a Web Access Confirmation prompt appears, click Yes. 

6. Enter your Identifying Information. 

 
7. Under Type of Certificate Needed, select Client Authentication Certificate. 
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8. Under Key Options, select Mark key as exportable. Do not change the other default options. 

 
9. Enter a Friendly Name for this certificate, and then click Submit. 

 

10. If a Web Access Confirmation prompt appears, click Yes. 
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11. Click Install this certificate. 

 
12. After you have clicked Install this certificate, if you see This CA is not trusted, click install this CA certificate. 

Othewise, skip this step. 

 

Note: 
In the Certificate Import Wizard used to install the CA certificate, select Place all certificates in the following store, 
and then select Trusted Root Certification Authorities as the Certificate store. 
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13. There is a confirmation when your certificate has successfully installed. You can also confirm that the client certificate 
has been installed by selecting Internet Explorer > Tools > Internet Options > Content > Certificates. In the 
Personal tab, verify that your certificate is listed. 

 

Mapping the client certificate to a user account in a domain 
1. Go to http://<CA-address>/certsrv. The CA address is the address of the device where the DC and CA installed. 

2. Select Server Manager > Roles > Active Directory Certificate Services > <Your CA>. 

3. Click Issued Certificates. Verify that you see the certificate issued in Requesting a client certificate from your CA. 

 
4. Right click this certificate, and then click Open. 

5. Export this certificate using the procedure in Exporting a PEM-format certificate from a certificate. 

6. Go to the DC Server. 
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7. Select Server Manager > Roles > Active Directory Domain Services > Active Directory Users and Computers > 
<Your Domain>. 

8. Select Users. 

 
9. Click View > Advanced Features. 

 
10. Right-click the user name (in this example, Administrator), and then click Name Mappings. 
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11. In the Security Identity Mapping dialog that appears, select the X.509 Certificates tab, and then select Add. 

 
12. Select Browse, select the location where you saved the user certificate when you exported it in step 5, and then click 

Open. 

13. Click OK. 

 
14. Click OK. 

 
The client certificate is now mapped against the user account. 
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Verifing the client-certificate authentication 
After enabling client-certificate authentication and mapping the client certificate against a user account in your domain, the 
configuration of client certificate authentication on the IIS Server is complete. Now, you can verify your configuration via an 
FTP client. Only a few FTP clients support for using a client certificate when connecting to FTPS server. The following 
procedure uses SmartFTP, a GUI-based FTP client that supports client-certificate authentication. 

1. On the device where you installed the client certificate that you requested, install SmartFTP. 

2. Enter your FTPS Server Address, user name, and port 990. You do not need a password to use client-certificate 
authentication. 

3. Open the properties dialog of your connection. Under Client Certificate, select Enable, and then select the client 
certificate. 

 
4. Click OK. 

5. Connect to the FTPS server, and then upload and download a file. If you cannot complete any one of these three 
functions, verify your configuration step by step. 

Deploying a client certificate to HPDM 
After you enable client-certificate authentication and configure the IIS FTPS server side, the FTP client must provide the 
correct client certificate information when connecting to your FTPS server. If there is no client certificate or if the client 
certificate fails to pass the authentication, the FTPS server refuses the connection.To connect your HPDM components to an 
FTPS server that has client-certificate authentication enabled, you must deploy your client certificates to all HPDM 
components. 

Exporting a client certificate 
After you have completed the procedure in Requesting a client certificate from your CA, a client certificate is installed on that 
device. If you want to deploy this client certificate to HPDM, you need to export it first. 

1. Select Internet Explorer > Tools > Internet Options > Content > Certificates > Personal, and then select the 
certificate that you requested. 
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2. Click Export. 

3. Click Next. 

 
4. Select Yes, export the private key, and then click Next. 

 
5. Select Personal Information Exchange – PKCS #12 (.PFX), and then click Next. 
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6. Enter a password for the private key. 

 
7. Select Browse, select the file you want to export, and then click Next. 

 
8. Click Finish. 
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Preparing a client certificate and its private key for HPDM 
HPDM supports only PEM-format certificates and private keys. To use the PFX-format client certificate exported in Exporting 
a client certificate, you must export the PEM-format certificate and its private key from the PFX file. HP recommends using 
OpenSSL. If you need the OpenSSL tool, contact HP Support. 

• For HPDM, the file name of the client certificate is client.pem and it cannot be changed. In OpenSSL, use the following 
command to export the client certificate file. 
openssl pkcs12 -in yourclientcert.pfx -out client.pem -clcerts -nokeys 

• For HPDM, the file name of the private key of the client certificate is client.key and it cannot be changed. In OpenSSL, 
use the following commant to export the private file. 
openssl pkcs12 -in yourclientcert.pfx -out client.key -clcerts –nocerts 

• When you export the certificate and private key, you must to provide the password entered when you exported the PFX 
file, and then enter a new password for the private key. 

Deploying a client certificate to HPDM components  
After preparing the client.pem file and the client.key file, you must deploy them to each HPDM component. If you do not, 
HPDM cannot to connect to an FTPS server that has client-certificate authentication enabled. 

To deploy the files to HPDM Console, HPDM Server, HPDM Gateway and Master Repository Controller: 

1. Copy client.pem and client.key to the folder 
%HPDMInstallPath%\Certificates\repos_certs\. 

2. To deploy the password for the client key, open a command prompt, change the current path to 
%HPDMInstallPath%\Certificates\, and then run the command dmenc <password> where <password> 
is the password you entered when you exported the PEM-format private key. 

For example, if the password is HPDM, run command dmenc HPDM. 

To deploy the files to HPDM Agents running a Windows Embedded operating system: 

1. Copy client.pem and client.key to the folder c:\windows\xpeagent\repos_certs\. 

2. Deploy the password of the private key by sending the following script task to the devices via HPDM. 
c:\windows\xpeagent\dmenc <password> 

To deploy the files to HPDM Agents running HP ThinPro: 

1. Copy client.pem and client.key to the folder /etc/hpdmagent/repos_certs/. 

2. Deploy the password of the private key by sending the following script task to the devices via HPDM. 
/usr/sbin/dmenc <password> 

Note 
If you want each HPDM Agent to use a different client certificate, you must request each client certificate, map each client 
certificate to a user account, prepare client.pem and client.key files for each client certificate, and then deploy each client 
certificate to a different HPDM Agents, one at a time.
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