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1 Abstract 

HP redesigned the 2015 generation of BIOS to support the requirements of the latest CPU and operating systems. HP took 
this opportunity to create a new BIOS architecture based on the UEFI specification version 2.4 with a common set of core 
modules capable of supporting both notebook and desktop models. Now HP notebooks and HP desktops models using this 
generation of the BIOS will have a similar look and feel for the (F10) setup menu, more shared WMI strings, and more 
shared features. 
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2 Introduction 

This white paper provides detailed information about features adjusted through the F10 BIOS setup menu. The section on 
computer notifications provides an explanation for the LED blink codes and screen messages that may occur. 

For decades, HP has provided an industry leading level of built in customer value through an internally developed Read Only 
Memory Basic Input/Output System (ROM BIOS), a set of routines that enable a PC to load the operating system and 
communicate with various devices such as storage drives, keyboard, display, slots, and ports. The BIOS ensures that there is 
a high degree of integration between firmware and HP professional innovations such as HP ProtectTools, HP Power 
Assistant, and HP Client Management Solutions. 

Currently a common BIOS experience for HP notebooks and desktops has been developed. Desktop models will move to a 
notebook user interface that supports mouse control. To help users understand the new features, the description of each 
feature includes a reference to the name and location of that feature from the previous year, if it is different from the 
current year. 

2.1 Supported models 

This document applies to HP commercial-grade notebooks and desktops. That is products designed to meet the demanding 
security and manageability requirements of national, regional, and local government agencies, schools, the military, 
international financial institutions and retail sales companies. 

This document applies to 2015 models only. For reasons previously stated, the BIOS setup menu has significant changes 
from previous years. For reference, the table below shows the year associated with particular models. In the feature 
documentation below, references to 2014 models are applicable to 2014 and earlier. 

Table 1  Notebook Generations 

Platforms 2013 2014 2015 

HP EliteBook Folio  9480m  x  

HP EliteBook Folio 1040  G2 G3 

HP EliteBook Folio 1020  G1  

HP ZBook  17 x G2 G3 

HP ZBook  15 x G2 G3 

HP ZBook  14 x G2  

HP ZBook  15u  G2 G3 

HP EliteBook  850 G1 G2 G3 

HP EliteBook  840 G1 G2 G3 

HP EliteBook  820 G1 G2 G3 

HP EliteBook  755  G2 G3 

HP EliteBook   745  G2 G3 

HP EliteBook  725  G2 G3 

HP ProBook  470  G2 G3 
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Platforms 2013 2014 2015 

HP ProBook  450  G2 G3 

HP ProBook  440  G2 G3 

HP ProBook  430  G2 G3 

HP ProBook  445  G2 G3 

HP EliteFolio 940 x   

HP EliteBook Folio    G3 

HP EliteBook  Revolve 810   G3 

HP ProBook    G2 

HP ZBook Studio   G3 

HP ProBook  455   G3 

 

Table 2  Desktop Generations 

Platforms 2014 2015 

HP EliteDesk 800 TWR  G2 

HP EliteDesk 880 TWR  G2 

HP EliteDesk  800 SFF  G2 

HP EliteDesk  800 DM (35W) G1 G2 

HP EliteDesk  800 DM (65W)  G2 

HP EliteOne  800 AiO 23 T & NT (GPU down)  G2 

HP EliteOne   800 AiO 23 T G1 G2 

HP EliteOne  800 AiO 23 NT  G2 

HP EliteDesk  705 MT G1 G2 

HP EliteDesk 705 SFF G1 G2 

HP EliteDesk  705 DM G1 G2 

HP EliteOne  705 AiO 23 T  (23 NT dropped) G1 G2 

HP ProDesk 600 MT G1 G2 

HP ProDesk  680 MT  G2 

HP ProDesk  600  SFF  G2 

HP ProDesk  600 DM G1 G2 

HP ProOne  600 AiO 21.5 T (EMEA only)  G2 

HP ProOne 600 AiO 21.5 NT  G2 

HP ProDesk  400 SFF (2x2) G2 G2.5 

HP ProDesk  400 MT G2 G3 



May 2016 

857394-002 

HP PC Commercial BIOS (UEFI) Setup   

 

© Copyright 2016 HP Development Company, L.P. 2 Introduction   8 
 

Platforms 2014 2015 

HP ProDesk  400 SFF (2x2)   

HP ProDesk  480 MT G2 G3 

HP ProDesk  490 MT G2 G3 

HP ProDesk  498 MT  G2 G3 

HP ProDesk  400 DM  G1 

HP ProDesk  400 DM  G2 

HP ProOne  400 AiO 20 T/NT  G2 

HP ProOne  460/480 AiO 20 T  G2 

HP Collaboration PC   G2 

 

Table 3  Additional 2014 Models 

Platforms 2014 

HP EliteOne  800  AiO 21.5 NT G1 

HP EliteDesk 705 MT G1 

HP EliteDesk  700 SFF G1 

HP EliteDesk  700 MT G1 

HP ProDesk  405 MT G1 

HP ProDesk   485  MT G2 

HP ProDesk  405 MT G2 

HP ProDesk  485 MT G2 

HP ProDesk  405 MT G2 

HP ProDesk  485 MT G2 

HP ProDesk  400 MT G2 

HP ProDesk  400 SFF G2 

HP ProOne  400 AiO 19.5 NT  G2 

HP ProOne  400 AiO 21.5 T G2 

HP ProOne  400 AiO 21.5 T G2 

HP 402 SFF  G1 

HP 406 MT G1 

HP 18 AiO Business  

 

This document applies to products with the N family of BIOS, introduced in 2015 to 2016. 

An N family BIOS is a version that begins with the letter N. For example “N01 ver. 02.04 10/12/2015.” 
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To be sure that this document applies to your product simply look at the header of the F10 setup menu. The new BIOS has 
four tabs: 

 Main 

 Security 

 Advanced 

 UEFI Drivers. 

This is completely new for Desktops and Notebooks since the UEFI Drivers tab has been added recently. 
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3 F10 Main Menu 

    

 

Main Security Advanced UEFI 

Drivers 

    HP Computer 

Setup 

Organization of the F 10 section: 
The hierarchy of the table of contents matches the sequence of the menus found in the F10 Setup menu, currently three 
levels deep. 

The top level tabs are: Main, Security, Advanced and UEFI Drivers. 

The next level are the menus found under these tabs. 

At the beginning of each major section is a diagram of the sub-menu items for each tab. 

A table provides a list of features for each menu. 

At the top of the table is a breadcrumb trail that describes the menu relationship in the hierarchy. 

Advanced ->Port Options Continued…  

Feature Type Description Default Notes 

 

The table has columns for feature, type, description, default and notes. The following is a field description or definition. 

Feature 
This is the name of the feature as it appears in the Setup menu. A feature prefaced with box or underlined shows how it 
appears in the menu. 

Type 
Features can be settings, actions, another menu, or display only settings. Most of the features by far are settings. A setting 
is system value modifiable by the user, using a check box, a drop down menu or a text box. 

Description 
If the feature is a setting with a drop down box, then all possible values are displayed. If the feature is new or has changed 
its name or location from the 2014 notebooks or desktops, then the description references or includes its previous name 
and location. The notation to describe the location indicates the menus that the user must navigate through to access the 
feature. For example: Menu 1->Menu 2->Feature X  indicates that to access Feature X, the user navigates through Menu 1 
to Menu 2. 

Default 
For features that are settings, this column provides the factory default setting. 
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Notes 
Some features are not available for all types of models. The notes will describe when a feature is Intel only, AMD only, 
notebook only or desktop only. 

Some actions require a reboot or physical presence. Physical presence is a menu that requires a human response to validate 
that a person is physically present before the action is completed. Actions that require physical presence are security 
sensitive changes. 

    

 Main Security Advanced UEFI Drivers 

    HP Computer Setup 

 

 System Information 

 System Diagnostics 

 Update System BIOS 

 

 System IDs 

 

 Replicated Setup 

 Save Custom Defaults 

 Apply Custom Defaults and Exit 

 Apply Factory Defaults and Exit 

 Ignore Changes and Exit 

 Save Changes and Exit 

 

3.1 Main Menu 

The following table describes the features in the Main menu. 

Table 4  Main Menu features 

Feature Type Description Default Notes 

System Information Menu System information, such as serial number, model 

number, CPU type, and memory configuration 

2014 Desktop: File -> System Information 

  

System Diagnostics Menu Application to run diagnostic tests on your system, such 

as start-up test, run-in test, memory test, and hard disk 

test 

2014 Desktop: New 
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Feature Type Description Default Notes 

Update System BIOS Menu Update system firmware from FAT 32 partition on the 

hard drive, a USB disk–on-key, or the network 

2014 Desktop: New menu. The equivalent 2014 feature 

for File -> Flash system ROM is located under this menu 

  

System IDs Menu Identification strings that assigned by an enterprise to 

track the system. 

2014 Notebook & Desktop: Security -> System IDs 

  

Replicated Setup Action Save your current BIOS settings, and later restore your 

setting from this file. 

2014 Notebook:  New 

  

Save Custom Defaults Action As an alternative to factory default settings, create 

custom default values for all but the security settings. It 

is not possible to create custom default values for 

security settings. 

2014 Notebook: New 

2014 Desktop: File -> Default Setup -> Save Current 

Settings as Default 

 Reboot 

required 

Apply Custom Defaults and 

Exit 

Action Set all but the security settings to your custom default 

values 

Note: For 2014 Desktops, you could only restore to one 

set of defaults. This year it is possible to restore to 

custom defaults or the factory defaults. 

2014 Notebook: New 

2014 Desktop: File -> Default Setup -> Apply Defaults 

and Exit 

  

Apply Factory Defaults and 

Exit 

Action Set all, but the security settings to factory values. See 

the Security menu section to set security settings to 

factory values 

2014 Notebook: Main -> Restore Defaults 

2014 Desktop: Two-step process. 

 File -> Default Setup -> Restore Factory Settings as 

Default 

 File -> Apply Defaults and Exit 

  

Ignore Changes and Exit Action Exits F10 Setup without saving any changes made during 

current session 

2014 Desktop: File -> Ignore Changes and Exit 

  

Save Changes and Exit Action Exits F10 Setup and saves all changes made during 

current session 

2014 Desktop: File -> Save Changes and Exit 
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3.2 Update System BIOS Menu 

This sub-menu under the Main menu provides information about the current system firmware, settings; these control 
updates, the ability to check for updates over the internet or on the local network, and the ability to update system firmware 
from a FAT 32 partition on the hard drive, or a USB disk–on-key. 

For the BIOS flash to succeed, do not remove power or turn off the system during any phase of the process. Below is a 
description of the BIOS flash phases to help you avoid interrupting the process. The BIOS flash proceeds in four phases: 

1. The system displays a progress bar. When progress is 100%, the system reboots. This is the initial BIOS flash. 

2. The screen is black; the system blinks one LED and makes a steady beeping sound. This is the system flashing the 
boot block. Video cannot display during this phase; so, the LED and the beep are the only way to let you know that 
the system is flashing normally. 

3. (Sure Start enabled systems only) A screen indicates that the system is copying the DXE to the HP Security Device 

4. The screen is black for a short period, and then the OS starts. The BIOS flash is now complete. 

Table 5  Update System BIOS Menu features 

Feature Type Description Default Notes 

Current System BIOS Version Display 

Only 

   

Current BIOS Release Date Display 

Only 

   

Installation Date of Current BIOS Display 

Only 

   

Most Recent Update Check Display 

Only 

   

Check the Network for BIOS Updates 

(or) Check HP.com for BIOS Updates 

Action Updates the system BIOS by using an image 

stored on hp.com or another source defined in 

the “BIOS Update Preferences” menu. 

When BIOS source is HP.com, then the feature 

appears as “Check HP.com for BIOS Updates” 

2014 Desktop: File -> Flash System ROM -> 

Network 

 Reboot 

required 

 Lock BIOS version Setting When checked, disallows BIOS updates. 

2014 Desktop: New 

Unchecked  

 Allow BIOS Update using a Network Setting When checked, automatic BIOS updates through 

the network in a scheduled basis. 

2014 Desktop:  Advanced -> Update BIOS via 

Network -> Automatic BIOS Update Setting 

Checked  

BIOS Update Preferences Menu Menu with network BIOS update settings such as 

source, actions when and update is available and 

the frequency to check for updates. 

2014 Notebook: Main -> Network Update 

Settings 

2014 Desktop: Advanced -> Update BIOS via 

Network 
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Network Configuration Settings Menu Configure the network connection to the server 

that is the host for your system firmware 

updates. 

2014 Notebook & Desktop: New 

  

Update BIOS using Local Media Action Updates the system BIOS by using an image 

stored on local media such as the hard drive or a 

USB drive formatted as FAT32 or EFI system 

partition. 

2014 Desktop: File -> Flash System ROM -> Hard 

Drive 

 Reboot 

required 

3.3 BIOS Update Preferences Menu 

The “Update System BIOS” sub-menu provides a method for initiating a check for an update to the current system firmware 
and settings that control where to check for system firmware updates, what to do when an update is available, and the 
frequency to check for system updates 

Table 6  BIOS Update Preferences Menu features 

Feature Type Description Default Notes 

 Check for Update on 

Next Reboot 

Action When checked, check if an updated BIOS is available during the 

next boot. This feature is only necessary from a WMI call. From 

the F10 Setup menu use the feature “Main -> Update System 

BIOS -> Check the Network for BIOS Updates” that will check for 

updates without a reboot. 

2014 Notebook:  Main -> Network Update Settings -> Check for 

Update on Next Reboot 

2014 Desktop:  Advanced -> Update BIOS via Network -> Force 

Check on Next Reboot 

Unchecked Reboot 

required 

BIOS Source Setting Select the source URL for BIOS updates 

 HP.com 

 Custom URL 

2014 Notebook:  Main -> Network Update Settings -> BIOS 

Source 

2014 Desktop: Advanced -> Update BIOS via Network -> Update 

Source 

HP.com  

Edit Custom URL Setting When not using HP.com, define the custom URL here. 

2014 Notebook:  Main -> Network Update Settings -> BIOS 

Source -> Edit Custom URL 

2014 Desktop: Advanced -> Update BIOS via Network -> Update 

Address 
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Feature Type Description Default Notes 

Automatic BIOS Update 

Setting 

Setting Defines how automatic updates behave. The following settings 

are possible: 

 Do not update 

 Check for BIOS updates automatically, but let me decide 

whether to install them 

 Download and install normal BIOS update automatically 

 Download and install important BIOS updates automatically 

2014 Notebook:  Main -> Network Update Settings -> 

Automatic BIOS Update Setting 

2014 Desktop: Advanced -> Update BIOS via Network -> 

Automatic BIOS Update Setting 

Do Not 

Update 

 

BIOS Update Frequency Setting Sets the frequency of checks to the BIOS update server. If a 

newer version of BIOS has been made available on the network 

server, the system will prompt to update the BIOS 

 Daily 

 Weekly 

 Monthly 

2014 Notebook:   Main -> Network Update Settings -> BIOS 

Update Frequency 

2014 Desktop:  Advanced -> Update BIOS via Network -> 

Automatic Update Frequency 

Monthly  

3.4 Network Configuration Settings Menu 

The “Update System BIOS” sub-menu configures the network connection to the server that is the host for the system 
firmware updates 

Table 7  Network Configuration Settings Menu features 

Feature Type Description Default Notes 

 Proxy Server Setting When checked, enables the use of a proxy server 

2014 Notebook: Main -> Network Update Settings -> Proxy server 

2014 Desktop: Advanced -> Connected BIOS -> Use Proxy 

Unchecked  

Edit Proxy Server Setting Specify the Proxy Server Address and the Port Number through the 

common-used <server>:<port> notation 

2014 Notebook: Main -> Network Update Settings -> Edit Proxy 

Server 

2014 Desktop: Advanced -> Connected BIOS -> Use Proxy 

  

Test Network 

Connection 

Action Check the network connection using current BIOS update 

configuration 

2014 Notebook: Main -> Network Update Settings -> Test Network 

Connection 

2014 Desktop: New 

  

IPv4 Configuration Setting The following settings are possible: 

 Automatic 

 Manual 

Automatic  
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Feature Type Description Default Notes 

2014 Notebook & Desktop: New 

IPv4 Address Setting When IPv4 settings are manual, setup for static IPv4 address 

2014 Notebook & Desktop: New 

  

IPv4 Subnet Mask Setting When IPv4 settings are manual, configure a valid IPv4 address for 

subnet mask 

2014 Notebook & Desktop: New 

  

IPv4 Gateway Setting When IPv4 settings are manual, configure a valid IPv4 address for 

gateway. 

2014 Notebook & Desktop: New 

  

DNS Configuration Setting Configure a list of DNS addresses. The following settings are 

possible: 

 Automatic 

 Manual 

2014 Notebook & Desktop: New 

Automatic  

DNS Addresses Setting When DNS configuration is manual, configure a comma separated 

list of DNS addresses 

2014 Notebook & Desktop: New 

  

Data Transfer Timeout Setting Set data transfer timeout in seconds. It is recommended not to use 

values under 15 seconds 

2014 Notebook & Desktop: New 

30  

 Force HTTP No Cache Setting When checked, disables HTTP caching. This means that caching in 

upstream proxies is disabled as well, which guarantees that the 

BIOS goes all the way to the content source for any updated BIN 

files or catalog files but might slow down downloads slightly. 

2014 Notebook & Desktop: New 

Unchecked  

3.5 System IDs Menu 

This sub-menu provides identification strings assigned by an enterprise to track the system. 

Table 8  System IDs Menu features 

Level Feature Type Description Default Notes 

2 Asset Tracking 

Number 

Setting Allows custom configuration of an asset tag (up to 18 

characters) 

2014 Notebook & Desktop: Security -> System IDs -> Asset 

Tracking Number 

Serial 

Number 

 

2 Ownership Tag Setting Allows custom configuration of an ownership tag (up to 80 

characters) 

2014 Notebook: 

Security -> System IDs -> Ownership Tag (40 characters) 

Security -> System IDs -> Ownership Tag 2 (40 characters) 

2014 Desktop: Security -> System IDs 

Blank  



May 2016 

857394-002 

HP PC Commercial BIOS (UEFI) Setup   

 

© Copyright 2016 HP Development Company, L.P. 4 Security Menu   17 
 

4 Security Menu 

    

 Main Security Advanced UEFI Drivers 

    HP Computer Setup 

Administrator Tools 

 Create/Change BIOS Administration Password 

 Create/Change POST Power-On Password 

 Fingerprint Reset on Reboot (Notebook with Fingerprint Reader Only) 

 Password Policies 

 

Security Configuration 

 TPM Embedded Security 

 BIOS SureStart 

 Smart Cover (Desktop Only) 

 Trusted Execution Technology (TXT) 

    TXT cannot be enabled unless VTx, VTd and TPM are enabled first 

Intel Software Guard Extensions (SGX) 

 

Utilities 

 Hard Drive Tools 

Absolute® Persistence Module Current State 

     Activation Status : 

     Absolute® Persistence Module Permanent Disable: 

 System Management Command (SMC) 

 Restore Security Settings to Factory Defaults 
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Table 9  Security Menu features 

Feature Type Description Default Notes 

Create BIOS Administrator 

Password 

Or Change BIOS 

Administrator Password 

Setting The Administrator password controls access to the setup 

menu (F10), 3rd Party Option ROM Management (F3), 

Update System ROM, WMI commands that change 

system settings and the BIOS Configuration Utility (BCU). 

When no Administrator password is set, anyone can 

change the system settings, add 3rd Party Option ROM or 

update the system ROM. When the power-on password is 

set, use the administrator password as an alternative to 

power-on the system. 

Recommendation: Set an administrator password when a 

power-on password is set. When a power-on password is 

forgotten, an administrator can reset the power-on 

password by using “Restore Security Settings to Factory 

Defaults” 

2014 Notebook: Security -> Setup BIOS Administrator 

Password 

2014 Desktop: Security -> Setup Password 

  

Create POST Power-On 

Password 

Or Change POST Power-On 

Password 

Setting Password required to power on the PC, independent of 

the OS password. When no password is set, anyone can 

power-on the PC. In addition to the administrator 

password, there is only one power-on password. 

Recommendation: Set an administrator password when a 

power-on password is set. When a power-on password is 

forgotten, an administrator can reset the power-on 

password by using “Restore Security Settings to Factory 

Defaults” 

2014 Notebook: Security -> User Management -> Create 

New BIOS User Account (multiple power-on passwords, 

including HP Client Security Users were possible.) 

2014 Desktop:  Security -> Power-On Password 

  

  Fingerprint Reset on 

Reboot 

Action When checked, resets the fingerprint on the next reboot. 

After reboot, this will be unchecked again. 

2014 Notebook: Security -> Fingerprint Reset on Reboot 

(If Present) 

Unchecked Notebook 

Only 

Password Policies Menu Allows the administrator to set password requirements 

for BIOS administration and power-on regarding the use 

of symbols, numbers, case and spaces 

2014 Desktop: New 

  

TPM Embedded Security Menu The Trusted Platform Module (TPM) is a dedicated 

microprocessor that provides security functions for 

secure communication and software and hardware 

integrity. The TPM hardware solution is more secure than 

a software only solution. 

2014 Desktop: New menu. TPM features referenced the 

Embedded Security Device, instead of TPM. See the TPM 

Embedded Security menu section of this document for 

details on individual TPM features. 
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Feature Type Description Default Notes 

BIOS Sure Start Menu Settings that control the behavior of HP Sure Start. HP 

Sure Start is a built-in hardware security system that 

protects your BIOS from accidental or malicious 

corruption by (1) detecting BIOS corruption and then (2) 

automatically restoring the BIOS to its last installed HP 

certified version. 

2014 Notebook: Security -> Sure Start 

2014 Desktop: New.  

  

Smart Cover Menu Controls settings for Cover Lock and Cover Sensor on a 

desktop. 

 Desktop 

Only with a 

Cover Lock 

installed 

 Trusted Execution 

Technology (TXT) 

Setting When checked, enables Trusted Execution Technology on 

select Intel-based systems 

NOTE: Enabling this feature disables OS management of 

Embedded Security Device, prevents a reset of the 

Embedded Security Device, and prevents the 

configuration of VTx, VTd, and Embedded Security Device 

2014 Notebook and Desktop: New 

Unchecked Intel Only 

Reboot 

Required 

Intel Software Guard 

Extensions (SGX) 

Setting Enables Intel Software Guard Extensions. The following 

settings are possible: 

 Enabled 

 Disabled 

NOTE: This feature is only available for systems with Intel 

vPro 

2014 Notebook and Desktop: New 

Disabled Intel Only 

Hard Drive Utilities Menu Utilities to protect private information on individual hard 

drives: Drive Lock and Secure Erase. 

2014 Notebook: Security -> Hard Drive Tools 

2014 Desktop: New 

  

Absolute® Persistence 

Module 

Heading A subscription service that provides PC theft recovery, 

tracking and data delete solutions 

2014 Notebook:  Security -> Anti-Theft Tools 

2014 Desktop: New 

  

Activation Status Display 

Only 

The subscription status can be inactive, active, or 

permanently disabled 

2014 Notebook:  Security -> Anti-Theft Tools 

2014 Desktop: New 

Inactive  

Absolute® Persistence 

Module Permanent Disable 

Display 

Only 

2014 Notebook: New 

2014 Desktop: New 

No  
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Feature Type Description Default Notes 

 System Management 

Command 

Setting When checked, allows authorized HP service personnel in 

possession of the PC to reset security settings in case of a 

customer service event. For customers that require more 

BIOS security, uncheck this to prevent this type of HP 

service command. 

NOTE: In the event BIOS password is lost and this option 

is disabled, HP authorized personnel will not be able to 

remove a lost password. 

2014 Desktop: New 

Checked Reboot 

Required 

Restore Security Settings 

to Default 

Action Apply factory defaults to all security settings. 

2014 Notebook: Security -> Restore Security Level 

Defaults 

2014 Desktop: New 

 Reboot 

Required 

4.1 Password Policies Menu 

This sub-menu allows the administrator to set text requirements controlling the use of symbols, numbers, case and spaces 
for the BIOS administration password and the power-on password. To set these requirements an administration password 
must be already set. 

Table 10  Password Policies Menu features 

Feature Type Description Default Notes 

Password Minimum Length Setting Allows the administrator to specify the minimum number of 

characters required for a password. 

 Minimum: 4 

 Maximum: 32 

2014 Desktop: New 

8  

 At least one symbol 

required in Administrator 

and User passwords 

Setting When checked, passwords require at least one symbol, such 

as $, %, ^, &, or # 

2014 Notebook: At least one symbol required 

2014 Desktop: New 

Unchecked  

 At least one number 

required  in Administrator 

and User passwords 

Setting When checked, passwords require at least one number 

2014 Notebook:  At least one number required 

2014 Desktop: New 

Unchecked  

 At least one upper-case 

character required  in 

Administrator and User 

passwords 

Setting When checked, passwords require at least one upper case 

character 

2014 Notebook: At least one upper case character required 

2014 Desktop: New 

Unchecked  

 At least one lower-case 

character required  in 

Administrator and User 

passwords 

Setting When checked, passwords require at least one lowercase 

character 

2014 Notebook: At least one lower case character required 

2014 Desktop: New 

Unchecked  

 Are spaces allowed in 

password? 

Setting When checked, passwords can have one or more spaces 

2014 Desktop: New 

Unchecked  
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Feature Type Description Default Notes 

 Prompt for Administrator 

password on F9 (Boot Menu) 

Setting When checked, the administrator password is required to 

enter the boot menu 

Checked  

 Prompt for Administrator 

password on F11 (System 

Recovery) 

Setting When checked, the administrator password is required to 

enter system recovery 

Checked  

 Prompt for Administrator 

password on F12 (Network 

Boot) 

Setting When checked, the administrator password is required to 

enter the network boot 

Checked  

Clear Password Jumper Setting On Desktops, a jumper is available that when removed, will 

clear the administrator and power on passwords. Set this to 

ignore, to prevent someone from clearing your passwords 

with the jumper. The following settings are possible: 

 Honor 

 Ignore 

2014 Desktop: Security -> Password Options -> Stringent 

Password 

Honor Desktop 

Only 
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4.2 Trusted Platform Module (TPM) Embedded Security Menu 

This sub-menu for the Trusted Platform Module (TPM.) is a dedicated microprocessor that provides security functions for 
secure communication and software and hardware integrity. The built in TPM hardware solution is more secure than a 
software only solution. 

Table 11  TPM Embedded Security Menu features 

Feature Type Description Default Notes 

TPM 

Activation 

Policy 

Setting This setting allows an administrator to choose between 

convenience and extra security. The extra security is to ensure 

that the user of the system will at least see that the TPM device 

upgraded its firmware (F1 to Boot), or at most the user has the 

ability to reject the upgrade of the TPM device (Allow user to 

reject.)  These user prompts limit the impact of remote attacks 

on the system by requiring a user to be physically present for the 

upgrade. When security of the system is of less concern, the 

third option (No prompts) removes any requirement for a user to 

acknowledge the upgrade. This last option is the most 

convenient for remotely upgrading many systems at once. 

The following settings are possible: 

 F1 to Boot 

 Allow user to reject 

 No prompts 

Allow 

user to 

reject 

HP recommends an 

option that 

requires the 

physical presence 

of the user 

TPM 

Specification 

Version 

Display 

Only 

The Trusted Computing Group (TCG) is an industry group that 

defines specifications for a TPM. As of this writing, possible TPM 

specification versions are 1.2 or 2.0. 

2014 Notebook and Desktop: New 

  

TPM Device Setting Makes the TPM available. The following settings are possible: 

 Available 

 Hidden 

2014 Desktop:  Security -> Device Security -> Embedded 

Security Device 

Available Reboot, Physical 

Presence Required 

 TPM State Setting When checked, enables the ability for the OS to take ownership 

of the TPM 

2014 Notebook: Security -> TPM Embedded Security -> 

Embedded Security Device State 

2014 Desktop:  Security -> System Security -> Embedded 

Security Device 

Checked Reboot, Physical 

Presence Required 

Clear TPM Action When selected, clears the TPM on the next boot. After clearing 

the TPM, this resets to No. The following settings are possible: 

 No 

 On next boot 

2014 Notebook:  Security -> TPM Embedded Security ->TPM 

Reset to Factory Defaults 

2014 Desktop:  Security -> System Security -> Embedded 

Security Device->Reset to Factory Settings 

No Reboot Required 
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4.3 BIOS Sure Start Menu 

Settings menu for Enhanced hardware based assurance that only HP approved Embedded Controller firmware will run on 
the HP Embedded Controller and that only HP approved BIOS will run on the host CPU. 

Table 12  BIOS Sure Start Menu features 

Feature Type Description Default Notes 

 Verify Boot Block 

on Every Boot 

Setting When not checked, HP Sure Start© will verify the integrity of HP 

fimrware in the non-volatile (flash) memory before resume from 

Sleep, Hibernate, or Off. 

When checked,  HP Sure Start© will verify the integrity of HP 

firmware in the non-volatile (flash) memory across operating 

system restart (warm reset) in addition to resume from Sleep, 

Hibernate Off. This setting provides higher security assurance, 

but could increase the time required to restart operating system 

2014 Desktop: New 

Unchecked Reboot 

Required 

BIOS Data Recovery 

Policy 

Setting The following settings are possible for HP Sure Start – Recovery 

Policy: 

 Automatic 

 Manual 

Automatic:  HP SureStart will automatically repair any HP 

firmware integrity issues in the non-volatile (flash) memory 

Manual: HP Sure Start will not repair any HP firmware integrity 

issues in the non-volatile (flash) memory until the Windows +Up 

Arrow+ Down Arrow keys are pressed. 

NOTE: Manual recovery is intended for use by the system 

administrator in the event forensic investigation is desired 

before HP Sure Start repairs the issue. It is not recommended 

for the typical user 2014 Desktop: New 

Automatic Reboot 

Required 

Network Controller 

Configuration 

Restore 

Action HP Sure Start – Network Controller Configuration Restore 

This action will restore the network controller parameters to the 

factory state saved in the HP Sure Start Private non-volatile 

(flash) memory. 

NOTE:  This process can take up to 30 seconds. You only need to 

restore this when the Network Controller Configuration 

mismatch warning is set 

2014 Notebook: Security -> Sure Start -> Restore Network 

Controller Configuration to factory defaults 

2014 Desktop: New 

 Reboot 

Required 

 Prompt on 

Network Controller 

Configuration 

Change 

Setting When enabled, HP Sure Start will monitor the network controller 

configuration and prompt the local user if any changes are 

detected compared to the factory configuration. The local user 

has the option to ignore the prompt, or restore the network 

controller to the factory configuration when prompted. 

2014 Notebook and Desktop: New 

Checked Intel Only 

Reboot 

Physical 

Presence 

Required 



May 2016 

857394-002 

HP PC Commercial BIOS (UEFI) Setup   

 

© Copyright 2016 HP Development Company, L.P. 4 Security Menu   24 
 

Feature Type Description Default Notes 

 Dynamic Runtime 

Scanning of Boot 

Block 

Setting When checked, allows HP Sure Start © will verify the integrity of 

the HP firmware  in the non-volatile (flash) memory every 15 

minutes while the system in the On state with the user 

operating system active 

2014 Desktop: New 

Checked  

4.4 Smart Cover Menu (Desktop Only) 

This sub-menu controls settings for Cover Lock and Cover Sensor. 

Table 13  Smart Cover Menu features 

Feature Type Description Default Notes 

Cover 

Lock 

Setting The Smart Cover Lock is a software-controllable cover lock. This lock prevents 

unauthorized access to the internal components. The following settings are 

possible: 

 Lock 

 Unlock 

Unlock Desktop 

Only with 

Cover Lock 

Reboot 

Required 

Cover 

Removal 

Sensor 

Setting The Cover Removal Sensor has the following settings: 

 Disabled 

 Notify the User: (Used by individuals managing their desktop) 

 Administrator Password: (Used to alert desktop administrators of a cover 

removal, by blocking use of the desktop without an administrator 

password. This setting is only visible when an administrator password set) 

Disabled Desktop 

Only with 

Cover 

Sensor 

Reboot 

Required 

4.5 Hard Drive Utilities Menu 

This sub-menu provides features that protect the data on individual hard drives, such as: recovering the master boot record, 
preventing unauthorized access and erasing data. 
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Table 14  Hard Drive Utilities Menu features 

Feature Type Description Default Notes 

 Save/Restore MBR 

of the system hard 

drive 

Setting When checked, saves a baseline MBR that can be restored if a 

change is detected 

NOTE: Not applicable for UEFI boot modes 

2014 Notebook: Security -> Hard Drive Tools -> Save/Restore 

MBR of the system hard drive 

2014 Desktop: Security -> Master Boot Record Security 

Unchecked Reboot 

Required 

DriveLock 

          Select a Drive… 

Menu DriveLock prevents unauthorized access to the contents of a 

selected hard drive. Enter a password to access the drive and 

the drive is accessible only when attached to a PC 

NOTE: DriveLock states cannot change after a warm reboot. 

Power off the system then boot directly to the setup menu, 

then to this menu 

2014 Notebook: Security -> Hard Drive Tools -> DriveLock 

2014 Desktop: Security -> DriveLock Security 

  

Secure Erase 

          Select a Drive… 

Action Uses hardware based methods to erase safely all data and 

personal information from a selected Hard Drive. 

2014 Notebook: Security -> Hard Drive Tools -> Secure Erase 

2014 Desktop: New 

 Reboot 

Required 

4.6 DriveLock Menu 

DriveLock prevents unauthorized access to the contents of a selected hard drive. Enter a password to access the drive and 
the drive is accessible only when attached to a PC. 

NOTE: DriveLock states cannot change after a warm reboot. Power off the system then boot directly to the setup menu, 

then to this menu. 

Table 15  DriveLock Menu features 

Feature Type Description Default Notes 

Set DriveLock 

Master 

Password 

Setting Password to disable or access a hard drive with DriveLock protection. 

2014 Notebook: Security -> Hard Drive Tools -> DriveLock -> Set 

DriveLock Password 

2014 Desktop: Security -> DriveLock Security -> Configure Master 

Password 

 Reboot 

Required 

Enable DriveLock Setting Enables DriveLock protection and creates a user password distinct from 

the master password that allows access to the hard drive 

2014 Notebook:  Security -> Hard Drive Tools -> DriveLock -> DriveLock 

password on restart 

2014 Desktop: Security -> DriveLock Security -> Enable/Disable 

DriveLock 

Disabled Reboot 

Required 



May 2016 

857394-002 

HP PC Commercial BIOS (UEFI) Setup   

 

© Copyright 2016 HP Development Company, L.P. 4 Security Menu   26 
 

Feature Type Description Default Notes 

Automatic 

DriveLock 

Setting Requires the BIOS to authenticate the user before the drive is unlocked. 

The user can be a BIOS user (managed by F10 Setup) or a HP Client 

Security Software Suite user (managed by the OS) 

Following authentication, the BIOS automatically supplies the DriveLock 

password. 

A BIOS administrator password is required for this feature and is set as 

the DriveLock master password. 

2014 Notebook: Security -> Hard Drive Tools -> Automatic DriveLock 

2014 Desktop: New 

Disabled Reboot 

Required 
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5 Advanced Menu 

    

 Main Security Advanced UEFI Drivers 

    HP Computer Setup 

 Display Language 

 Scheduled Power-On 

 Boot Options 

 Secure Boot Configuration 

 System Options 

 Built-In Device Options 

 Port Options 

 Option ROM Launch Policy 

 Power Management Options 

 Remote Management Options  (Intel Only) 

 Electronic Labels (Notebook Only) 
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5.1 Advanced Menu 

For detailed information on the features in the advanced menu, see the following table: 

Table 16  Advanced Menu features 

Feature Type Description Default Notes 

Display 

Language 

Menu Select the display language and the keyboard language. Choose between 

14 languages. You can display the menu in English, French, German, 

Spanish, Italian, Dutch, Danish, Japanese, Norwegian, Portuguese, Swedish, 

Finnish, Chinese Traditional, or Chinese Simplified. 

NOTE: Affects the BIOS menus, not the OS nor the WMI commands 

2014 Notebook and Desktop: New menu. Selecting a language is not new, 

but selecting the keyboard language is new. 

2014 Desktop: New languages: Simplified Chinese and Traditional Chinese 

  

Scheduled 

Power On 

Menu Choose days of the week and a single time of day for the system to power-

on. This feature wakes the system up from a powered off state. 

2014 Notebook and Desktop: Advanced -> BIOS Power-On 

  

Boot Options Menu Settings that control the behavior of the system during boot up 

2014 Notebook: Moved Secure Boot settings to a separate menu. See 

below. 

2014 Desktop: New menu. Groups features from the following menus: 

Storage -> Boot Order, Security -> Network Boot, and Advanced -> Power-

On Options. 

  

Secure Boot 

Configurations 

Menu Starting with Windows 8, Secure Boot is a UEFI feature that helps resist 

attacks and infection from malware. From the factory, your system came 

with a list of keys that identify trusted hardware, firmware, and operating 

system loader code. Your system also has a list of keys to identify known 

malware. 

2014 Notebook: New 

2014 Desktop: Security -> Secure Boot Configuration 

  

System 

Options 

Menu Settings that control the CPU, PCI, PCIe, the power button and function 

keys. 

2014 Notebook: New 

2014 Desktop:  New Menu. Groups features from the following menus: 

Security -> Slot Security, Advanced -> Bus Options, and Advanced -> Device 

Options 

  

Built in Device 

Options 

Menu Settings of devices built-in to the PC 

2014 Desktop:  New menu. Groups selected features from the following 

menus: Advanced -> Power-On Options, Advanced -> Device Options, 

Advanced -> VGA configuration, Power -> Thermal and Security -> Network 

boot 

  

Port Options Menu Settings that enable or disable ports and interrupts on the system. 

2014 Desktop:  New menu. Groups selected features from the following 

menus: Advanced -> Onboard Devices, Advanced -> Device Options, 

Security -> Device Security, Security -> USB Security 

  

Option ROM 

Launch Policy 

Menu Configure the Device Option ROMs that load at boot time. 

2014 Notebook: new 
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Feature Type Description Default Notes 

Power 

Management 

Options 

Menu Settings that control power saving features and the behavior of the system 

in low power modes 

2014 Notebook: New 

2014 Desktop: New Menu. Groups features from the following menus 

Power -> OS Power Management, Power -> Hardware Power Management 

  

Remote 

Management 

Options 

Menu Settings that controls Intel Active Management technology that provides 

out-of-band remote management of the system. 

2014 Notebook: Advanced -> AMT Options 

2014 Desktop:  Advanced -> Management Operations 

 Intel Only 

Electronic 

Labels 

Display 

Only 

Mandatory certification marks, for example: the Federal Communication 

Commission (FCC) Declaration of Conformity (Doc) and the CE marking for 

Europe 

2014 Notebook: New 

 Notebook 

Only 

5.2 Display Language Menu 

This sub-menu allows for selection of the display language and the keyboard language. For each setting, choose from the 
following languages: 

 English 

 Deutsch 

 Español 

 Italiano 

 Français 

 日本語 

 Português 

 Danske 

 Svenska 

 Nederlands 

 Norsk 

 Suomi 

 简体中文 

 繁體中文 

NOTE: Affects the BIOS menus, not the OS nor the WMI commands. 

Table 17  Display Language Menu features 

Feature Type Description Default Notes 

Select Language Setting Language used by BIOS setup menus 

2014 Notebook: Advanced -> Language 

2014 Desktop:  F8 key 

English  

Select Keyboard Layout Setting Language of the keyboard layout used by BIOS setup menus 

2014 Notebook and Desktop: New 

English  



May 2016 

857394-002 

HP PC Commercial BIOS (UEFI) Setup   

 

© Copyright 2016 HP Development Company, L.P. 5 Advanced Menu   30 
 

5.3 Scheduled Power-On Menu 

This sub-menu controls the days of the week and a single time of day for the system to power-on. This feature wakes the 
system up from a powered off state. 

Table 18  Scheduled Power On Menu features 

Feature Type Description Default Notes 

 Sunday 

 Monday 

 Tuesday 

 Wednesday 

 Thursday 

 Friday 

 Saturday 

Setting Days of the week selection 

2014 Notebook and Desktop: Advanced -> BIOS Power-On 

 Reboot Required 

Hour Setting Time selection 

2014 Notebook and Desktop: Advanced -> BIOS Power-On -> Hour 

0 Reboot Required 

Minute Setting Hour: 0 – 23, Minute: 0 – 59 

2014 Notebook and Desktop: Advanced -> BIOS Power-On -> Minute 

0 Reboot Required 

5.4 Boot Options Menu 

Sub-menu controls the behavior of the system during boot up 

Table 19  Boot Options Menu features 

Feature Type Description Default Notes 

Startup Menu 

Delay 

Setting Select the number of seconds (0 – 60) to pause the boot before 

starting the OS. Increasing the delay, gives more time to press a 

key that opens one of the BIOS menus. Set this to 0 if you have 

excellent twitch reflexes honed from a lifetime of video games. 

Increase the delay, if you need a little more time to respond during 

the boot up. 

2014 Desktop: Advanced ->Power-On Options -> POST Delay 

0  

 Fast Boot Setting When checked, reduces boot up time by bypassing boot to USB, 

CD-ROM, and PXE. 

NOTE: When a power on password, other security features, or 

default boot order have been modified, Fast Boot is ignored 

2014 Desktop: Security -> Secure Boot Configuration -> Fast Boot 

Unchecked  

 CD-ROM 

Boot 

Setting When checked, allows system to boot from CD-ROM 

2014 Desktop: New. Storage -> Storage Options -> Removable 

Media Boot.  

Checked  

 USB Storage 

Boot 

Setting When checked, allows system to boot from USB 

2014 Notebook: Advanced -> Boot Options -> USB device boot 

2014 Desktop: New. Storage -> Storage Options -> Removable 

Media Boot.  

Checked  
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Feature Type Description Default Notes 

 Network PXE 

Boot 

Setting When checked, allows system to boot from a network card 

2014 Notebook: Advanced -> Boot Options -> PXE Internal NIC 

boot 

2014 Desktop: Security -> Network Boot 

Checked  

After Power 

Loss 

Setting Specifies the desktop state after power loss. The following settings 

are possible: 

 Power Off 

 Power On 

 Previous State 

2014 Desktop: Advanced -> Power-On Options -> After Power Loss 

Power Off Desktop Only 

 Power On 

When AC 

Detected 

Setting When checked, the notebook will power on when it is off, AC power 

has not been available and then becomes available. 

2014 Notebook: Advanced -> Device Configurations -> Power on 

Unit when AC is detected 

Unchecked Notebook Only 

 Power On 

When Lid is 

Open 

Setting When checked, the system will power on when the lid opens 

2014 Notebook: Advanced -> Built-In Device Options -> Power on 

unit when lid is opened 

Unchecked Notebook Only 

 Prompt on 

Battery Errors 

Setting When checked, the system will pause during system boot to warn 

about battery errors 

2014 Notebook: New 

Checked Notebook Only 

 Thunderbolt 

Boot 

Setting When checked, allows the system to boot from a device connected 

to a Thunderbolt interface. 

2014 Notebook and Desktop: New 

Unchecked Systems with 

Thunderbolt 

Only 

 Audio Alerts 

during boot 

Setting When checked, errors trigger audible beeps during POST 

2014 Desktop: New 

Checked  

 Prompt on 

Memory Size 

Change 

Setting When checked, notify the user during the boot process when a 

memory size change has been detected 

2014 Notebook: New 

2014 Desktop: New. The most similar feature is Advanced -> 

Power-On Options -> Bypass F1 Prompt on Configuration Changes. 

This disabled all prompts including prompts for memory size 

changes. 

Checked  

 Prompt on 

Fixed Storage 

Change 

Setting When checked, notify the user during the boot process when a 

fixed storage change has been detected 

2014 Notebook: New 

2014 Desktop: New. The most similar feature is Advanced -> 

Power-On Options -> Bypass F1 Prompt on Configuration Changes. 

This disabled all prompts including prompts for storage changes. 

Unchecked  

 Prompt on 

Memory Size 

Change 

Setting When checked, notify the user during the boot process when a 

memory size change has been detected 

2014 Notebook: New 

2014 Desktop: New. The most similar feature is Advanced -> 

Power-On Options -> Bypass F1 Prompt on Configuration Changes. 

This disabled all prompts including prompts for memory size 

changes. 

Checked  
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Feature Type Description Default Notes 

 Legacy Boot 

Order 

Setting When checked, allows the system to boot from non-UEFI devices. 

2014 Notebook: New 

2014 Desktop: Storage -> Boot Order -> Legacy Boot Sources -> 

F5 key 

Requires “Legacy Boot Enable and Secure Boot Disable.”  See 

“Secure Boot Configuration” -> “Configure Legacy Support and 

Secure Boot” 

When Legacy Boot Disabled, the check boxes for UEFI Boot Order 

and Legacy Boot Order will grayed out and not functional, because 

only UEFI devices can boot in this mode. 

When enabling the UEFI Boot Order, the system attempts to boot 

from all UEFI devices before any non-UEFI devices. 

Arrange the boot order from the non-UEFI devices found. By 

default, the system will arrange the boot order by device type 

using the following precedence: 

1. USB 

2. SATA DVD (Desktop Only) 

3. SATA Hard Drives 

4. M.2 devices 

Network Boot 

Checked  
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5.5 Secure Boot Configurations Menu 

Submenu to configure Secure Boot. Starting with Windows 8, Secure Boot is a UEFI feature that helps resist attacks and 
infection from malware. From the factory, your system came with a list of keys that identify trusted hardware, firmware, 
and an operating system loader code. It also created a list of keys to identify known malware. 

Table 20  Secure Boot Configurations Menu features 

Feature Type Description Default Notes 

Configure Legacy 

Support and Secure 

Boot 

Setting Legacy Support is the ability to boot from a non-UEFI device. 

Only UEFI devices can support Secure Boot. The following 

settings are possible: 

 Legacy Support Enable and Secure Boot Disable 

 Legacy Support Disable and Secure Boot Enable 

 Legacy Support Disable and Secure Boot Disable 

2014 Notebook: Advanced -> Boot Options -> Boot Mode 

 Legacy 

 UEFI Hybrid (With CSM) 

 UEFI Native (Without CSM) 

2014 Desktop: Security -> Secure Boot Configuration 

 -> Legacy support 

 -> Secure Boot 

Legacy Support 

Enable and 

Secure Boot 

Disable 

 

 Clear Secure Boot 

Keys 

One 

Time 

Action 

When checked, clears the Secure Boot keys one time on next 

save and exit. This setting will be unchecked again, when you 

return from exit. This action is not available with Legacy 

Support enabled or when no keys are present, possibly from a 

previous clear command. 

2014 Notebook: Advanced -> Boot Options -> Clear Secure 

Boot Keys 

2014 Desktop:  Security -> Secure Boot Configuration 

-> Clear Secure Boot Keys 

-> Key Ownership: HP Keys 

Unchecked  

 Reset Secure Boot 

Keys to Factory 

Defaults 

One 

Time 

Action 

When checked, restores secure boot keys to factory defaults 

one time on next save and exit. This setting will be unchecked 

again, when you return from exit. 

2014 Notebook: Advanced -> Boot Options -> User Mode -> HP 

Factory Keys 

Unchecked  

 Enable MS UEFI CA 

key 

Setting When checked, the Microsoft (MS) UEFI Certificate Authority 

(CA) key is trusted by Secure Boot 

Note: Uncheck this to support Windows 10 Device Guard 

feature 

2014 Notebook and Desktop: New 

Checked  
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5.6 System Options Menu 

Table 21  System Options Menu features 

Feature Type Description Default Notes 

 Configure 

Storage 

Controller for 

RAID 

Setting When checked, configures SATA Controller for RAID mode 

2014 Desktop:  Storage -> Storage Options -> SATA 

Emulation 

Unchecked Desktop Only 

PCIE GEN 

Support Speed 

Setting Allows you to restrict the maximum speed of the PCI 

Express devices to previous generations. The following 

settings are possible: 

 Auto 

 Gen 1 

 Gen 2 

 Gen 3 

2014 Notebook and Desktop: New 

Auto  

 POST Prompt 

for RAID 

Configuration 

Setting When checked, prompts for RAID Configuration utility 

2014 Desktop: Storage -> Storage Options 

-> Ctrl-I Suppression  

Checked Desktop Only 

 Turbo Boost Setting When checked, enables Intel® Turbo Boost Technology to 

improve performance when operation conditions allow 

2014 Notebook: New 

2024 Desktop:  Advanced -> Device Options -> Turbo 

Mode 

Checked Intel Only 

 Hyper-

threading (Intel® 

HT) 

Setting When checked, enables Hyper-threading capability on Intel 

processors 

Intel HT Technology (HT) is designed to improve 

performance of multi-threaded software products and 

requires a computer system with a processor supporting 

HT and an HT-enabled chipset, BIOS and OS. Please 

contact your software provider to determine compatibility. 

Not all customers or software applications will benefit 

from the use of HT. 

See http://www.intel.com/info/hyperthreading for more 

information. 

2014 Notebook: Advanced -> Device Configurations -> 

Intel® HT Technology 

2014 Desktop: Advanced -> Device Options ->  Hyper-

threading (Intel® HT) 

Checked Intel CPU with 

Hyper-threading 

Only 

(Core i7) 

 Multi-

processor 

Setting When checked, enables BIOS to report multiple processor 

cores to the OS 

2014 Notebook: Advanced -> Device Configurations -> 

Multi Core CPU 

2014 Desktop: Advanced -> Device Options -> Multi-

Processor 

Checked  

http://www.intel.com/info/hyperthreading
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Feature Type Description Default Notes 

 Virtualization 

Technology (VTx) 

Setting When checked, enables VT on Intel-based systems 

2014 Notebook: Advanced -> Device Configurations ->  

Virtualization Technology (VTx) 

2014 Desktop: Security -> System Security ->  

Virtualization Technology (VTx) 

Unchecked Intel Only 

 Virtualization 

Technology for 

Directed I/O 

(VTd) 

Setting When checked, grants virtual machines direct access to 

peripheral devices on select Intel-based systems 

2014 Notebook: Advanced -> Device Configurations ->  

Virtualization Technology for Directed I/O (VTd) 

2014 Desktop: Security -> System Security ->  

Virtualization Technology for Directed I/O (VTd) 

Unchecked Intel Only 

 SVM CPU 

Virtualization 

Setting When checked, enables Virtualization on AMD-based 

systems 

2014 Notebook: New 

2014 Desktop: Security -> System Security -> SVM CPU 

Virtualization 

Unchecked AMD Only 

 Swap Fn and 

Ctrl (Keys) 

Setting When checked, switches functionality between Fn and Ctrl 

keys 

2014 Notebook: Advanced -> Device Configurations -> 

Fn+(F1-F12) Key switch 

Unchecked Notebook Only 

 Enable Turbo 

Boost on DC 

Setting When checked, allows Intel® Turbo Boost Technology to 

activate when a power adapter is not connected 

2014 Notebook: Advanced -> Device Configurations -> 

Enable Turbo Boost on DC 

Unchecked Intel Notebook 

Only 

 PCI Express 

x16 Slot 1 

Setting When checked, PCI Express x16 slot is available 

2014 Desktop: Security -> Slot Security 

Checked Desktop Only 

 PCI Express x1 

Slot 1 

Setting When checked, PCI Express x1 slot is available 

2014 Desktop: Security -> Slot Security  

Checked Desktop Only 

 PCI Express x1 

Slot 2 

Setting When checked, PCI Express x1 slot is available 

2014 Desktop: Security -> Slot Security 

Checked Desktop Only 

 PCI Express x4 

Slot 1 

Setting When checked, PCI Express x4 slot is available 

2014 Desktop: Security -> Slot Security 

Checked Desktop Only 

 Allow PCIe/PCI 

SERR# Interrupt 

Setting When checked, enables PCI device to generate SERR# 

(System Error), as defined by the PCI specification 

2014 Desktop: Advanced -> Bus Options -> PCI SERR# 

Generation 

Checked Desktop Only 
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Feature Type Description Default Notes 

Power Button 

Override 

Setting Sets the time required to hold the power button down for 

the desktop to turn off, overriding the power button 

behavior defined by the operating system. The following 

settings are possible: 

 Disable 

 4 sec 

 15 sec 

2014 Desktop: New 

4 sec Desktop Only 

5.7 Built-in Device Options Menu 

This menu provides settings built-in devices on the system. 

Table 22  Built-in Device Options Menu features 

Feature Type Description Default Notes 

 Embedded 

LAN Controller 

Setting When checked, enables integrated network interface 

controller (NIC) device 

2014 Desktop: Security -> Device Security -> Network 

Controller 

Checked  

Wake on LAN Setting Allows the system to wake via Local Area Network (LAN). 

The following settings are possible: 

 Disabled 

 Boot to Network 

 Boot to Hard Drive 

2014 Desktop:  New 

Boot to 

Network 

 

 Dust Filter Setting When checked, enables the dust filter reminder. This will 

prompt you after a period of days specified by the setting 

below. 

2014 Desktop: New 

Unchecked Desktop Only 

Dust Filter 

Reminder (Days) 

 Number of days for a reminder to replace the dust filter 

 15 

 30 

 60 

 90 

 120 

 180 

2014 Desktop: New 

60 Desktop Only 

 Integrated 

Video 

Setting When checked, enables the integrated video device. When 

not using the integrated video, disable the integrated 

video to save system memory. 

2014 Desktop: New 

Checked Desktop with 

add-in graphics 

card Only 
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Feature Type Description Default Notes 

VGA Boot Device  The firmware can only support one graphic device when 

booting up; so, when a graphics card is added, this feature 

selects the graphics system to use as the primary VGA 

device during boot-up 

 The integrated graphics 

 Add-in graphics card 

2014 Desktop: New 

Add-in graphics 

is set as primary 

Desktop with 

add-in graphics 

card Only 

Video Memory 

Size 

Setting System memory reserved for video memory. The 

following settings are possible: 

Intel: 

 32 MB 

 64 MB 

 128 MB 

 256 MB 

 512 MB 

AMD: 

 128 MB 

 256 MB 

 512 MB 

 Auto 

2014 Notebook: Advanced -> Device Configurations -> 

Video Memory Size 

2014 Desktop: New 

Intel: 32 MB 

AMD: Auto 

 

Graphics Setting Set the graphics adapter. The following settings are 

possible: 

 Hybrid Graphics 

 UMA Graphic 

2014 Notebook: New 

Hybrid Graphics Multiple Graphic 

Card Notebook  

Only 

 Audio Device Setting This setting provides a single point of control for the 

integrated microphone, the internal speakers, and the 

headphone out. 

When checked, the operating system visibility of each 

audio device below is controlled independently 

When unchecked, hides all audio devices from the 

operating systems. The individual audio device settings 

below gray out and are not accessible. 

2014 Desktop: Security -> Device Security -> System 

Audio 

Checked  

 Integrated 

Microphone 

Setting When checked, enables integrated microphone 

2014 Desktop: New. The most similar feature is Security -

> Device Security -> System Audio 

Checked Notebook Only 
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Feature Type Description Default Notes 

 Internal 

Speakers 

Setting When checked, enables the internal speaker 

2014 Notebook: New. The most similar feature is  

Advanced –> Built-In Options -> Speakers and 

Headphones 

2014 Desktop: New. The most similar feature is Security -

> Device Security -> System Audio 

Checked  

 Headphone 

Output 

Setting When checked, enables the headphone jack 

2014 Notebook: New. The most similar feature is  

Advanced –> Built-In Options -> Speakers and 

Headphones 

2014 Desktop: New. The most similar feature is Security -

> Device Security -> System Audio 

Checked Notebook Only 

 Embedded 

GPS device 

Setting When checked, enables integrated GPS device Checked Notebook Only 

 Intel® Smart 

Sound 

Setting When checked enables Intel® Smart Sound 

2014 Notebook: New 

Checked Intel 

Notebook Only 

 Lock Wireless 

Button 

Setting When checked, the WLAN device cannot be toggled on and 

off using the wireless button 

2014 Notebook: Advanced -> Built-In Options -> Wireless 

Button State 

Unchecked Notebook Only 

Increase Idle Fan 

Speed (%) 

Setting Controls the minimum fan speed during periods that the 

fan would normally be off under the control of the 

desktop thermal sensor. Choose a percentage of the 

maximum fan speed: 0 –100%. 

2014 Desktop: Power -> Thermal -> Fan Idle Mode 

0 Desktop Only 

 Wireless 

Network Device 

(WLAN) 

Setting When checked, enables integrated 802.11 device 

2014 Notebook: Advanced -> Built-In Device Options -> 

Embedded WLAN Device 

Checked Notebook Only 

 Mobile 

Network Device 

(WWAN) 

Setting When checked, enables integrated WWAN device 

2014 Notebook: Advanced -> Built-In Device Options -> 

Embedded WWAN Device 

Checked Notebook Only 

 Bluetooth Setting When checked, enables integrated Bluetooth device 

2014 Notebook: Advanced -> Built-In Device Options -> 

Bluetooth Device 

Checked Notebook Only 

 LAN/WLAN 

Auto Switching 

Setting When checked, enables automatic switching between 

embedded WLAN device and embedded LAN controller; 

disables WLAN when LAN connection is detected 

2014 Notebook: Advanced -> Built-In Device Options -> 

LAN/WLAN Switching 

Unchecked Notebook Only 

 Wake on LAN 

in Battery Mode 

Setting When checked and powered by battery, enables the 

notebook to wake via LAN 

Unchecked Notebook Only 
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Feature Type Description Default Notes 

 Fan Always on 

while on AC 

Power 

Setting When checked, leaves the fan on while running on AC 

power 

2014 Notebook: Advanced -> Device Configuration -> Fan 

Always on while on AC Power 

Unchecked Notebook Only 

 Boost 

Converter 

Setting When checked, the notebook draws power from the 

battery when the system is on AC in order to give the CPU 

a momentary performance gain by increasing the overall 

power available to the CPU 

Checked Notebook Only 

Backlit Keyboard 

Timeout 

Setting Specifies the timeout period for the keyboard’s backlit 

LEDs. The following settings are possible: 

 5 secs 

 15 secs 

 30 secs 

 1 min 

 5 min 

 Never 

2014 Notebook: New 

15 seconds Notebook Only 

 Fingerprint 

Device 

Setting When checked, enables fingerprint reader Checked Notebook Only 

 Integrated 

Camera 

Setting When checked, enables the integrated camera Checked Notebook Only 

5.8 Port Options Menu 

The following table describes varous setting options for Ports. 

Table 23  Port Options Menu features 

Feature Type Description Default Notes 

 Thunderbolt 

Port 

Setting Thunderbolt technology is a new I/O technology that 

supports high-resolution displays and high-performance 

data devices through a single, compact port 

When checked, enables integrated Thunderbolt port 

2014 Notebook: New 

Checked Notebook Only 

Thunderbolt 

Security Level 

Setting The following settings are possible: 

 PCIe and DisplayPort – No Security 

 PCIe and DisplayPort – User Authorization 

 PCIe and DisplayPort – Secure Connect 

 DisplayPort only 

2014 Notebook: New 

PCIe and 

DisplayPort – 

No Security 

 

Notebook Only 

 USB Ports Setting When checked, enables integrated USB ports Checked Notebook Only 
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Feature Type Description Default Notes 

 USB Charging 

Port 

Setting When checked, enables the USB charging port to charge 

devices during hibernation or shutdown. This setting is 

equivalent to the “USB Charging Port Function” setting on 

a desktop. 

2014 Notebook: New 

Unchecked Notebook Only 

 Media Card 

Reader 

Setting When checked, enables integrated media card reader. This 

setting is equivalent to the “ Media Card Reader/SD_RDR 

USB ” setting on a desktop 

2014 Notebook: Advanced -> Port Options -> Flash media 

reader 

Checked Notebook Only 

 Smart Card Setting When checked, enables integrated Smart Card slot Checked Notebook Only 

 Smart Card 

Power Savings 

Setting When checked, enables the power-saving feature of the 

Smart Card reader, thus not maintaining a session when 

the card is removed 

2014 Notebook:  Advanced -> Device Configuration -> 

Smart Card Reader Power Setting 

Checked Notebook Only 

 Serial Port A 

(B) 

Setting When checked, enables serial port A 

2014 Desktop: Security -> Device Security -> Serial Port A 

(B) 

Checked Desktop Only 

I/O Address A (B) Setting The following settings are possible: 

 Auto 

 3F8 

 2F8 

 3E8 

 2E8 

2014 Desktop: Advanced -> On Board Devices -> Serial 

Port A (B) 

Auto Desktop Only 

Interrupt A (B) Setting The following settings are possible: 

 Auto 

 IRQ 3 

 IRQ 4 

 IRQ 5 

 IRQ 10 

2014 Desktop: Advanced -> On Board Devices -> Serial 

Port A (B) 

Auto Desktop Only 

SATA0 (1,2,3,4,5) Setting When checked, makes the specified SATA port visible to 

the OS 

2014 Desktop: Security -> Device Security -> SATA0 

(1,2,3,4,5) 

Checked Desktop Only 

 Front USB 

Ports 

Setting When checked, enables front USB ports 

2014 Desktop: Security -> USB Security -> Front USB 

Ports 

Checked Desktop Only 

 Rear USB 

Ports 

Setting When checked, enables rear USB ports 

2014 Desktop: Security -> USB Security -> Rear USB Ports 

Checked Desktop Only 
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Feature Type Description Default Notes 

 USB Charging 

Port Function 

Setting When checked, enables the USB charging port to charge 

devices during hibernation or shutdown. This setting is 

equivalent to the “USB Charging Port” setting on a 

notebook. 

2014 Desktop: Advanced -> Device Options -> USB 

Charging Port 

Checked Desktop Only 

 Media Card 

Reader/SD_RDR 

USB 

Setting When checked, enables integrated media card reader. This 

setting is equivalent to the “Media Card Reader” setting on 

a notebook 

2014 Desktop: New 

Checked Desktop Only 

Restrict USB 

Devices 

Setting The following settings are possible: 

 Allow all USB Devices 

 Allow only keyboard and mouse 

 Allow all but storage devices and hubs 

2014 Desktop: New 

Allow all USB 

Devices 

Desktop Only 

5.9 Option ROM Launch Policy Menu 

This menu under the advanced menu configures the kind of device option ROM that can load at boot time. 

Table 24  Option ROM Launch Policy Menu features 

Feature Type Description Default Notes 

Configure Option 

ROM Launch 

Policy 

Setting The following settings are possible: 

 All Legacy 

 All UEFI 

 All UEFI Except Video 

2014 Notebook: New 

2014 Desktop: New. This feature consolidates separate 

settings under Advanced -> Option ROM Launch Policy. 

There are separate settings for PXE Option ROM, Storage 

Option ROM, and Video Option ROM. Possible settings are 

the following: 

 Legacy Only+ 

 UEFI Only 

 Do Not Launch 

All Legacy  
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5.10 Power Management Options Menu 

The following table describes varous setting options for Power Management Options. 

Table 25  Power Management Options Menu features 

Feature Type Description Default Notes 

 Runtime 

Power 

Management 

Setting When checked, enables Runtime Power Management 

2014 Desktop: Power -> OS Power Management -> 

Runtime Power Management 

Checked Desktop Only 

 Extended Idle 

Power States 

Setting When checked, increases the OS Idle Power Savings 

2014 Desktop: Power -> OS Power Management -> Idle 

Power Savings 

Checked Desktop Only 

 S5 Maximum 

Power Savings 

Setting When checked, minimizes power consumption of system 

while in S5 (off) state. 

NOTE: Windows 8 with Fast Startup enabled powers off to 

the S4 (suspend to disk) state. 

2014 Desktop: Power -> Hardware Power Management -> 

S5 Maximum Power Savings 

Unchecked Desktop Only 

 SATA Power 

Management 

Setting When checked, enables SATA bus to enter low power 

states when idle 

2014 Desktop: Power -> Hardware Power Management -> 

SATA Power Management 

Checked Desktop Only 

 Deep Sleep Setting When checked, reduces power consumption while in 

S3/S4/S5 to extend battery life. 

Note: Enabling deep sleep disables some wake events 

such as wake on USB without AC power. 

2014 Notebook: New 

Checked Notebook Only 

 PCI Express 

Power 

Management 

Setting When checked, enables PCI Express bus to enter low 

power states when idle 

2014 Desktop: Power -> Hardware Power Management -> 

PCI Express Power Management 

Checked  

 Power On 

from Keyboard 

Ports 

Setting When checked, allows the desktop to turn on by pressing 

a key on the keyboard 

2014 Desktop: New 

Checked Desktop Only 

 Unique Sleep 

State Blink Rates 

Setting When checked, when the desktop is in the S4 power state, 

the power LED periodically blinks 4 times with a pause. 

Unchecked, the desktop will not blink at all in S4 (the same 

as S5, power off) 

This also affects S3 blink behavior. When checked, the 

desktop power LED periodically blinks 3 times with a 

pause, unchecked it blinks once per period. Study these 

blink rates carefully at bedtime and you will enter a sleep 

state. 

2014 Desktop: Power -> OS Power Management -> 

Unique Sleep State Blink Rates 

Unchecked Desktop Only 
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Feature Type Description Default Notes 

 Wake when 

Lid is Opened 

Setting When checked, opening the lid wakes the notebook from 

sleep mode 

2014 Notebook: Advanced -> Built-In Device Options -> 

Wake unit from sleep when lid is opened 

Unchecked Notebook Only 

 Wake on USB Setting When checked, allows the system to resume from sleep 

when a USB input device is triggered (such as mouse 

movement or keyboard key-press) 

2014 Notebook: New 

Checked Notebook Only 

 Power Control Setting When checked, enables the notebook to support power 

management applications such as IPM+ that help 

enterprises reduce power costs by intelligently managing 

the battery usage of the notebook. 

2014 Notebook: New 

Unchecked Notebook Only 

5.11 Remote Management Options Menu (Intel Only) 

The following table describes varous setting options for Remote Management Options. 

Table 26  Remote Management Options Menu features 

Feature Type Description Default Notes 

 Active 

Management 

Technology 

(AMT) 

Setting When checked, enables AMT and allows individual AMT 

settings on this menu to be configured 

2014 Notebook: New 

2014 Desktop: Advanced -> Management Operations -> 

AMT 

Checked Intel Only 

 USB Key 

Provisioning 

Support 

Setting When checked, enables AMT provisioning using USB disk–

on- key 

2014 Notebook: Advanced -> AMT Options -> USB Key 

Provisioning Support 

2014 Desktop: New 

Unchecked Intel Only 

 USB 

Redirection 

Support 

Setting When checked, enables support for storage redirection 

through USB 

NOTE: Intel® AMT must be correctly provisioned 

2014 Notebook and Desktop: New 

Checked Intel Only 

Unconfigure AMT 

on Next Boot 

One 

time 

action 

When applied, reset AMT configuration options on next 

boot. The following actions are possible: 

 Do Not Apply 

 Apply 

2014 Notebook: Advanced -> AMT Options -> 

Unconfigure AMT on next boot 

2014 Desktop: Advanced -> Management Operations -> 

Unconfigure AMT/ME 

Do Not Apply Intel Only 
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Feature Type Description Default Notes 

SOL Terminal 

Emulation Mode 

Setting Specifies the Serial Over Lan (SOL) terminal emulation 

mode. The following settings are possible: 

 ANSI 

 VT100 

2014 Notebook: Advanced -> AMT Options -> SOL 

Terminal Emulation Mode 

2014 Desktop: New 

ANSI Intel Only 

 Show 

Unconfigure ME 

Confirmation 

Prompt 

Setting When checked, requires user confirmation when 

unconfiguring Intel® Management Engine 

2014 Notebook: New 

2014 Desktop:  Advanced -> Management Operations -> 

Hide Unconfigure ME Confirmation Prompt 

Checked Intel Only 

 Verbose Boot 

Messages 

Setting When checked, report additional information when a boot 

message is displayed 

NOTE: Unavailable when AMT is disabled 

2014 Notebook and Desktop: New 

Unchecked Intel Only 

 Watchdog 

Timer 

Setting When checked, enables Watchdog Timers 

2014 Notebook: New 

2014 Desktop:  Advanced -> Management Operations -> 

Watchdog Timer 

Checked Intel Only 

    OS Watchdog 

Timer (min.) 

Setting Sets OS Watchdog Timer (minutes). Possible values are 

from 5 to 25 

2014 Notebook: New 

2014 Desktop:  Advanced -> Management Operations -> 

OS Watchdog Timer 

5 Intel Only 

    BIOS Watchdog 

Timer (min.) 

Setting Sets BIOS Watchdog Timer (minutes). Possible values are 

from 5 to 25 

2014 Notebook: New 

2014 Desktop:  Advanced -> Management Operations -> 

BIOS Watchdog Timer 

5 Intel Only 

CIRA Timeout 

(min.) 

Setting Client Initiated Remote Access timeout. Possible values 

are from 1 to 4 minutes or never. 

2014 Notebook: Advanced -> AMT Options -> Initiate Intel 

CIRA 

2014 Desktop: New 

1 Intel Only 
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6 UEFI Drivers 

    

 Main Security Advanced UEFI Drivers 

    HP Computer Setup 

This will restart the system into the 3rd Part Option ROM Management application. You can get to this application directly by 
pressing F3 during startup 

3rd Party Option ROM Management 
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7 Computer Notifications 

7.1 Introduction 

The power LED on the Intel® NUC will blink in a pattern if an error occurs during POST. Intel NUC products that include a front 
panel audio jack will also produce an audible beep pattern heard through headphones or speakers plugged into that jack. 

The notification system can take several forms such as: 

 Blinks and Beeps 

 On screen notifications  that include the following: 

○ Popup (toaster) messages 

○ Event Logs 

○ Pre-Boot messages (BIOS) 

○ HP System Information Notices: (modal messages) 

A modal window is a graphical control element subordinate to an application's main window that creates a mode where the 
main window cannot be used. The modal window is a child window that requires users to interact with it before it can return 
to operating the parent application, thus preventing the workflow on the application main window. 

A Toast is a non-modal, unobtrusive window element used to display brief, auto-expiring windows of information to a user. 

https://en.wikipedia.org/wiki/Graphical_control_element_(software)
https://en.wikipedia.org/wiki/Main_window
https://en.wikipedia.org/wiki/Mode_(computer_interface)
https://en.wikipedia.org/wiki/Window_(computing)#Properties
https://en.wikipedia.org/wiki/Tree_(data_structure)#Terminology
https://en.wikipedia.org/wiki/Workflow
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7.2 Blink and Beep Codes 

Some system errors prevent the use of the video screen; instead, the system provides error information through blink 
codes using LED lights. The LED light used depends on the system being a notebook or a desktop. The codes are presented 
in a sequence. For desktop, this means red blinks followed by white blinks. Audible long and short beeps accompany red or 
white blinks, respectively. The table below describes the meaning of critical blink codes. 

Table 27  Computer notifications 

Notebook Desktop Description 

CAP NUM Battery 

LED 

Red 

with 

long 

beeps 

White 

with 

short 

beeps 

2  2 2 The main area (DXE) of BIOS has become corrupted and there is no 

recovery binary image available  

8  2 3 The embedded controller policy requires the user to enter a key 

sequence (SureStart 2.0) 

 White and 

Amber 

blinking 

2 4 The embedded controller is recovering the boot block or DXE. Since it 

takes 10 sec. or so to load the DXE image and get video in the DXE 

case, this blink code is necessary. (SureStart) 

3  3 2 The embedded controller has timed out waiting for BIOS to return 

from memory initialization 

4  3 3 The embedded controller has timed out waiting for BIOS to return 

from graphics initialization 

5  3 4 The system board displays a power failure (crowbar) 

  3 5 The CPU is not being detected 

  3 6 The CPU does not support an enabled feature (typically this applies 

only to TXT) 

7 1 5 2 The embedded controller cannot find valid firmware 
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7.3 Popup Messages 

Onscreen notification can involve popup (toaster) messages. These describe several events involving USB Type C ports. 

Table 28  Popup messages 

Event Code Message Detail 

Power Adapter 

Accepted: Matches 

capabilities to charge 

while in Sx 

1 Title: USB Type-C 

Connector 

Text: "For full 

performance, connect a 

higher capacity power 

adapter." 

A user plugs in a power adapter that is too small to operate 

the system while the device is powered on. The adapter could 

be used to charge in sleep mode or when powered off. 

Power adapter 

rejected: Upstream 

power flow is not 

supported 

2 Title: USB Type-C 

Connector 

Text: “Charging system 

via adapter plugged into 

the USB port is not 

supported.”  

A user plugs in an adapter that requests power in which is not 

supported. (Cypress controller) 

Connected device 

requests more power 

than can be supplied 

3 Title: USB Type-C 

Connector 

Text: “USB device 

requesting more power 

than system can 

provide.” Display system 

charging capability 

A user plugs in a device that requires more power than can be 

provided by the system. 

Balance downstream 

power for charging 

from Multiple USB ports 

4, 5 Title: USB Type-C 

Connector 

Text: “Charging from 

multiple USB ports may 

have limited support.” 

A user has plugged in an adapter to both a USB Type-A port 

and a USB Type-C port (or into 2 USB Type –C ports) and the 

system is not capable of charging both at full capacity while 

system is running. 

The attached dock 

cable is inadequate to 

handle the needed 

power load 

6 Title: USB Connector 

Text: “For full 

performance, connect 

higher capacity USB 

cable to dock.” Display 

capabilities of the cable 

A user plugs a cable connecting the dock to the system that is 

inadequate to power the system and charge the battery 

simultaneously. 

Power adapter 

rejected: Provider and 

consumer mismatch 

7 Title: USB Connector 

Text: “The power adapter 

is not compatible with 

this system.” 

The user has inserted an adapter that is not compatible with 

the HP system (from a 3rd party vendor that is not supported.) 
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8 Appendix 1 

8.1 What is UEFI? 

Unified Extensible Firmware Interface (UEFI) defines the interface between the operating system and platform firmware 
during the boot, or start-up process. Compared to BIOS, UEFI supports advanced pre-boot user interfaces. 

The UEFI network stack enables implementation on a richer network-based OS deployment environment while still 
supporting traditional PXE deployments. UEFI supports both IPv4 and IPv6 networks. In addition, features such as Secure 
Boot enable platform vendors to implement an OS-agnostic approach to securing systems in the pre-boot environment. 

The HP ROM-Based Setup Utility (RBSU) functionality is available from the UEFI interface along with additional configuration 
options. 

8.2 Introduction 

The HP UEFI System Utilities are embedded in the system ROM. The UEFI System Utilities enable a wide range of 
configuration activities, including: 

 Configuring system devices and installed options. 

 Enabling and disabling system features. 

 Displaying system information. 

 Selecting the primary boot controller or partition. 

 Configuring memory options. 

 Launching other pre-boot environments, such as the Embedded UEFI Shell and Intelligent Provisioning. 

8.3 Benefits of UEFI 

 Abstracts Platform from OS and Decouples development 

 Includes modular driver model and CPU-independent option ROMs 

 Modular and extensible and provides OS-Neutral value add 

 OS loader can keep the same as underlying hardware change 

 Supports larger drives over 2TB with GPT partition 

8.4 Overview of UEFI Boot Process 

The purpose of the UEFI interfaces is to define a common boot environment abstraction for use by loaded UEFI images, 
which include UEFI drivers, UEFI applications, and UEFI OS loaders. UEFI allows the extension of platform firmware by 
loading UEFI driver and UEFI application images. When UEFI drivers and UEFI applications are loaded they have access to all 
UEFI-defined runtime and boot services. 

There are two sets of services in UEFI: 

 Boot Services - UEFI applications (including OS loaders) must use boot services functions to access devices and allocate 
memory. These services are not available once the OS is running. 

 Runtime Services - The primary purpose of runtime services is to abstract minor parts of the hardware implementation 
of the platform from the OS. 

These services are present when OS is running. 
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8.5 The UEFI Forum 

For more information contact the Unified Extensible Firmware Interface (UEFI) Forum, it is a world-class non-profit industry 
standards body that works in partnership to enable the evolution of platform technologies. 

The UEFI Forum champions firmware innovation through industry collaboration and the advocacy of a standardized 
interface that simplifies and secures platform initialization and firmware bootstrap operations. Both developed and 
supported by representatives from more than 200 industry-leading technology companies, UEFI specifications promote 
business and technological efficiency, improve performance and security, facilitate interoperability between devices, 
platforms and systems, and comply with next-generation technologies. 
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