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Key Specifications

Spare Parts

Processor Type AMD Athlon 64, Sempron-64, Phenom

RAM Type PC2-6400 (800 MHz) non-ECC

Maximum RAM Supported 8 GB

Expansion Slots • 1 PCIe-x16
• 2 PCIe-x1
• 3 PCI

Graphics Adapter ATI Radeon 3100 graphics

Drive Support • 4 SATA (HDD + Optical)
• RAID 1 Support
• FDD, Media Card Reader, Removable HDD

I/O Interfaces Serial (2, 1 optional), parallel (1), USB 2.0 (8), RJ-45 (1), front 
and rear audio jacks (2 each), PS/2 ports (2), VGA connector 
(1), USB header on system board

System Unit

1 Access panel 461859-001

2 Front bezel 460883-001

3 Power supply, 300W 460879-001

3 Power supply, 300W, 80% efficient 460880-001

* 5.25-inch bezel blank 335937-001

* Not shown

Cables

1 Front I/O with USB 460885-001

2 Power switch/LED cable assembly 460886-001

3 SATA HDD cable, 18 inch, 1 straight end, 1 angled end 393958-001

4 SATA cable, 17 inch, 2 straight ends 453317-001

* SATA cable, 19 inch, 2 straight ends 391739-001

*Not shown

Keyboards (not illustrated)

PS/2, Basic
USB, Basic
USB SmartCard

435302-xxx
435382-xxx
435385-xxx

Arabic -171 Korean (Hangul) -AD1

Belgian -181 LA Spanish -161

BHCSY -B41 Norwegian -091

Brazilian Portuguese -201 PRC -AA1

Czech -221 Portuguese -131

Danish -081 Romanian* -271

Finnish -351 Russian -251

French -051 Slovakian -231

French Arabic -DE1 Spanish -071

French Canadian -121 Swedish -101

German -041 Swiss -111

Greek -151 Taiwanese -AB1

Hebrew -BB1 Thai -281

Hungarian -211 Turkish -141

International -B31 U.S. -001

Italian -061 U.K. -031

Japanese -291

*Not for 435385-xxx 

Mass Storage Devices (not illustrated)

Diskette drive with bezel 431452-001

Media card reader, 5.25-inch 412838-001

16X SATA DVD±RW and CD-RW drive with LightScribe 447310-001

16X SATA DVD-ROM drive 419496-001

48X CD-RW/DVD-ROM combo drive 419497-001

500 GB SATA hard drive, 3.0 Gb/s, NCQ 457909-001

250 GB, 7200-RPM SATA hard drive, 8-MB cache, 3.0 Gb/s, NCQ 449980-001

250 GB, 7200-RPM SATA hard drive, 8-MB cache, 3.0 Gb/s 440747-001

160 GB, 7200-RPM SATA hard drive, 8-MB cache, 3.0 Gb/s 484145-001

160 GB, 7200-RPM SATA hard drive, 8-MB cache, 3.0 Gb/s 440499-001

160 GB, 10000-RPM SATA hard drive, 16-MB cache, 1.5Gb/s 439995-001

80 GB, 7200-RPM SATA hard drive, 8-MB cache, 3 Gb/s, NCQ 484144-001

80 GB, 7200-RPM SATA hard drive, 8-MB cache, 3 Gb/s 440754-001

80 GB, 10000-RPM SATA hard drive, 16-MB cache, 1.5 Gb/s 439994-001
dc5850 Illustrated Parts & Service Map, MT 481406-001 page 1 



System Board

Standard and Optional Boards

1 ReadyBoost module, 1 GB 462851-001

Memory modules

* 512 MB, PC2-6400, CL6 418952-001

* 1 GB, PC2-6400, CL6 418951-001

* 2 GB, PC2-6400, CL6 457624-001

Other boards

* Belkin 802.11a/g, WLAN adapter for use in the rest of the world 391866-002

* nVidia Quadro NVS 290, 256MB, PCI-E graphics adapter 456137-001

* Broadcom NetXtreme GbE PCI-E NIC, FH 430654-001

* 56K modem, Agere 2006 PCI Hi-Speed, FH 398661-001

* nVidia GeForce 8400 GS 256-MB video card with DMS-59 and TV 
(S-Video) outputs,  FH

461450-001

* nVidia GeForce 8400 GS 256-MB video card with DMS-59 and TV 
(S-Video) outputs, LP

445743-001

* HP FireWire IEEE 1394 PCI card, 2 external, 1 internal port, FH 441448-001

System boards with thermal grease, alcohol pad, and CPU socket cover

* System board 461537-001

* System board, excludes ES 462852-001

AMD Athlon 64 processor with alcohol pad and thermal grease

* X2 5400+, 2.8 GHz, 1-MB L2 cache 465312-001

* X2 5200+, 2.7 GHz, 2x512-KB L2 cache 465302-001

* X2 5000+ 2.6 GHz, 2x512-KB L2 cache 465301-001

* X2 4450B, 2.3 GHz, 1-MB L2 cache 465303-001

* LE-1640, 2.6GHz, 1-MB L2 cache 465304-001

AMD Sempron-64 processor with alcohol pad and thermal grease

* 1300, 2.3 GHz, 512-KB L2 cache 458069-001

* 1200, 2.1 GHz, 512-KB L2 cache 460341-001

AMD Phenom processor with alcohol pad and thermal grease

* 9600, quad core, 2.4 GHz, 4x512-KB L2 cache 465459-001

* 8600, tri core, 2.3 GHz, 3x512-KB L2 cache 466174-001

* Not shown

Miscellaneous Parts

1 Second serial port, LP 392414-001

2 Chassis fan 460884-001

3 Fan duct 463721-001

4 Fan duct assy 460882-001

* Heatsink with alcohol pad and factory-applied thermal grease 460897-001

* System board tray 460881-001

* Printer port, LP 465339-001

* Mouse, PS2, optical 417966-001

* Mouse, optical 390938-001

* Mouse, USB laser 459821-001

* Battery, real-time clock 153099-001

* Internal speaker 392413-001

*Not shown
LP = Low profile

System Board Connectors and Jumpers (position of some untitled 
components may vary in location)

E49 Password P23 Front audio

J9 RJ-45 over dual USB P25 ReadyBoost

J10 Quad stack USB P52 Second serial port

J20 PCI slot 1 P53 Serial port connector

J31 PCIe X1, slot 1 P6 Internal speaker

J32 PCIe X1, slot 2 P60 SATA0

J41 PCIe X16 P61 SATA1

J68_1 Mouse P62 SATA2

J68_2 Keyboard P63 SATA3

J69 VGA connector P70 Primary CPU fan

J70 DVI P8 Primary chassis fan

J78 Double stack audio connector P150 Media reader

P1 Main power XBT1 Real-time-clock battery

P16 System fan XMM1 DIMM 1

P126 Parallel connector XMM2 DIMM 2

P24 Front USB XMM4 DIMM 4

P3 CPU power XU1 Processor

P5 Power button/LED
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Setup Utility
Basic system information is maintained in the Setup Utility held in the system ROM, accessed 
by pressing the F10 key when prompted (on screen) during the boot sequence.

Boot Block Emergency Recovery Mode
failure. For example, if a power failure were to occur during a BIOS upgrade, the ROM flash 
would be incomplete. This would render the system BIOS unusable. The Boot Block is a flash-
protected section of the ROM that contains code that checks for a valid system BIOS image 
when the system is turned on.
• If the system BIOS image is valid, the system starts normally.
• If the system BIOS image is not valid, a failsafe Boot Block BIOS provides enough support 

to search removable media for BIOS image files. If an appropriate BIOS image file is found, 
it is automatically flashed into the ROM.

When an invalid system BIOS image is detected, the system power LED will blink red 8 times, 
one blink every second. Simultaneously, the speaker will beep 8 times. If the portion of the 
system ROM containing the video option ROM image is not corrupt, Boot Block Emergency 
Recovery Mode will be displayed on the screen.
To recover the system after it enters Boot Block Emergency Recovery Mode, complete the 
following steps:

1. Turn off the computer.

2. Insert a flash drive or CD containing the BIOS image in the root directory. The media must be 
formatted using the FAT12, FAT16, or FAT32 file system. 

3. Turn on the computer. If no appropriate BIOS image is found, you will be prompted to insert 
media containing a BIOS image file. The system will automatically flash the ROM. After a 
successful flash, the system will either automatically restart or prompt the user to unplug the 
unit, wait 5 seconds, reattach the power cord, and then press the power button. 

4. Remove the removable media used to upgrade the BIOS.

5. Turn the power on to restart the computer.

NOTE: BitLocker prevents Windows Vista from booting when a CD containing the BIOS image 
file is in an optical drive. If BitLocker is enabled, remove this CD before attempting to boot to 
Windows Vista.

Password Security

Establishing a Setup password using computer setup
1. Turn on or restart the computer. If you are in Windows, click Start > Shut Down > Restart.

2. As soon as the computer is turned on, press F10 when the monitor light turns green to enter 
Computer Setup. Press Enter to bypass the title screen, if necessary. If you do not press F10 
when prompted, a restart will be necessary.

3. Select Security > Setup Password and follow the instructions on the screen.

4. Before exiting, click File > Save Changes and Exit. 

Changing a Power-on or Setup password
1. Turn on or restart the computer. If you are in Windows, click Start > Shut Down > Restart.

2. If you want to change the Setup password, as soon as the computer is turned on, press F10 
when the monitor light turns green to enter Computer Setup. Press Enter to bypass the title 
screen, if necessary.

3. If you want to change the Power-On password, when the key icon appears, type your current 
password, a slash (/) or alternate delimiter character, your new password, another slash (/) or 
alternate delimiter character, and your new password again as shown:

current password/new password/new password.

NOTE: Type the new password carefully since the characters do not appear on the screen. 

4. Press Enter.
The new password will take effect the next time the computer is restarted. 

Deleting a Power-on or Setup password
1. Turn on or restart the computer. If you are in Windows, click Start > Shut Down > Restart.

2. To delete the Setup password, as soon as the computer is turned on, press F10 when the 
monitor light turns green to enter Computer Setup. Press Enter to bypass the title screen, if 
necessary.

3. To delete the Power-on password, when the key icon appears, type the current password 
followed by a slash (/) or alternate delimiter character as shown: currentpassword/ 

4. Press Enter. 

Clearing CMOS
1. Turn off the computer and any external devices, and disconnect the power cord from the 

power outlet.

2. Remove the access panel.

3. On the system board, press and hold the CMOS button for 5 seconds. 

4. Replace the access panel, external devices, and reconnect the power cord.

5. Turn on the computer. 

You will receive POST error messages after clearing CMOS and rebooting advising you that 
configuration changes have occurred. Use Computer Setup to reset any special system setups 
along with the date and time.

Computer Setup Menu

Heading Option/Description

File System Information - Lists the following main system specifications:

• Product name
• SKU number (some models)
• Processor type/speed/stepping
• Cache Size (L1/L2)

• Memory size/speed/ no. channels
• Integrated MAC Address
• System BIOS
• Chassis serial number
• Asset tracking number

About - Displays copyright notice.

Set Time and Date - Allows you to set system time and date.

Flash System ROM - Allows you to select a drive containing a new BIOS.

Replicated Setup-Save to Removable Media & Restore from Removable Media

Default Setup 
• Save Current Settings as Default 
• Restore Factory Settings as Default

Apply Defaults and Exit - Applies the selected default settings and clears any 
established passwords.

Ignore Changes and Exit - Exits setup without applying or saving any changes.

Save Changes and Exit - Saves changes to system configuration or default set-
tings and exits Computer Setup.

Storage Device Configuration - Lists all installed BIOS-controlled storage devices. The 
following options are available:
• Diskette Type(Legacy Diskettes only)-3.5” 1.44 MB and 5.25” 1.2 MB
• Emulation Type - ATAPI Zip drive, hard disk, legacy diskette, CD-ROM 

drive, and ATAPI LS-120 drive
• Drive Emulation Type Options
• Multisector Transfers
• Translation Mode
• Translation Parameters
• Default Values SATA

Storage Options: Removable Media Boot, Legacy Diskette Write, SATA Emula-
tion, SATA 0 and 2, SATA 1 and 3

DPS Self-Test - Allows you to execute self-tests on ATA hard drives.

Boot Order - Allows you to specify boot order.
• Shortcut to Temporarily Override Boot Order

Security Setup Password - Allows you to set and enable setup (Administrator) password.

Power-On Password - Allows you to set and enable power-on password.

Password Options - When any password exists allows you to lock legacy 
resources, enable/disable network server mode, specify password requirement 
for warm boot, and allows you to enable/disable Setup Browse Mode.

Device Security (some models) - Enables/disables all I/O ports, audio, network 
controllers, SMBus controller, and embedded security devices.

Network Service Boot - Enables/disables boot from OS on a server.

System IDs - Allows you to set Asset tag, ownership tag, Chassis serial number, 
UUID, and keyboard locale setting.

DriveLock Security-Lets you assign/modify hard drive p/w for added security.

System Security (some models) - Allows you to enable/disable:
• Data Execution Prevention
• Virtualization Technology
• Virtualization Technology Directed I/O
• Trusted Execution Technology
• Embedded Security Device Support
• OS management of Embedded Security Device through OS
• Virtual Appliance options
• Smart Card BIOS Password Support

Setup Security Level - Provides method to allow users limited access to change 
specified setup options without knowing Setup password.

Power OS Power Management - Lets you enable/disable Runtime Power Management, 
Idle Power Savings, ACPI S3 Hard Disk Reset, ACPI S3 PS2 Mouse Wakeup, 
USB Wake on Device Insertion, Unique Sleep State Blink Rates.

Hardware Power Management-Lets you enable/disable SATA bus power mgmt.

Thermal - Allows you to control minimum permitted fan idle speed.

Advanced Power-On Options - Allows you to set:
• POST mode - QuickBoot, FullBoot, or FullBoot every 1-30 days.
• POST messages - Enable/disable
• MEBx Setup prompt - Enable/disable or hidden/displayed
• F9 prompt - Enable/disable
• F10 prompt - Enable/disable 
• F12 prompt - Enable/disable
• Factory Recovery Boot Support - Enable/disable
• Option ROM prompt - Enable/disable
• WOL After Power Loss - Enable/disable
• Remote wakeup boot source - Remote server/local hard drive
• After Power Loss - Off/on/previous state
• POST delay - None, 5, 10, 15, or 20 seconds
• Limit CPUID

Execute Memory Test -Restarts computer and executes POST memory test.

BIOS Power-On - Allows you to set the computer to turn on at a preset time.

Onboard Devices - Lets you set resources or disable onboard system devices.

PCI Devices - Lists installed PCI devices with their IRQ settings and allows you 
to reconfigure IRQ or disable devices.

PCI VGA Configuration - Allows you to specify which VGA controller will be 
used when multiple video adapters are available.

Bus Options (some models) - Allows you to enable/disable PCI SERR# Genera-
tion and PCI VGA palette snooping.

Device Options - Allows you to set:
• Printer Mode - Bi-Directional, EPP & ECP, Output Only
• Num Lock state at power-on - off/on
• S5 Wake on LAN - enable/disable
• Processor cache - enable/disable
• Multi-Processor - enable/disable
• Integrated video - enable/disable
• Internal speaker - enable/disable
• Monitor Tracking - enable/disable
• NIC PXE Option ROM Download - enable/disable
• SATA RAID Option ROM Download - enable/disable
• HPET - enable/disable
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HP Insight Diagnostics
The HP Insight Diagnostics utility allows you to view information about the hardware configu-
ration of the computer and perform hardware diagnostic tests on the subsystems of the com-
puter. The utility simplifies the process of effectively identifying, diagnosing, and isolating 
hardware issues.
The Survey tab is displayed when you invoke HP Insight Diagnostics. This tab shows the cur-
rent configuration of the computer. From the Survey tab, there is access to several categories of 
information about the computer. Other tabs provide additional information, including diagnostic 
test options and test results. The information in each screen of the utility can be saved as an html 
file and stored on a diskette or USB HP flash drive.
Use HP Insight Diagnostics to determine if all the devices installed on the computer are recog-
nized by the system and functioning properly. Running tests is optional but recommended after 
installing or connecting a new device.
You should run tests, save the test results, and print them so that you have printed reports avail-
able before placing a call to the Customer Support Center.
Insight Diagnostics may be found on the Documentation and Diagnostics CD that shipped with 
the computer. The tool may also be downloaded from the HP Web site using the following pro-
cedure:

1. Go to www.hp.com

2. Click the Software & Download driver link.

3. Enter the product number (for example, dc5800) in the text box and press the Enter key.

4. Select the specific product.

5. Select the OS.

6. Click the Diagnostics link.

7. Select HP Insight Diagnostics Offline Edition.

8. Select the proper language and click Download.

NOTE: The download includes instructions on how to create a bootable CD.

Common POST Error Messages

Screen Message Description Recommended Action

101-Option ROM Error 1. System ROM checksum.

2. Expansion board option 
ROM checksum.

1. Verify ROM, reflash if required

2. Remove suspected card, reboot

3. If expansion board recently added, 
remove to see if problem remains.

4. Clear CMOS.

5. If message disappears, may be 
problem with expansion card.

6. Replace system board.

162-System Options 
Not Set

Configuration incorrect.
RTC battery may need to be 
replaced.

Run Computer Setup and check con-
figuration in Advanced > Onboard 
Devices. Reset date and time in Con-
trol Panel. If problem persists, 
replace RTC battery.

163-Time & Date Not 
Set

Invalid time or date in con-
figuration memory.
RTC (real-time clock) bat-
tery may need to be 
replaced.

Reset the date and time under Con-
trol Panel (Computer Setup can also 
be used). If the problem persists, 
replace the RTC battery.

164-Memory Size 
Error

Memory amount has 
changed since the last
boot (memory added or 
removed).

Incorrect memory configu-
ration.

Press the F1 key to save the memory 
changes.

-or-

1. Run Setup (F10).

2. Make sure the memory module(s) 
are installed properly.

3. If third-party memory has been 
added, test using HP-only 
memory.

4. Verify proper memory module 
type.

201-Memory Error RAM failure. 1. Run Setup (F10).

2. Ensure memory modules are 
correctly installed.

3. Verify proper memory module 
type.

4. Remove and replace the identified 
faulty memory module(s).

5. If the error persists after replacing 
memory modules, replace the 
system board.

213-Incompatible 
Memory Module in 
Memory Socket(s) X, 
X, ...

A memory module in mem-
ory socket identified in the 
error message is missing 
critical SPD information, or 
is incompatible with the 
chipset.

1. Verify proper memory module 
type.

2. Try another memory socket.

3. Replace DIMM with a module 
conforming to the SPD standard.

214-DIMM Configura-
tion Warning

Populated DIMM configura-
tion is not optimized.

Rearrange the DIMMs so that each 
channel has the same amount of 
memory.

215-DIMM Configura-
tion Warning

Populated DIMM configura-
tion is not optimized.

Remove power from the system and 
reinstall memory modules. Populate 
modules starting with slot XMM4, 
then XMM3, followed by slots 
XMM2 and XMM1.

219-ECC Memory 
Module Detected ECC
Modules not supported 
on this Platform

Recently added memory 
module(s) support ECC 
memory error correction.

1. If additional memory was recently 
added, remove it to see if the 
problem remains.

2. Check product documentation for 
memory support information.

301, 304-Keyboard 
error

Keyboard failure. 1. Reconnect keyboard with 
computer turned off.

2. Check connector for bent of 
missing pins.

3. Ensure that none of the keys are 
depressed.

4. Replace keyboard.

5. If 304 possible system board 
issue.

Common POST Error Messages (continued)

Screen Message Description Recommended Action

501-Display Adapter 
Failure

Graphics display controller. 1. Reseat graphics card.

2. Clear CMOS.

3. Check monitor connection.

4. Replace graphics card (if 
possible).

510-Flash Screen 
Image Corrupted

Flash Screen image has 
errors.

Reflash the system ROM with the 
latest BIOS image.

511-CPU, CPUA, or 
CPUB Fan not 
Detected

CPU fan is not connected or 
may have malfunctioned.

1. Reseat CPU fan.

2. Reseat fan cable.

3. Replace CPU fan.

512-Chassis, Rear 
Chassis, or Front Chas-
sis Fan not Detected

Chassis, rear chassis, or 
front chassis fan is not con-
nected or may have mal-
functioned.

1. Reseat chassis, rear chassis, or 
front chassis fan.

2. Reseat fan cable.

3. Replace chassis, rear chassis, or 
front chassis fan.

601-Diskette Control-
ler Error

Diskette controller circuitry 
or floppy drive circuitry 
incorrect.

1. Run Computer Setup.

2. Check and/or replace cables.

3. Clear CMOS.

4.  Replace diskette drive.

5.  Replace the system board.

605-Diskette Drive 
Type Error

Mismatch in drive type. 1. Run Computer Setup.

2. Disconnect any other diskette 
controller devices (tape drives).

3. Clear CMOS.

917-Front Audio Not 
Connected

Front audio harness has 
been detached or unseated 
from motherboard.

Reconnect or replace front audio 
harness.

918-Front USB Not 
Connected

Front USB harness has been 
detached or
unseated from motherboard.

Reconnect or replace front USB har-
ness.

921-Device in PCI 
Express slot failed to 
initialize

There is an incompatibility/
problem with this device and 
the system or PCI Express 
Link could not be retrained 
to an x1.

Try rebooting the system. If the error 
reoccurs, the device may not work 
with this system

1720-SMART Hard 
Drive Detects Immi-
nent Failure

Hard drive is about to fail. 
(Some hard drives have a 
hard drive firmware patch 
that will fix an erroneous 
error message.)

1. Determine if hard drive is giving 
correct error message. Enter 
Computer Setup and run the Drive 
Protection System test under 
Storage > DPS Self-test.

2. Apply hard drive firmware patch 
if applicable.

3. Back up contents and replace hard 
drive.

1796-SATA Cabling 
Error

One or more SATA devices 
are improperly attached. For 
optimal performance, the 
SATA 0 and SATA 1 con-
nectors must be used before
SATA 4 and SATA 5.

Ensure SATA connectors are used in 
ascending order. For one device, use 
SATA 0. For two devices, use SATA 
0 and SATA 1. For three devices, use 
SATA 0, SATA1, and SATA 4.

1797-SATA Drivelock 
is not supported in 
RAID mode.

Drivelock is enabled on one 
or more SATA hard drives, 
and they cannot be accessed 
while the system is config-
ured for RAID mode.

Either remove the Drivelocked 
SATA device or disable the Drive-
lock feature. To disable the Drive-
lock feature, enter Computer Setup,
change Storage > Storage Options 
> SATA Emulation to IDE, and 
select File > Save Changes and 
Exit. Re-enter Computer Setup and 
select Security > Drivelock. For 
each listed Drivelock-capable SATA 
device, ensure Drivelock is Disabled. 
Lastly, change Storage > Storage 
Options > SATA Emulation back to 
RAID and select File > Save 
Changes and Exit.

1801-Microcode Patch 
Error

Processor not supported by 
ROM BIOS.

1. Upgrade BIOS to proper version.

2. Change the processor.

Invalid Electronic 
Serial Number

Electronic serial number is 
missing.

Enter the correct serial number in 
Computer Setup.

Memory Parity Error Parity RAM failure.
Third-party graphics card 
may be causing a problem.

Run Computer Setup and Diagnostic 
utilities. Remove third-party graph-
ics card to see if the problem goes 
away.

Network Server Mode 
Active and No Key-
board Attached

Keyboard failure while Net-
work Server Mode enabled.

1. Reconnect keyboard with 
computer turned off.

2. Check connector for bent or 
missing pins.

3. Ensure that none of the keys are 
depressed.

4. Replace keyboard.

Parity Check 2 Parity RAM failure.
Third-party graphics card 
may be causing a problem.

Run Computer Setup and Diagnostic 
utilities. Remove third-party graph-
ics card to see if problem goes away.
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